aboutsummaryrefslogtreecommitdiff
path: root/games/lincity-ng/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-07-21 21:02:45 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-07-21 21:02:45 +0000
commit6c2c0c83aceafb09a4ecddcbbaf7a64499e00476 (patch)
tree95f52611694720168e3e52e68e3469aa239fbe13 /games/lincity-ng/Makefile
parentd8fc136e9d354f01711723e3155e756148805f5f (diff)
downloadports-6c2c0c83aceafb09a4ecddcbbaf7a64499e00476.tar.gz
ports-6c2c0c83aceafb09a4ecddcbbaf7a64499e00476.zip
Notes
Diffstat (limited to 'games/lincity-ng/Makefile')
-rw-r--r--games/lincity-ng/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
new file mode 100644
index 000000000000..05459abb2faa
--- /dev/null
+++ b/games/lincity-ng/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: lincity-ng
+# Date created: 25 June 2005
+# Whom: Andrej Zverev
+#
+# $FreeBSD$
+#
+
+PORTNAME= lincity-ng
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://download.berlios.de/lincity-ng/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= az@inec.ru
+COMMENT= Improved rich city simulation game for X
+
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+LIB_DEPENDS= physfs-1.0.0:${PORTSDIR}/devel/physfs
+
+USE_BZIP2= yes
+USE_GCC= 3.2+
+USE_SDL= sdl mixer image ttf gfx
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libphysfs=${PREFIX}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on 4.x"
+.endif
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} jam)
+
+do-install:
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} jam ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>