aboutsummaryrefslogtreecommitdiff
path: root/games/lincity-ng
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-17 14:57:03 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-17 14:57:03 +0000
commitda2ce8780ff1f8de9433f9c0b29f4b9bec635233 (patch)
treeadeaf30f0b54e5aa47415d8dd5824018e5951f75 /games/lincity-ng
parent634628a4293b08e51d9c23a5e2e06693226216da (diff)
downloadports-da2ce8780ff1f8de9433f9c0b29f4b9bec635233.tar.gz
ports-da2ce8780ff1f8de9433f9c0b29f4b9bec635233.zip
Notes
Diffstat (limited to 'games/lincity-ng')
-rw-r--r--games/lincity-ng/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index 706396f541a1..a1d37397a4e9 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Improved rich city simulation game for X
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
-LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs
+LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs
USES= pkgconfig
USE_BZIP2= yes
@@ -26,14 +26,13 @@ CONFIGURE_ARGS= --with-libphysfs=${PREFIX} \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's| -O| -I${LOCALBASE}/include&|g' \
${WRKSRC}/Jamrules
do-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} jam)
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} jam -j${MAKE_JOBS_NUMBER})
do-install:
- @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} jam ${INSTALL_TARGET})
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} jam -sprefix=${STAGEDIR}${PREFIX} ${INSTALL_TARGET})
.include <bsd.port.mk>