aboutsummaryrefslogtreecommitdiff
path: root/games/lincity/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-21 17:44:51 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-21 17:44:51 +0000
commitb6f16b3151df7d170fd491a0beb20f0bbd614cd4 (patch)
treefc5f96530a706cd8466084ba375517f61a7680f7 /games/lincity/Makefile
parent30480c3a02c3cf372a3a1920a5352aee12eb300b (diff)
downloadports-b6f16b3151df7d170fd491a0beb20f0bbd614cd4.tar.gz
ports-b6f16b3151df7d170fd491a0beb20f0bbd614cd4.zip
Notes
Diffstat (limited to 'games/lincity/Makefile')
-rw-r--r--games/lincity/Makefile26
1 files changed, 20 insertions, 6 deletions
diff --git a/games/lincity/Makefile b/games/lincity/Makefile
index ad6591039dc2..4778639dec01 100644
--- a/games/lincity/Makefile
+++ b/games/lincity/Makefile
@@ -6,18 +6,32 @@
#
PORTNAME= lincity
-PORTVERSION= 1.11
-PORTREVISION= 1
+PORTVERSION= 1.12.0
CATEGORIES= games
-MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/linux/games/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Rich city simulation game for X
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-USE_XLIB= yes
-ALL_TARGET= freebsd
MAN6= lincity.6
+.if defined(WITH_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+CONFIGURE_ARGS+= --without-x
+PLIST_SUB= PROG="bin/lincity"
+.else
+USE_XLIB= yes
+CONFIGURE_ARGS+= --without-svga
+PLIST_SUB= PROG="bin/xlincity"
+.endif
+
.include <bsd.port.mk>