aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-etpro
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-11 17:43:44 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-11 17:43:44 +0000
commit8a08a108340fb7751b60f3053a289efe56c14ea1 (patch)
treed7bbacd99bb1bd2966f1ce4b5ccafeb96f173148 /games/linux-enemyterritory-etpro
parent2915abb3bbbd2bbb979fa26e5f0b1bb5411a777c (diff)
Notes
Diffstat (limited to 'games/linux-enemyterritory-etpro')
-rw-r--r--games/linux-enemyterritory-etpro/Makefile50
-rw-r--r--games/linux-enemyterritory-etpro/distinfo3
-rw-r--r--games/linux-enemyterritory-etpro/pkg-descr9
-rw-r--r--games/linux-enemyterritory-etpro/pkg-plist32
4 files changed, 94 insertions, 0 deletions
diff --git a/games/linux-enemyterritory-etpro/Makefile b/games/linux-enemyterritory-etpro/Makefile
new file mode 100644
index 000000000000..47c1a6d42c17
--- /dev/null
+++ b/games/linux-enemyterritory-etpro/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: etpro
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= etpro
+PORTVERSION= 3.2.5
+CATEGORIES= games linux
+MASTER_SITES= http://bani.anime.net/etpro/ \
+ http://dl.vpclan.de/etpro/ \
+ http://www.enemyterritory.sk/files/ \
+ ftp://download:etpro@preachers.cz/ \
+ http://ftp.freenet.de/pub/4players/hosted/wolfenstein/users/mods/ \
+ http://www.dakteam.org/ \
+ http://www.enemyterritory.cl/files/
+PKGNAMEPREFIX= linux-enemyterritory-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= ET Pro - The Enemy Territory Competition Mod
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_LINUX= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
+
+PLIST_SUB= VERSION="${PORTVERSION:S/./_/g}"
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/${PORTNAME}/* ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-etpro/distinfo b/games/linux-enemyterritory-etpro/distinfo
new file mode 100644
index 000000000000..79ed01d0daa4
--- /dev/null
+++ b/games/linux-enemyterritory-etpro/distinfo
@@ -0,0 +1,3 @@
+MD5 (etpro-3_2_5.zip) = 5b00b6a10772151ed16833ec649b07e5
+SHA256 (etpro-3_2_5.zip) = 5bd3eeb0aa130d56592b675079db50eba4952e225f0350ddff2be4dbd1a9331a
+SIZE (etpro-3_2_5.zip) = 3693471
diff --git a/games/linux-enemyterritory-etpro/pkg-descr b/games/linux-enemyterritory-etpro/pkg-descr
new file mode 100644
index 000000000000..13bc3dc00963
--- /dev/null
+++ b/games/linux-enemyterritory-etpro/pkg-descr
@@ -0,0 +1,9 @@
+ET Pro is a mod specifically targeted at competition play, with features
+specifically designed for administration of competition servers.
+
+ET Pro has been chosen as the official tournament mod for STA, TWL, CAL,
+Clanbase, and ESL.
+
+The official IRC channel for ET Pro is #etpro on irc.freenode.net
+
+WWW: http://etpro.anime.net/
diff --git a/games/linux-enemyterritory-etpro/pkg-plist b/games/linux-enemyterritory-etpro/pkg-plist
new file mode 100644
index 000000000000..92ce1a49b7ce
--- /dev/null
+++ b/games/linux-enemyterritory-etpro/pkg-plist
@@ -0,0 +1,32 @@
+bin/et-etpro
+bin/etded-etpro
+%%DATADIR%%/animations/scripts/human_base.script
+%%DATADIR%%/etpro-%%VERSION%%.pk3
+%%DATADIR%%/etpro_cheats.dat
+%%DATADIR%%/etpromapscripts/battery.script
+%%DATADIR%%/etpromapscripts/fueldump.script
+%%DATADIR%%/etpromapscripts/fueldump_lms.script
+%%DATADIR%%/etpromapscripts/goldrush.script
+%%DATADIR%%/etpromapscripts/oasis.script
+%%DATADIR%%/etpromapscripts/oasis_lms.script
+%%DATADIR%%/etpromapscripts/radar.script
+%%DATADIR%%/etpromapscripts/railgun.script
+%%DATADIR%%/etpromapscripts/railgun_lms.script
+%%DATADIR%%/example.cfg
+%%DATADIR%%/maps/battery.script
+%%DATADIR%%/maps/fueldump.script
+%%DATADIR%%/maps/fueldump_lms.script
+%%DATADIR%%/maps/goldrush.script
+%%DATADIR%%/maps/oasis.script
+%%DATADIR%%/maps/oasis_lms.script
+%%DATADIR%%/maps/radar.script
+%%DATADIR%%/maps/railgun.script
+%%DATADIR%%/maps/railgun_lms.script
+%%DATADIR%%/qagame.mp.i386.so
+%%DATADIR%%/qagame_mp_x86.dll
+@dirrm %%DATADIR%%/maps
+@dirrm %%DATADIR%%/etpromapscripts
+@dirrm %%DATADIR%%/configs
+@dirrm %%DATADIR%%/animations/scripts
+@dirrm %%DATADIR%%/animations
+@dirrm %%DATADIR%%