aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-jaymod-21
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-01-24 21:26:40 +0000
committerRene Ladan <rene@FreeBSD.org>2012-01-24 21:26:40 +0000
commit743a5b1728e5c3614590b1d98e6536bae5d081c5 (patch)
tree717478e9ef3e05af27a0294893ce7232f54b58ca /games/linux-enemyterritory-jaymod-21
parent21cd1819a0cd36b6b719c0eb283deb3ee14592cb (diff)
downloadports-743a5b1728e5c3614590b1d98e6536bae5d081c5.tar.gz
ports-743a5b1728e5c3614590b1d98e6536bae5d081c5.zip
Notes
Diffstat (limited to 'games/linux-enemyterritory-jaymod-21')
-rw-r--r--games/linux-enemyterritory-jaymod-21/Makefile21
-rw-r--r--games/linux-enemyterritory-jaymod-21/pkg-plist4
2 files changed, 15 insertions, 10 deletions
diff --git a/games/linux-enemyterritory-jaymod-21/Makefile b/games/linux-enemyterritory-jaymod-21/Makefile
index 5a3b6e2f9c65..4f8f116fe0c6 100644
--- a/games/linux-enemyterritory-jaymod-21/Makefile
+++ b/games/linux-enemyterritory-jaymod-21/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jaymod
PORTVERSION= 2.1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games linux
MASTER_SITES= http://etmod.googlecode.com/files/ \
http://www.zenenterprises.biz/bud/jaymod/ \
@@ -20,32 +20,37 @@ COMMENT= Jaymod - An Enemy Territory Modification
RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+VERSTR= ${PORTVERSION:C/([0-9])\.([0-9])\.([0-9]+)/\1\2\3/}
+PKGNAMESUFFIX= -${VERSTR}
+PLIST_SUB= VERSTR="${VERSTR}"
+
USE_LINUX= yes
OPTIONS= OMNIBOT "Install Omni-Bot for bot support" off
-DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}-${VERSTR}
+DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}-${VERSTR}
CLIENT_PK3= ${PORTNAME}-${PORTVERSION}.pk3
-PLIST_SUB= CLIENT_PK3="${CLIENT_PK3}"
+PLIST_SUB+= CLIENT_PK3="${CLIENT_PK3}"
.include <bsd.port.pre.mk>
.if defined(WITH_OMNIBOT)
-RUN_DEPENDS+= et-omni-bot:${PORTSDIR}/games/linux-enemyterritory-omni-bot-0660
+OB_VERSTR= 0660
+RUN_DEPENDS+= et-omni-bot-${OB_VERSTR}:${PORTSDIR}/games/linux-enemyterritory-omni-bot-${OB_VERSTR}
.endif
do-build:
.for f in et etded
@(${ECHO_CMD} "#!/bin/sh"; \
- ${ECHO_CMD} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} +set omnibot_path "${DATADIR}/../omni-bot" "$$@"') > \
- ${WRKSRC}/${f}-${PORTNAME}
+ ${ECHO_CMD} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME}-${VERSTR} +set omnibot_path "${DATADIR}/../omni-bot-${OB_VERSTR}" "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}-${VERSTR}
.endfor
do-install:
.for f in et etded
- ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME}-${VERSTR} ${PREFIX}/bin
.endfor
${MKDIR} ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
diff --git a/games/linux-enemyterritory-jaymod-21/pkg-plist b/games/linux-enemyterritory-jaymod-21/pkg-plist
index 24da152cd408..6cafea9af8d2 100644
--- a/games/linux-enemyterritory-jaymod-21/pkg-plist
+++ b/games/linux-enemyterritory-jaymod-21/pkg-plist
@@ -1,5 +1,5 @@
-bin/et-jaymod
-bin/etded-jaymod
+bin/et-jaymod-%%VERSTR%%
+bin/etded-jaymod-%%VERSTR%%
%%DATADIR%%/jaymod.cfg
%%DATADIR%%/%%CLIENT_PK3%%
%%DATADIR%%/linux/convert_shrub