aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-jaymod
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-19 20:53:09 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-19 20:53:09 +0000
commit3214cd81503c4840419f62afaa07d2f15acf9a3f (patch)
tree7503b7a6bf8481d1fdf300d34663608351bcb82c /games/linux-enemyterritory-jaymod
parent2d83162aba76fe20ae501ce9d93e90dac2d02f2e (diff)
downloadports-3214cd81503c4840419f62afaa07d2f15acf9a3f.tar.gz
ports-3214cd81503c4840419f62afaa07d2f15acf9a3f.zip
Notes
Diffstat (limited to 'games/linux-enemyterritory-jaymod')
-rw-r--r--games/linux-enemyterritory-jaymod/Makefile30
-rw-r--r--games/linux-enemyterritory-jaymod/distinfo6
-rw-r--r--games/linux-enemyterritory-jaymod/pkg-plist19
3 files changed, 45 insertions, 10 deletions
diff --git a/games/linux-enemyterritory-jaymod/Makefile b/games/linux-enemyterritory-jaymod/Makefile
index b6f5fe9a5474..a4886be678ca 100644
--- a/games/linux-enemyterritory-jaymod/Makefile
+++ b/games/linux-enemyterritory-jaymod/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= jaymod
-PORTVERSION= 2.0.6
+PORTVERSION= 2.1.7
CATEGORIES= games linux
MASTER_SITES= http://jaymod.clanfu.org/lib/downloads/ \
http://budjb.com/lib/downloads/ \
http://www.zenenterprises.org/bud/jaymod/ \
http://www.spherens.com/zen/et/distro/
PKGNAMEPREFIX= linux-enemyterritory-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-linux
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Jaymod - An Enemy Territory Modification
@@ -22,13 +21,24 @@ RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
USE_LINUX= yes
+OPTIONS= OMNIBOT "Install Omni-Bot for bot support" off
+
DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+CLIENT_PK3= ${PORTNAME}-${PORTVERSION}.pk3
+PLIST_SUB= CLIENT_PK3="${CLIENT_PK3}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OMNIBOT)
+RUN_DEPENDS+= et-omni-bot:${PORTSDIR}/games/linux-enemyterritory-omni-bot
+.endif
+
do-build:
.for f in et etded
- @(${ECHO} "#!/bin/sh"; \
- ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ @(${ECHO_CMD} "#!/bin/sh"; \
+ ${ECHO_CMD} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} +set omnibot_path "${DATADIR}/omni-bot" "$$@"') > \
${WRKSRC}/${f}-${PORTNAME}
.endfor
@@ -37,6 +47,12 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
.endfor
${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/pentium4/qagame.mp.i386.so ${DATADIR}
-
-.include <bsd.port.mk>
+ ${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${CLIENT_PK3} *.cfg ${DATADIR}
+ ${CP} -r ${WRKSRC}/linux ${WRKSRC}/mapscripts ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README.txt doc/jaymod.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-enemyterritory-jaymod/distinfo b/games/linux-enemyterritory-jaymod/distinfo
index 73ebbcc532e6..7571a58f83cd 100644
--- a/games/linux-enemyterritory-jaymod/distinfo
+++ b/games/linux-enemyterritory-jaymod/distinfo
@@ -1,3 +1,3 @@
-MD5 (jaymod-2.0.6-linux.tar.gz) = 3388cc9843067727a714a3ef9e2595d6
-SHA256 (jaymod-2.0.6-linux.tar.gz) = 4ec033e622b82bc67c4d00227b36cf63902959e13ed48f32a037a796515f5bc9
-SIZE (jaymod-2.0.6-linux.tar.gz) = 2396212
+MD5 (jaymod-2.1.7.tar.gz) = 422eec802d4bded0b89908ca38c00434
+SHA256 (jaymod-2.1.7.tar.gz) = f9341236f351765826e00c5905ede9f485dbf2a57c556d2959b925a4a4aa8948
+SIZE (jaymod-2.1.7.tar.gz) = 11926903
diff --git a/games/linux-enemyterritory-jaymod/pkg-plist b/games/linux-enemyterritory-jaymod/pkg-plist
index e09e9e26d125..24da152cd408 100644
--- a/games/linux-enemyterritory-jaymod/pkg-plist
+++ b/games/linux-enemyterritory-jaymod/pkg-plist
@@ -1,4 +1,23 @@
bin/et-jaymod
bin/etded-jaymod
+%%DATADIR%%/jaymod.cfg
+%%DATADIR%%/%%CLIENT_PK3%%
+%%DATADIR%%/linux/convert_shrub
+%%DATADIR%%/linux/serverctl
+%%DATADIR%%/mapscripts/battery.script
+%%DATADIR%%/mapscripts/fueldump.script
+%%DATADIR%%/mapscripts/fueldump_lms.script
+%%DATADIR%%/mapscripts/goldrush.script
+%%DATADIR%%/mapscripts/oasis.script
+%%DATADIR%%/mapscripts/oasis_lms.script
+%%DATADIR%%/mapscripts/radar.script
+%%DATADIR%%/mapscripts/railgun.script
+%%DATADIR%%/mapscripts/railgun_lms.script
%%DATADIR%%/qagame.mp.i386.so
+%%DATADIR%%/server.cfg
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/jaymod.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/mapscripts
+@dirrm %%DATADIR%%/linux
@dirrm %%DATADIR%%