aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-jaymod
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-01-24 21:34:49 +0000
committerRene Ladan <rene@FreeBSD.org>2012-01-24 21:34:49 +0000
commitd70f1057d511f30fcd4e634be72478411c2607c7 (patch)
tree48e12617decdc32619e2028f17b66382be00c644 /games/linux-enemyterritory-jaymod
parent1fb10fbbaf51e70146fe05a21c290a13247f42e6 (diff)
downloadports-d70f1057d511f30fcd4e634be72478411c2607c7.tar.gz
ports-d70f1057d511f30fcd4e634be72478411c2607c7.zip
Notes
Diffstat (limited to 'games/linux-enemyterritory-jaymod')
-rw-r--r--games/linux-enemyterritory-jaymod/Makefile24
-rw-r--r--games/linux-enemyterritory-jaymod/distinfo4
-rw-r--r--games/linux-enemyterritory-jaymod/pkg-plist10
3 files changed, 25 insertions, 13 deletions
diff --git a/games/linux-enemyterritory-jaymod/Makefile b/games/linux-enemyterritory-jaymod/Makefile
index 5a3b6e2f9c65..0b954758b094 100644
--- a/games/linux-enemyterritory-jaymod/Makefile
+++ b/games/linux-enemyterritory-jaymod/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= jaymod
-PORTVERSION= 2.1.7
-PORTREVISION= 2
+PORTVERSION= 2.2.0
CATEGORIES= games linux
-MASTER_SITES= http://etmod.googlecode.com/files/ \
- http://www.zenenterprises.biz/bud/jaymod/ \
- http://bud.zenenterprises.biz/jaymod/ \
- http://et.lsdfunweb.fr/et/jaymod/
+MASTER_SITES= http://jaymod.clanfu.org/lib/downloads/ \
+ http://www.zenenterprises.biz/bud/jaymod/
PKGNAMEPREFIX= linux-enemyterritory-
MAINTAINER= barbara.xxx1975@libero.it
@@ -33,7 +30,7 @@ PLIST_SUB= CLIENT_PK3="${CLIENT_PK3}"
.include <bsd.port.pre.mk>
.if defined(WITH_OMNIBOT)
-RUN_DEPENDS+= et-omni-bot:${PORTSDIR}/games/linux-enemyterritory-omni-bot-0660
+RUN_DEPENDS+= et-omni-bot:${PORTSDIR}/games/linux-enemyterritory-omni-bot
.endif
do-build:
@@ -49,11 +46,22 @@ do-install:
.endfor
${MKDIR} ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${CLIENT_PK3} *.cfg ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${CLIENT_PK3} ${DATADIR}
+.for f in jaymod.cfg server.cfg
+ ${CP} -p ${WRKSRC}/${f} ${DATADIR}/${f}.sample
+.endfor
${CP} -r ${WRKSRC}/linux ${WRKSRC}/mapscripts ${DATADIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} README.txt doc/jaymod.pdf ${DOCSDIR}
.endif
+post-install:
+ @if [ ! -f ${DATADIR}/jaymod.cfg ]; then \
+ ${CP} -p ${DATADIR}/jaymod.cfg.sample ${DATADIR}/jaymod.cfg ; \
+ fi
+ @if [ ! -f ${DATADIR}/server.cfg ]; then \
+ ${CP} -p ${DATADIR}/server.cfg.sample ${DATADIR}/server.cfg ; \
+ fi
+
.include <bsd.port.post.mk>
diff --git a/games/linux-enemyterritory-jaymod/distinfo b/games/linux-enemyterritory-jaymod/distinfo
index 8be3bd6798ac..6303cb4b9c7d 100644
--- a/games/linux-enemyterritory-jaymod/distinfo
+++ b/games/linux-enemyterritory-jaymod/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jaymod-2.1.7.tar.gz) = f9341236f351765826e00c5905ede9f485dbf2a57c556d2959b925a4a4aa8948
-SIZE (jaymod-2.1.7.tar.gz) = 11926903
+SHA256 (jaymod-2.2.0.tar.gz) = b6e7fa62762ec9dfe4cd890f2265ad5e380c9aa134615eb23a64a05d237122ff
+SIZE (jaymod-2.2.0.tar.gz) = 11898043
diff --git a/games/linux-enemyterritory-jaymod/pkg-plist b/games/linux-enemyterritory-jaymod/pkg-plist
index 24da152cd408..a769fc6fb791 100644
--- a/games/linux-enemyterritory-jaymod/pkg-plist
+++ b/games/linux-enemyterritory-jaymod/pkg-plist
@@ -1,6 +1,8 @@
bin/et-jaymod
bin/etded-jaymod
-%%DATADIR%%/jaymod.cfg
+@unexec if cmp %D/lib/enemyterritory/jaymod/jaymod.cfg %D/lib/enemyterritory/jaymod/jaymod.cfg.sample; then rm -f %D/lib/enemyterritory/jaymod/jaymod.cfg; fi
+%%DATADIR%%/jaymod.cfg.sample
+@exec if [ ! -f %D/lib/enemyterritory/jaymod/jaymod.cfg ] ; then cp -p %D/lib/enemyterritory/jaymod/jaymod.cfg.sample %D/lib/enemyterritory/jaymod/jaymod.cfg; fi
%%DATADIR%%/%%CLIENT_PK3%%
%%DATADIR%%/linux/convert_shrub
%%DATADIR%%/linux/serverctl
@@ -14,10 +16,12 @@ bin/etded-jaymod
%%DATADIR%%/mapscripts/railgun.script
%%DATADIR%%/mapscripts/railgun_lms.script
%%DATADIR%%/qagame.mp.i386.so
-%%DATADIR%%/server.cfg
+@unexec if cmp %D/lib/enemyterritory/jaymod/server.cfg %D/lib/enemyterritory/jaymod/server.cfg.sample; then rm -f %D/lib/enemyterritory/jaymod/server.cfg; fi
+%%DATADIR%%/server.cfg.sample
+@exec if [ ! -f %D/lib/enemyterritory/jaymod/server.cfg ] ; then cp -p %D/lib/enemyterritory/jaymod/server.cfg.sample %D/lib/enemyterritory/jaymod/server.cfg; fi
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/jaymod.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/mapscripts
@dirrm %%DATADIR%%/linux
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%% \ No newline at end of file