aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-shrub
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-05-11 18:53:55 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-05-11 18:53:55 +0000
commit673e3d9a2d46339cb119ca0853bfbd42bf1213cf (patch)
tree6ad3ae9ea4a87c6bdd9c03fbc431ccf80a5f4fd0 /games/linux-enemyterritory-shrub
parent6e54f5a09b3d311ab2021584fb751975881aefa5 (diff)
downloadports-673e3d9a2d46339cb119ca0853bfbd42bf1213cf.tar.gz
ports-673e3d9a2d46339cb119ca0853bfbd42bf1213cf.zip
Notes
Diffstat (limited to 'games/linux-enemyterritory-shrub')
-rw-r--r--games/linux-enemyterritory-shrub/Makefile47
-rw-r--r--games/linux-enemyterritory-shrub/distinfo3
-rw-r--r--games/linux-enemyterritory-shrub/pkg-descr3
3 files changed, 53 insertions, 0 deletions
diff --git a/games/linux-enemyterritory-shrub/Makefile b/games/linux-enemyterritory-shrub/Makefile
new file mode 100644
index 000000000000..3ee535d83753
--- /dev/null
+++ b/games/linux-enemyterritory-shrub/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: shrub
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= shrub
+PORTVERSION= 1.2
+CATEGORIES= games linux
+MASTER_SITES= http://www.etstats.com/shrubet/downloads/
+PKGNAMEPREFIX= linux-enemyterritory-
+DISTNAME= 1.2-test13-l
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Shrub - An Enemy Territory Modification
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_LINUX= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
+
+PLIST_FILES= bin/et-${PORTNAME} \
+ bin/etded-${PORTNAME} \
+ %%DATADIR%%/qagame.mp.i386.so
+PLIST_DIRS= %%DATADIR%%
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-shrub/distinfo b/games/linux-enemyterritory-shrub/distinfo
new file mode 100644
index 000000000000..7801a13c6bad
--- /dev/null
+++ b/games/linux-enemyterritory-shrub/distinfo
@@ -0,0 +1,3 @@
+MD5 (1.2-test13-l.zip) = b8aa344e128070d1b5174ee7e2b1d3d4
+SHA256 (1.2-test13-l.zip) = d90d0dbf364d2fffd85ca265d7189f5c9e03035961892309f6445f5fe9cb69fa
+SIZE (1.2-test13-l.zip) = 567743
diff --git a/games/linux-enemyterritory-shrub/pkg-descr b/games/linux-enemyterritory-shrub/pkg-descr
new file mode 100644
index 000000000000..1addee5d1f19
--- /dev/null
+++ b/games/linux-enemyterritory-shrub/pkg-descr
@@ -0,0 +1,3 @@
+The shrub mod is a server-side mod for Wolfenstein: Enemy Territory.
+
+WWW: http://www.planetwolfenstein.com/shrub/