aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-tce
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-14 20:22:14 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-14 20:22:14 +0000
commit88b7c33544812584e6e55286b6d070e795870370 (patch)
treed534d2c5cc665e0ced56b110d82bd10c3f5ce3e8 /games/linux-enemyterritory-tce
parentc002530ceca5fd5270e858111e0e8b1255b12911 (diff)
downloadports-88b7c33544812584e6e55286b6d070e795870370.tar.gz
ports-88b7c33544812584e6e55286b6d070e795870370.zip
Notes
Diffstat (limited to 'games/linux-enemyterritory-tce')
-rw-r--r--games/linux-enemyterritory-tce/Makefile62
-rw-r--r--games/linux-enemyterritory-tce/distinfo4
-rw-r--r--games/linux-enemyterritory-tce/pkg-descr24
-rw-r--r--games/linux-enemyterritory-tce/pkg-plist19
4 files changed, 109 insertions, 0 deletions
diff --git a/games/linux-enemyterritory-tce/Makefile b/games/linux-enemyterritory-tce/Makefile
new file mode 100644
index 000000000000..8af31e8ea700
--- /dev/null
+++ b/games/linux-enemyterritory-tce/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: Enemy Territory TrueCombat:Elite
+# Date created: 25 Mar 2005
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= enemyterritory-tce
+PORTVERSION= 0.48
+CATEGORIES= games linux
+MASTER_SITES= http://ftp.games.skynet.be/pub/www.filesnetwork.com/Wolfenstein_Enemy_Territory/Mods/Total_Conversions/:full \
+ http://ftp.games.skynet.be/pub/www.filesnetwork.com/Wolfenstein_Enemy_Territory/Mods/Total_Conversions/:update \
+ http://darkstar.ist.utl.pt/pub/games/:full \
+ http://darkstar.ist.utl.pt/pub/games/:update \
+ http://ftp.wireplay.co.uk/pub/enemyterritory/mods/tcelite/Linux/:full \
+ http://et2.migamer.com/:full \
+ http://jogos.bragatel.pt/downloads/et/tcE/linux/:update
+PKGNAMEPREFIX= linux-
+DISTNAME= tcetest
+DISTFILES= tcetest_0209_full.zip:full \
+ tcetest_0.48_update.zip:update
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A modern tactical Enemy Territory modification
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_ZIP= yes
+PREFIX?= ${X11BASE} # USE_X_PREFIX would pull in USE_XLIB
+USE_LINUX= yes
+NO_PACKAGE= Distfiles are 135MB, set FORCE_PACKAGE if you really want to build this package
+RESTRICTED= Redistribution is limited, see license
+ETDIR= ${PREFIX}/lib/enemyterritory
+STRIP= # do not brand Linux binaries as FreeBSD on INSTALL_PROGRAM
+
+do-build:
+ @${ECHO} '#!/bin/sh' > ${WRKSRC}/et-tce
+ @${ECHO} 'exec ${PREFIX}/bin/et +set fs_game tcetest "$$@"' >> ${WRKSRC}/et-tce
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/et-tce ${PREFIX}/bin
+
+ ${MKDIR} ${ETDIR}/tcetest
+.for f in cgame.mp.i386.so elitelogoicon.ico maps.cfg mp_bin.pk3 pak0.pk3 \
+ pak1.pk3 pak2.pk3 pak3.pk3 qagame.mp.i386.so server.cfg ui.mp.i386.so
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${ETDIR}/tcetest
+.endfor
+.for f in cgame.mp.i386.so qagame.mp.i386.so ui.mp.i386.so
+ -${CHOWN} ${LIBOWN}:${LIBGRP} ${ETDIR}/tcetest/${f}
+ ${CHMOD} ${LIBMODE} ${ETDIR}/tcetest/${f}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in README.TXT TCEeula1.0.rtf changelog.txt description.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-tce/distinfo b/games/linux-enemyterritory-tce/distinfo
new file mode 100644
index 000000000000..58d917aaedd3
--- /dev/null
+++ b/games/linux-enemyterritory-tce/distinfo
@@ -0,0 +1,4 @@
+MD5 (tcetest_0209_full.zip) = e01cb2add0bc5c6509f6923419b0515d
+SIZE (tcetest_0209_full.zip) = 134902370
+MD5 (tcetest_0.48_update.zip) = efc04e68d324bbab0f5d736866ed98e5
+SIZE (tcetest_0.48_update.zip) = 7017159
diff --git a/games/linux-enemyterritory-tce/pkg-descr b/games/linux-enemyterritory-tce/pkg-descr
new file mode 100644
index 000000000000..058506f1af34
--- /dev/null
+++ b/games/linux-enemyterritory-tce/pkg-descr
@@ -0,0 +1,24 @@
+Based on the popular Quake3 modification, "True Combat", TC:E provides
+a realistic combat simulator set against the backdrop of modern urban
+warfare. The player can expect thrilling shootouts, an emphasis on
+tactical team play, engaging close quarter fighting and some of the
+best weapons of modern warfare. Being accessible to both veteran
+players and those new to the world of tactical simulators is only one
+of TC:E's many strengths. Map authors can customize weapon load outs,
+skins, objectives and even the voice chats for each of their maps.
+
+Key features:
+ * A full game completely free for download
+ * Mission-based online multiplayer game
+ * Soft player class system (assault, recon, sniper)
+ * Rounds with skill-based "Armament Availability System"
+ * Voice Communication System designed in collaboration with real
+ SWAT Members
+ * Iron sight aiming system with ACOG and reflex sights
+ * Still in development: mission system - future versions will
+ integrate various objectives into the game
+
+WWW: http://www.truecombat.com/intro.php
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org
diff --git a/games/linux-enemyterritory-tce/pkg-plist b/games/linux-enemyterritory-tce/pkg-plist
new file mode 100644
index 000000000000..9c8fdf2d6a0b
--- /dev/null
+++ b/games/linux-enemyterritory-tce/pkg-plist
@@ -0,0 +1,19 @@
+bin/et-tce
+lib/enemyterritory/tcetest/cgame.mp.i386.so
+lib/enemyterritory/tcetest/elitelogoicon.ico
+lib/enemyterritory/tcetest/maps.cfg
+lib/enemyterritory/tcetest/mp_bin.pk3
+lib/enemyterritory/tcetest/pak0.pk3
+lib/enemyterritory/tcetest/pak1.pk3
+lib/enemyterritory/tcetest/pak2.pk3
+lib/enemyterritory/tcetest/pak3.pk3
+lib/enemyterritory/tcetest/qagame.mp.i386.so
+lib/enemyterritory/tcetest/server.cfg
+lib/enemyterritory/tcetest/ui.mp.i386.so
+%%PORTDOCS%%%%DOCSDIR%%/README.TXT
+%%PORTDOCS%%%%DOCSDIR%%/TCEeula1.0.rtf
+%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/description.txt
+@dirrm lib/enemyterritory/tcetest
+@unexec rmdir %D/lib/enemyterritory 2>/dev/null || true
+%%PORTDOCS%%@dirrm %%DOCSDIR%%