aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /games/linux-enemyterritory
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
Notes
Diffstat (limited to 'games/linux-enemyterritory')
-rw-r--r--games/linux-enemyterritory/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/games/linux-enemyterritory/Makefile b/games/linux-enemyterritory/Makefile
index 3da7b2e94b76..1b4b597645f7 100644
--- a/games/linux-enemyterritory/Makefile
+++ b/games/linux-enemyterritory/Makefile
@@ -7,6 +7,7 @@
PORTNAME= enemyterritory
PORTVERSION= 2.60
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= http://mirrors.xmission.com/idsoftware/et/linux/ \
http://3dgamers.intelenet.net/pub/3dgamers/games/wolfensteinet/ \
@@ -22,15 +23,11 @@ EXTRACT_SUFX= .run
MAINTAINER= benlutz@datacomm.ch
COMMENT= Wolfenstein: Enemy Territory (Linux version)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
ONLY_FOR_ARCHS= i386
-PREFIX?= ${X11BASE} # USE_X_PREFIX would pull in USE_XLIB
USE_LINUX= yes
+USE_X_PREFIX= yes
NO_PACKAGE= Package will be 257MB, set FORCE_PACKAGE if you really want to build it
RESTRICTED= Redistribution is limited, see license
-NO_BUILD= yes
-STRIP= # empty: do not strip(1) linux binaries
NO_WRKSUBDIR= yes
ETDIR= ${PREFIX}/lib/${PORTNAME}
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
@@ -45,6 +42,12 @@ post-patch:
@${SED} -e 's|@ETDIR@|${ETDIR}|' ${FILESDIR}/${FILE}.in > ${WRKSRC}/${FILE}
.endfor
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/pb/pbweb.x86
+.for FILE in et.x86 etded.x86
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/${FILE}
+.endfor
+
do-install:
${INSTALL_DIR} ${ETDIR}