aboutsummaryrefslogtreecommitdiff
path: root/games/linux-ningpo-demo
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-07 02:01:21 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-07 02:01:21 +0000
commit9f0a6948cf60d4a5fa4f3222bdc7536e00786db8 (patch)
treea96a264fc571d4922b86de603efcd2c1a68c9c58 /games/linux-ningpo-demo
parent99dbf79cb398c5a293b10f74009104d0244f3809 (diff)
downloadports-9f0a6948cf60d4a5fa4f3222bdc7536e00786db8.tar.gz
ports-9f0a6948cf60d4a5fa4f3222bdc7536e00786db8.zip
Notes
Diffstat (limited to 'games/linux-ningpo-demo')
-rw-r--r--games/linux-ningpo-demo/Makefile59
-rw-r--r--games/linux-ningpo-demo/distinfo3
-rw-r--r--games/linux-ningpo-demo/files/ningpo.in4
-rw-r--r--games/linux-ningpo-demo/pkg-descr4
-rw-r--r--games/linux-ningpo-demo/pkg-plist7
5 files changed, 77 insertions, 0 deletions
diff --git a/games/linux-ningpo-demo/Makefile b/games/linux-ningpo-demo/Makefile
new file mode 100644
index 000000000000..43afb3f14d86
--- /dev/null
+++ b/games/linux-ningpo-demo/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: linux-ningpo-demo
+# Date created: 2009-01-31
+# Whom: Marcus von Appen <mva@sysfault.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ningpo-demo
+PORTVERSION= 1.05.04
+CATEGORIES= games linux
+MASTER_SITES= http://demofiles.linuxgamepublishing.com/ningpo/
+PKGNAMEPREFIX= linux-
+DISTNAME= ningpo_demo
+EXTRACT_SUFX= .run
+
+MAINTAINER= mva@sysfault.org
+COMMENT= NingPo Mahjong Demo - a feature rich Mahjong game
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12 \
+ ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
+ ${LINUXBASE}/usr/lib/libSDL_mixer-1.2.so.0:${PORTSDIR}/audio/linux-sdl_mixer \
+ ${LINUXBASE}/usr/lib/libmikmod.so.2:${PORTSDIR}/audio/linux-mikmod \
+ ${LINUXBASE}/usr/lib/libogg.so.0:${PORTSDIR}/audio/linux-libogg \
+ ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis \
+ ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+NO_CDROM= Redistribution is limited, see license
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
+SUB_FILES= ningpo
+PORTDOCS= README README.licenses license.txt
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && ${TAIL} +377 ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAR} jxf -
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/Bin/ningpo_demo
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/Linux/x86/Bin/ningpo_demo.dynamic
+
+do-install:
+ @${MKDIR} ${DATADIR}/Bin
+ @cd ${WRKSRC}/bin/Linux/x86/Bin && \
+ ${INSTALL_PROGRAM} ningpo_demo ningpo_demo.dynamic ${DATADIR}/Bin
+ @${INSTALL_PROGRAM} ${WRKDIR}/ningpo ${PREFIX}/bin/${PKGNAMEPREFIX}ningpo
+ @${CP} -R ${WRKSRC}/Resources ${DATADIR}
+.if !defined (NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-ningpo-demo/distinfo b/games/linux-ningpo-demo/distinfo
new file mode 100644
index 000000000000..c95dc0a396f5
--- /dev/null
+++ b/games/linux-ningpo-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (ningpo_demo.run) = a0df73754437ee7c4c51c074b979a294
+SHA256 (ningpo_demo.run) = 93186f53ab80a64717f8b1d80717e4faaf3afc21c6cb3c7f8de057e47077a943
+SIZE (ningpo_demo.run) = 6610552
diff --git a/games/linux-ningpo-demo/files/ningpo.in b/games/linux-ningpo-demo/files/ningpo.in
new file mode 100644
index 000000000000..3cee139b5441
--- /dev/null
+++ b/games/linux-ningpo-demo/files/ningpo.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%DATADIR%% || exit 1
+exec ./Bin/ningpo_demo "$@"
diff --git a/games/linux-ningpo-demo/pkg-descr b/games/linux-ningpo-demo/pkg-descr
new file mode 100644
index 000000000000..11e945be4159
--- /dev/null
+++ b/games/linux-ningpo-demo/pkg-descr
@@ -0,0 +1,4 @@
+The classic Mahjong game with hundreds of play variations, various board
+styles and nine tile sets.
+
+WWW: http://www.linuxgamepublishing.com/info.php?id=15
diff --git a/games/linux-ningpo-demo/pkg-plist b/games/linux-ningpo-demo/pkg-plist
new file mode 100644
index 000000000000..7624de2cfe7e
--- /dev/null
+++ b/games/linux-ningpo-demo/pkg-plist
@@ -0,0 +1,7 @@
+bin/linux-ningpo
+%%DATADIR%%/Bin/ningpo_demo
+%%DATADIR%%/Bin/ningpo_demo.dynamic
+%%DATADIR%%/Resources/ningpo.pyz
+@dirrm %%DATADIR%%/Bin
+@dirrm %%DATADIR%%/Resources
+@dirrm %%DATADIR%%