aboutsummaryrefslogtreecommitdiff
path: root/games/linux-nwnclient
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-12-21 11:40:01 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-12-21 11:40:01 +0000
commit1ad7b2d338b4adf0311b829d06b578331d447543 (patch)
treedcd6061e3b706dd9513d28f1d51d52b208b0de4a /games/linux-nwnclient
parent9f972cc5dfad77f5de3b9f30f6a8710a3c7f42da (diff)
downloadports-1ad7b2d338b4adf0311b829d06b578331d447543.tar.gz
ports-1ad7b2d338b4adf0311b829d06b578331d447543.zip
Notes
Diffstat (limited to 'games/linux-nwnclient')
-rw-r--r--games/linux-nwnclient/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index dc993d5984e8..e56b049d7b37 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -46,7 +46,9 @@ do-install:
${CPIO} -pdmuv -R${SHAREOWN}:${SHAREGRP} ${DATADIR})
${LN} -s ${LINUXBASE}/usr/lib/libstdc++-2-libc6.1-1-2.9.0.so \
${DATADIR}/lib/libstdc++-libc6.1-2.so.3
- ${CHMOD} -R a+r ${DATADIR}
+ ${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 chmod 0755
+ ${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 chmod 0644
+ (cd ${DATADIR} && ${CHMOD} 0755 dmclient nwmain nwserver)
${INSTALL_SCRIPT} ${WRKDIR}/nwn ${PREFIX}/bin/
.include <bsd.port.mk>