aboutsummaryrefslogtreecommitdiff
path: root/games/linux-nwnclient
diff options
context:
space:
mode:
authorSean Farley <scf@FreeBSD.org>2010-09-30 22:16:06 +0000
committerSean Farley <scf@FreeBSD.org>2010-09-30 22:16:06 +0000
commit09ccb050914af55bde53fe07fa737c5994d89f08 (patch)
tree21f5119e1c5ece20678f8d1c10cd2d737f593921 /games/linux-nwnclient
parentbe0ca6a00e4eb171dcbec3b03fa213d672f40e02 (diff)
downloadports-09ccb050914af55bde53fe07fa737c5994d89f08.tar.gz
ports-09ccb050914af55bde53fe07fa737c5994d89f08.zip
Notes
Diffstat (limited to 'games/linux-nwnclient')
-rw-r--r--games/linux-nwnclient/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 08edd1b720d8..d623256f9c43 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -67,16 +67,18 @@ do-extract:
(cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${_distfile} ${EXTRACT_AFTER_ARGS})
.endfor
-.if !defined(WITHOUT_NWMOVIES)
+.if defined(BINKPLAYERFILE)
(cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${NWMOVIESFILE} ${EXTRACT_AFTER_ARGS} \
nwmovies/binklib.so nwmovies/libdis/libdisasm.so \
nwmovies/nwmovies.so)
(cd ${WRKSRC} && ${MV} BinkPlayer nwmovies)
.endif
- ${RM} ${WRKSRC}/lib/libSDL* ${WRKSRC}/SDL-1.2.5/* ${WRKSRC}/fixinstall \
- ${WRKSRC}/nwn
- ${RMDIR} ${WRKSRC}/SDL-1.2.5
+ ${RM} ${WRKSRC}/lib/libSDL* ${WRKSRC}/fixinstall ${WRKSRC}/nwn
+ if [ -d ${WRKSRC}/SDL-1.2.5 ]; then \
+ ${RM} ${WRKSRC}/SDL-1.2.5/*; \
+ ${RMDIR} ${WRKSRC}/SDL-1.2.5; \
+ fi
do-configure:
${SED} -e 's|%%NWNDATADIR%%|${NWNDATADIR}|' \
@@ -90,7 +92,7 @@ do-install:
${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
(cd ${DATADIR} && ${CHMOD} 0755 dmclient nwmain nwserver)
-.if !defined(WITHOUT_NWMOVIES)
+.if defined(BINKPLAYERFILE)
(cd ${DATADIR} && ${CHMOD} 0755 nwmovies/BinkPlayer)
(cd ${DATADIR}/nwmovies && ${LN} -s /compat/linux/usr/lib/libX11.so.6 libX11.so)
${INSTALL_SCRIPT} ${FILESDIR}/nwmovies.pl ${DATADIR}