aboutsummaryrefslogtreecommitdiff
path: root/games/linux-rtcw
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-17 00:43:48 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-17 00:43:48 +0000
commit1fa74db4daf467d9fb569b511a9c9cf8d88a5d2c (patch)
treed1c827f907651acb8a1d9ab3744ccee7a150ff26 /games/linux-rtcw
parent74d73173c2e15aca00a6709e8c6b5545f013c507 (diff)
Notes
Diffstat (limited to 'games/linux-rtcw')
-rw-r--r--games/linux-rtcw/Makefile26
1 files changed, 8 insertions, 18 deletions
diff --git a/games/linux-rtcw/Makefile b/games/linux-rtcw/Makefile
index f502da4ab112..7a16b3db158b 100644
--- a/games/linux-rtcw/Makefile
+++ b/games/linux-rtcw/Makefile
@@ -26,9 +26,6 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
# XXX: should probably be converted to use the LICENSE framework
post-extract:
@${MV} ${WRKSRC}/pb/PB_EULA.txt ${WRKSRC}
@@ -41,23 +38,16 @@ do-build:
.endfor
do-install:
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.for f in ${WRAPPERS}
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/Linux/x86/${f}.x86 ${DATADIR}/${f}
- ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/Linux/x86/${f}.x86 ${STAGEDIR}${DATADIR}/${f}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${CP} -a ${WRKSRC}/main ${WRKSRC}/pb ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/Wolf[MS]P.xpm ${PREFIX}/share/pixmaps
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ ${CP} -a ${WRKSRC}/main ${WRKSRC}/pb ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Wolf[MS]P.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && \
- ${INSTALL_DATA} CHANGES INSTALL QUICKSTART *.txt ${DOCSDIR}
- ${CP} -a ${WRKSRC}/Docs ${DOCSDIR}
-.endif
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ ${INSTALL_DATA} CHANGES INSTALL QUICKSTART *.txt ${STAGEDIR}${DOCSDIR}
+ ${CP} -a ${WRKSRC}/Docs ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>