aboutsummaryrefslogtreecommitdiff
path: root/games/linux-savage/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-12-01 02:57:31 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-12-01 02:57:31 +0000
commit295dcfe0ebba3f1db23fa72670fe77d47227f234 (patch)
tree666c736c75ed4e7c11488b7487b6a4802bdf010d /games/linux-savage/Makefile
parent5554b7daeb96685d98eab12e983b40f035f5ea14 (diff)
downloadports-295dcfe0ebba3f1db23fa72670fe77d47227f234.tar.gz
ports-295dcfe0ebba3f1db23fa72670fe77d47227f234.zip
Notes
Diffstat (limited to 'games/linux-savage/Makefile')
-rw-r--r--games/linux-savage/Makefile67
1 files changed, 29 insertions, 38 deletions
diff --git a/games/linux-savage/Makefile b/games/linux-savage/Makefile
index 0f160f0060bd..ee2005964767 100644
--- a/games/linux-savage/Makefile
+++ b/games/linux-savage/Makefile
@@ -6,19 +6,13 @@
#
PORTNAME= savage
-PORTVERSION= 2.00c
-PORTREVISION= 1
+PORTVERSION= 2.00e
CATEGORIES= games linux
-MASTER_SITES= http://downloads.s2games.com/online_orders/:full \
- http://patches.s2games.com/:patch
+MASTER_SITES= http://www.happypuppy.com/s2games/:full \
+ http://www.notforidiots.com/autoupdater/:patch
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME:S/$/_/}
-DISTFILES= ${DISTNAME:S/$/linux/}.sh.gz:full \
- ${PORTNAME}20030905a-patch.tar.gz:patch \
- ${PORTNAME}20030905d-patch.tar.gz:patch \
- ${PORTNAME}20030908a-patch.tar.gz:patch \
- ${PORTNAME}20031004b-patch.tar.gz:patch \
- ${PORTNAME}20031022a-patch.tar.gz:patch
+DISTFILES= ${PORTNAME:S/s/S/}_with_sep3t.run:full \
+ SEP-3T_3T+-r2.tar.gz:patch
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
@@ -34,7 +28,7 @@ NO_PACKAGE= Package will be 350MB, set FORCE_PACKAGE if you really want it
WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
SAVAGEDIR= lib/${PKGNAMEPREFIX}${PORTNAME}
-SUB_FILES= pkg-message savage savage_editor savage_server
+SUB_FILES= pkg-message savage savage_editor
PLIST_SUB+= SAVAGEDIR="${SAVAGEDIR}"
SUB_LIST+= SAVAGEDIR="${PREFIX}/${SAVAGEDIR}"
@@ -53,61 +47,58 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_d
.endif
do-extract:
-# Extract savage base
+# Extract savage 2.00e
@${MKDIR} ${WRKSRC}
- @${GZIP_CMD} -dc ${_DISTDIR}/${DISTNAME:S/$/linux/}.sh.gz > \
- ${WRKDIR}/${DISTNAME:S/$/linux/}.sh
@cd ${WRKSRC} && \
- ${TAIL} +175 ${WRKDIR}/${DISTNAME:S/$/linux/}.sh | \
- ${GZIP_CMD} -dc | ${TAR} xf -
-# Extract savage 2.00c
- @${MKDIR} ${WRKDIR}/patch
-.for FILE in 20030905a 20030905d 20030908a 20031004b 20031022a
- @${TAR} xfz ${_DISTDIR}/savage${FILE}-patch.tar.gz --directory ${WRKDIR}/patch
+ ${TAIL} +402 ${_DISTDIR}/${PORTNAME:S/s/S/}_with_sep3t.run | ${TAR} xf -
+.for FILE in graveyard savage
+ @${TAR} xfj ${WRKSRC}/${FILE}.tar.bz2 --directory ${WRKSRC}
.endfor
-post-extract:
- @${CP} -Rf ${WRKSRC}/linux/* ${WRKSRC}/Savage/
- @${CP} -Rf ${WRKSRC}/bin/x86/* ${WRKSRC}/Savage/
- @${MV} ${WRKDIR}/patch/savage.bin.new ${WRKDIR}/patch/savage.bin
- @${CP} -Rf ${WRKDIR}/patch/* ${WRKSRC}/Savage/
- @${FIND} -E ${WRKSRC}/Savage -type f -iregex ".*\.(dll|exe|bat)" -exec ${RM} "{}" \;
- @${FIND} ${WRKSRC}/Savage -type d -name CVS | ${XARGS} ${RM} -rf
+.for FILE in libcrypto libcurl libfmod libfreetype libglib libgssapi_krb5 libk5crypto \
+ libkrb5 libpng libssl libstdc++
+ @${RM} ${WRKSRC}/libs/${FILE}*
+.endfor
+
+# Extract SEP patch
+ @${TAR} xfz ${_DISTDIR}/SEP-3T_3T+-r2.tar.gz --directory ${WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/${SAVAGEDIR}
-.for DIRE in editor game updater
+.for DIRE in graveyard game updater
@${MKDIR} ${PREFIX}/${SAVAGEDIR}/${DIRE}
- @cd ${WRKSRC}/Savage/${DIRE} && \
+ @cd ${WRKSRC}/${DIRE} && \
${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${SAVAGEDIR}/${DIRE}/{}" \; && \
${FIND} * -type f -name "*.so" -exec ${INSTALL_PROGRAM} "{}" \
"${PREFIX}/${SAVAGEDIR}/${DIRE}/{}" \; && \
- ${FIND} -E * -type f -iregex ".*\.(bik|cfg|tga|txt|ttf|s2g|s2z|ogg)" \
+ ${FIND} -E * -type f -iregex ".*\.(bik|cfg|dat|db|tga|txt|ttf|s2g|s2z|ogg)" \
-exec ${INSTALL_DATA} "{}" "${PREFIX}/${SAVAGEDIR}/${DIRE}/{}" \;
.endfor
@${MKDIR} ${PREFIX}/${SAVAGEDIR}/libs
- @cd ${WRKSRC}/Savage/libs && \
+ @cd ${WRKSRC}/libs && \
${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${PREFIX}/${SAVAGEDIR}/libs/{}" \;
-.for FILE in dedicated_server.bin savage savage.bin silverback.bin update
- ${INSTALL_PROGRAM} ${WRKSRC}/Savage/${FILE} ${PREFIX}/${SAVAGEDIR}
+.for FILE in silverback.bin update
+ ${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${PREFIX}/${SAVAGEDIR}
.endfor
-.for FILE in savage savage_editor savage_server
+.for FILE in savage savage_editor
${INSTALL_SCRIPT} ${WRKDIR}/${FILE} ${PREFIX}/bin/${PKGNAMEPREFIX}${FILE}
.endfor
.for FILE in agp_error.txt icon.xpm logo.png eula.txt
- ${INSTALL_DATA} ${WRKSRC}/Savage/${FILE} ${PREFIX}/${SAVAGEDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/${SAVAGEDIR}
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Savage/docs/* ${DOCSDIR}
+. for FILE in README commander_controls.txt licenses.txt
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+. endfor
.endif
post-install:
- @PKG_PREFIX=${PREFIX}/${SAVAGEDIR} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>