aboutsummaryrefslogtreecommitdiff
path: root/games/linux-steam/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-02 14:08:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-02 14:08:38 +0000
commit015046aa09a75cb832342151dff48a04cb4b0675 (patch)
tree8217e92b0109f48806a75cbd3400f4ce384b31c3 /games/linux-steam/Makefile
parentdc78890adfc3cd5356d3ce7c171042a339152b5b (diff)
Notes
Diffstat (limited to 'games/linux-steam/Makefile')
-rw-r--r--games/linux-steam/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/linux-steam/Makefile b/games/linux-steam/Makefile
new file mode 100644
index 000000000000..b58dde3e7969
--- /dev/null
+++ b/games/linux-steam/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: hlstats
+# Date created: 29 December 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= steam
+PORTVERSION= 1.0
+CATEGORIES= games linux
+MASTER_SITES= http://hlstats.neojapangz.com/files/
+PKGNAMEPREFIX= linux-
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= Half Life dedicated server running on steam
+
+IS_INTERACTIVE= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_LINUX= yes
+
+do-build:
+ @ ${CHMOD} +x ${WRKDIR}/hldsupdatetool.bin && cd ${WRKDIR} && ./hldsupdatetool.bin
+ @ ${CAT} pkg-message | ${SED} 's|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/${PORTNAME}
+ @ ${CP} ${WRKDIR}/${PORTNAME} ${PREFIX}/${PORTNAME}/
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>