aboutsummaryrefslogtreecommitdiff
path: root/games/linux-steam
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-10 11:31:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-10 11:31:15 +0000
commit105ff63d66851b8190aabada8e6b329065c8a299 (patch)
treeb140990ebe364dfd76deb8ed89c4524080b159db /games/linux-steam
parentf130f54ba418659d8a26da09dad86a8286c94b18 (diff)
downloadports-105ff63d66851b8190aabada8e6b329065c8a299.tar.gz
ports-105ff63d66851b8190aabada8e6b329065c8a299.zip
Notes
Diffstat (limited to 'games/linux-steam')
-rw-r--r--games/linux-steam/Makefile11
-rw-r--r--games/linux-steam/pkg-message22
-rw-r--r--games/linux-steam/pkg-plist4
3 files changed, 26 insertions, 11 deletions
diff --git a/games/linux-steam/Makefile b/games/linux-steam/Makefile
index b58dde3e7969..2dda2bba69d1 100644
--- a/games/linux-steam/Makefile
+++ b/games/linux-steam/Makefile
@@ -18,13 +18,20 @@ IS_INTERACTIVE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_LINUX= yes
+INSTALLDIR?= steam
+
+PLIST_SUB+= INSTALLDIR=${INSTALLDIR}
+
+pre-everything::
+ @ ${ECHO_MSG} "You can use the INSTALLDIR option to change the install dir"
+
do-build:
@ ${CHMOD} +x ${WRKDIR}/hldsupdatetool.bin && cd ${WRKDIR} && ./hldsupdatetool.bin
@ ${CAT} pkg-message | ${SED} 's|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
do-install:
- @ ${MKDIR} ${PREFIX}/${PORTNAME}
- @ ${CP} ${WRKDIR}/${PORTNAME} ${PREFIX}/${PORTNAME}/
+ @ ${MKDIR} ${PREFIX}/${INSTALLDIR}
+ @ ${CP} ${WRKDIR}/${PORTNAME} ${PREFIX}/${INSTALLDIR}/
@ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/games/linux-steam/pkg-message b/games/linux-steam/pkg-message
index 51c58bc40490..b970223cc988 100644
--- a/games/linux-steam/pkg-message
+++ b/games/linux-steam/pkg-message
@@ -1,19 +1,27 @@
##################################################################
-# To get started goto %%PREFIX%%/steam #
+# To get started goto %%PREFIX%%/%%INSTALLDIR%% #
# and type the following to create a steam-user. #
-# ./steam -create <username> <password> <question> <answer> #
+# ./steam -command create -username <username> \ #
+# -email <emailaddress> -password <password> \ #
+# -question <question> -answer <answer> #
+# #
# Example #
-# ./steam -create johndoe l337cr3w nameofmygun M4A1 #
+# ./steam -command create -username johndoe \ #
+# -email johndoe@mydomain.com -password 12345678 \ #
+# -question nameofmygun -answer M4A1 #
# #
# Once you have a steam-user account or if you have a registered #
# account already type the following to start updating your HLDS #
-# ./steam -update <game> <installdir> <username> [<password> [Y]]#
-# example #
-# ./steam -update cstrike . johndoe l337cr3w Y #
+# ./steam -command update -game <game> -dir <steamdir> \ #
+# -username <username> -password <password> -remember_password #
+# #
+# Example #
+# ./steam -command update -game cstrike -dir %%PREFIX%%/steam \ #
+# -username johndoe -password 12345678 -remember_password #
# #
# Once your server has been updated type the following #
# to test your server. #
-# ./hlds_run -game cstrike +maxplayers 10 +map de_dust #
+# ./hlds_run -game cstrike +map de_dust -maxplayers 16 #
# #
# For instructions on configuring your server goto #
# http://server.counter-strike.net #
diff --git a/games/linux-steam/pkg-plist b/games/linux-steam/pkg-plist
index f9cf2635a5a8..711caef9c1a9 100644
--- a/games/linux-steam/pkg-plist
+++ b/games/linux-steam/pkg-plist
@@ -1,2 +1,2 @@
-steam/steam
-@dirrm steam
+%%INSTALLDIR%%/steam
+@dirrm %%INSTALLDIR%%