aboutsummaryrefslogtreecommitdiff
path: root/games/linux-ut/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-07-10 23:43:29 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-07-10 23:43:29 +0000
commitbd53c33cb131b67e2a59cd1466247b098f10c900 (patch)
treeb2630decc4fcd56e9aea57242dff1b331481829a /games/linux-ut/Makefile
parente8cbf7288505377e5879cf0cd4b5de292a3b1cbf (diff)
downloadports-bd53c33cb131b67e2a59cd1466247b098f10c900.tar.gz
ports-bd53c33cb131b67e2a59cd1466247b098f10c900.zip
Notes
Diffstat (limited to 'games/linux-ut/Makefile')
-rw-r--r--games/linux-ut/Makefile46
1 files changed, 34 insertions, 12 deletions
diff --git a/games/linux-ut/Makefile b/games/linux-ut/Makefile
index 5da5ea5c2c27..ea9447979602 100644
--- a/games/linux-ut/Makefile
+++ b/games/linux-ut/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= linux-ut
-PORTVERSION= 436
+PORTVERSION= 451
CATEGORIES= games linux
-MASTER_SITES= http://liflg.org/?what=dl&catid=6&gameid=51&filename=
-DISTFILES= unreal.tournament_436-multilanguage.run \
- unreal.tournament.official.bonus.pack.collection.run
+MASTER_SITES= "http://liflg.org/?what=dl&catid=6&gameid=51&filename=":p436 \
+ http://www.utpg.org/patches/:p451
+DISTFILES= ${PATCH436FILES} \
+ ${PATCH451FILES}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= sean-freebsd@farley.org
COMMENT= Unreal Tournament for Linux
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
# A redirect will occur, so have fetch save the file with the correct name.
FETCH_CMD= /usr/bin/fetch -Rr
FETCH_BEFORE_ARGS= -o $${file}
@@ -24,15 +27,19 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_XLIB= yes
NO_BUILD= yes
-NO_PACKAGE= Distribution is 340MB\; set FORCE_PACKAGE if you really want\
+NO_PACKAGE= Distribution is 340MB; set FORCE_PACKAGE if you really want\
to build this package
RESTRICTED= Redistribution is limited, see license
IS_INTERACTIVE= yes
WRKSRC= ${WRKDIR}/${PKGNAME}
+PATCH436FILES= unreal.tournament_436-multilanguage.run:p436 \
+ unreal.tournament.official.bonus.pack.collection.run:p436
+PATCH451FILES= UTPGPatch451.tar.bz2:p451
+
do-extract:
@${MKDIR} ${WRKSRC}
-.for file in ${DISTFILES}
+.for file in ${PATCH436FILES:C/:.*//}
@cd ${WRKSRC} &&\
${SED} -e '1,/exit $$res/d' ${_DISTDIR}/${file} | ${TAR} zxf -
.endfor
@@ -50,8 +57,9 @@ post-patch:
# - Copy desired content off of CD to drive. Windows files left behind.
# - Extract files from Linux patch minus various language files (necessary?).
# - Extract bonus pack.
-# - Patch .ini file to use absolute paths to content.
-# - Apply Linux patch.
+# - Patch .ini file to also use absolute paths to content in addition to the
+# relative paths for user saved content.
+# - Apply Linux patches.
# - Install scripts and README's.
# - Set permissions on files and directories.
do-install:
@@ -76,18 +84,19 @@ do-install:
${TAR} x -C ${DATADIR} -f -
.endfor
@${RM} ${DATADIR}/Logs/delete_me.txt
- @${ECHO_CMD} "Installing v${PORTVERSION} patch files"
+ @${ECHO_CMD} "Installing v436 patch files"
.for tarfile in Credits NetGamesUSA.com OpenGL.ini data
@${TAR} zox -C ${DATADIR} --exclude '*.exe'\
-f ${WRKSRC}/${tarfile}.tar.gz
.endfor
@${ECHO_CMD} "Installing bonus pack"
.for ndx in 1 2 3 4
- @${TAR} jox -C ${DATADIR} -f ${WRKSRC}/bp${ndx}.tar.bz2
+ @${TAR} jx -C ${DATADIR} -f ${WRKSRC}/bp${ndx}.tar.bz2
.endfor
- @${SED} -i "" -e "s|\.\.\\\\|${DATADIR}\\\\|" -e "s|\.\./|${DATADIR}/|"\
+ @${SED} -i "" -e 's|\\|/|g'\
+ -e "/^Paths=/{h;s|\(Paths=\)\.\./|\1${DATADIR}/|;x;p;x;}"\
${DATADIR}/System/UnrealTournament.ini
- @${ECHO_CMD} "Applying v${PORTVERSION} patch"
+ @${ECHO_CMD} "Applying v436 patch"
@${WRKSRC}/setup.data/bin/FreeBSD/x86/loki_patch\
${WRKSRC}/setup.data/patch.dat ${DATADIR}
.for script in ucc ut
@@ -96,7 +105,20 @@ do-install:
.for datafile in README README.Loki README.bonus.pack.collection
@${INSTALL_DATA} ${WRKSRC}/${datafile} ${DATADIR}
.endfor
+ @${ECHO_CMD} "Installing v${PORTVERSION} patch files"
+ @${TAR} jx -C ${DATADIR} --exclude 'checkfiles.sh'\
+ --exclude 'patch.md5' --exclude 'd3ddrv.int'\
+ -f ${_DISTDIR}/${PATCH451FILES:C/:.*//}
+ @cd ${DATADIR}/System &&\
+ ${MV} -f glidedrv.int GlideDrv.int &&\
+ ${MV} -f softdrv.int SoftDrv.int &&\
+ ${MV} -f opengldrv.int OpenGlDrv.int &&\
+ ${MV} -f galaxy.int Galaxy.int &&\
+ ${MV} -f editor.int Editor.int &&\
+ ${MV} -f windrv.int WinDrv.int
@${ECHO_CMD} "Setting permissions"
+ @${FIND} ${DATADIR} -print0 |\
+ ${XARGS} -0 ${CHOWN} ${SHAREOWN}:${SHAREGRP}
@${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
@${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${NOBINMODE}
@${FIND} ${DATADIR} \( -name "*.so" -o -name "lib*.so*" \) -print0 |\