aboutsummaryrefslogtreecommitdiff
path: root/games/linux-ut
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-06-13 17:56:25 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-06-13 17:56:25 +0000
commit6314b147f283b57ff3f99385363bf1ac8cb52b10 (patch)
tree6a3ffb820547cad018ef6e014bc31881a3f1aac6 /games/linux-ut
parent467a07aa3ae12ff7657b8ce67c66f145a27b25fa (diff)
downloadports-6314b147f283b57ff3f99385363bf1ac8cb52b10.tar.gz
ports-6314b147f283b57ff3f99385363bf1ac8cb52b10.zip
Notes
Diffstat (limited to 'games/linux-ut')
-rw-r--r--games/linux-ut/Makefile109
-rw-r--r--games/linux-ut/distinfo6
-rw-r--r--games/linux-ut/pkg-descr15
-rw-r--r--games/linux-ut/pkg-plist574
4 files changed, 704 insertions, 0 deletions
diff --git a/games/linux-ut/Makefile b/games/linux-ut/Makefile
new file mode 100644
index 000000000000..5da5ea5c2c27
--- /dev/null
+++ b/games/linux-ut/Makefile
@@ -0,0 +1,109 @@
+# New ports collection makefile for: linux-ut
+# Date created: 7 Jan 2006
+# Whom: Sean Farley <sean-freebsd@farley.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux-ut
+PORTVERSION= 436
+CATEGORIES= games linux
+MASTER_SITES= http://liflg.org/?what=dl&catid=6&gameid=51&filename=
+DISTFILES= unreal.tournament_436-multilanguage.run \
+ unreal.tournament.official.bonus.pack.collection.run
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sean-freebsd@farley.org
+COMMENT= Unreal Tournament for Linux
+
+# A redirect will occur, so have fetch save the file with the correct name.
+FETCH_CMD= /usr/bin/fetch -Rr
+FETCH_BEFORE_ARGS= -o $${file}
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_XLIB= yes
+NO_BUILD= yes
+NO_PACKAGE= Distribution is 340MB\; set FORCE_PACKAGE if you really want\
+ to build this package
+RESTRICTED= Redistribution is limited, see license
+IS_INTERACTIVE= yes
+WRKSRC= ${WRKDIR}/${PKGNAME}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+.for file in ${DISTFILES}
+ @cd ${WRKSRC} &&\
+ ${SED} -e '1,/exit $$res/d' ${_DISTDIR}/${file} | ${TAR} zxf -
+.endfor
+ @${MV} ${WRKSRC}/bin/Linux/x86/ucc ${WRKSRC}/bin/.
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|\(UT_DATA_PATH=\).*|\1\"${DATADIR}/System\"|"\
+ ${WRKSRC}/bin/ucc
+ @${REINPLACE_CMD} -e "s|^\(GAME_DIR=\).*|\1\"${DATADIR}\"|"\
+ -e "/ll=/{N;d;}" ${WRKSRC}/bin/ut
+
+# Installation steps performed:
+# - Verify path to CD content.
+# - Verify CD was correctly mounted. -b option may be needed to mount it.
+# - Copy desired content off of CD to drive. Windows files left behind.
+# - Extract files from Linux patch minus various language files (necessary?).
+# - Extract bonus pack.
+# - Patch .ini file to use absolute paths to content.
+# - Apply Linux patch.
+# - Install scripts and README's.
+# - Set permissions on files and directories.
+do-install:
+.if !defined(CDROM_MOUNT)
+ @${ECHO_CMD} "${PKGNAME} requires CDROM_MOUNT set to mount point of CD"
+ @${FALSE}
+.endif
+.if !exists(${CDROM_MOUNT}/NetGamesUSA.com)
+ @${ECHO_CMD} \
+ "NetGamesUSA.com not found on CD; try mounting with -b option"
+ @${FALSE}
+.endif
+ @${ECHO_CMD} "Installing data from CD"
+ @${MKDIR} ${DATADIR}
+.for dir in Help Logs Maps Music NetGamesUSA.com Sounds System Textures Web
+ @cd ${CDROM_MOUNT} &&\
+ ${TAR} c --exclude '*.ICD' --exclude '*.bat' --exclude '*.dll'\
+ --exclude '*.est*' --exclude '*.[Ee][Xx][Ee]'\
+ --exclude '*.frt*' --exclude '*.ico' --exclude '*.itt*'\
+ --exclude '*.mpi' --exclude '*.url' --exclude 'D3D*'\
+ --exclude 'mplay*' -f - ${dir} |\
+ ${TAR} x -C ${DATADIR} -f -
+.endfor
+ @${RM} ${DATADIR}/Logs/delete_me.txt
+ @${ECHO_CMD} "Installing v${PORTVERSION} patch files"
+.for tarfile in Credits NetGamesUSA.com OpenGL.ini data
+ @${TAR} zox -C ${DATADIR} --exclude '*.exe'\
+ -f ${WRKSRC}/${tarfile}.tar.gz
+.endfor
+ @${ECHO_CMD} "Installing bonus pack"
+.for ndx in 1 2 3 4
+ @${TAR} jox -C ${DATADIR} -f ${WRKSRC}/bp${ndx}.tar.bz2
+.endfor
+ @${SED} -i "" -e "s|\.\.\\\\|${DATADIR}\\\\|" -e "s|\.\./|${DATADIR}/|"\
+ ${DATADIR}/System/UnrealTournament.ini
+ @${ECHO_CMD} "Applying v${PORTVERSION} patch"
+ @${WRKSRC}/setup.data/bin/FreeBSD/x86/loki_patch\
+ ${WRKSRC}/setup.data/patch.dat ${DATADIR}
+.for script in ucc ut
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/${script} ${PREFIX}/bin/
+.endfor
+.for datafile in README README.Loki README.bonus.pack.collection
+ @${INSTALL_DATA} ${WRKSRC}/${datafile} ${DATADIR}
+.endfor
+ @${ECHO_CMD} "Setting permissions"
+ @${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${NOBINMODE}
+ @${FIND} ${DATADIR} \( -name "*.so" -o -name "lib*.so*" \) -print0 |\
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+.for exec in ucc-bin ut-bin
+ @${CHMOD} ${BINMODE} ${DATADIR}/System/${exec}
+.endfor
+ @${ECHO_CMD} "Install complete"
+
+.include <bsd.port.mk>
diff --git a/games/linux-ut/distinfo b/games/linux-ut/distinfo
new file mode 100644
index 000000000000..684f5747355c
--- /dev/null
+++ b/games/linux-ut/distinfo
@@ -0,0 +1,6 @@
+MD5 (linux-ut/unreal.tournament_436-multilanguage.run) = 726aede817997a2aefccb8c20601d760
+SHA256 (linux-ut/unreal.tournament_436-multilanguage.run) = 8c0f0e266744ed18b14f6f6777d9ce8ed3ece120ccc37e7bbffa92e5a92ad2a8
+SIZE (linux-ut/unreal.tournament_436-multilanguage.run) = 7492482
+MD5 (linux-ut/unreal.tournament.official.bonus.pack.collection.run) = 82e71a81de1eaf4e09648372c0ca7289
+SHA256 (linux-ut/unreal.tournament.official.bonus.pack.collection.run) = b4ac49ab1df2bd9644d05e0dfe6a67effbaeab739b6073c98220872eb9eec464
+SIZE (linux-ut/unreal.tournament.official.bonus.pack.collection.run) = 37213789
diff --git a/games/linux-ut/pkg-descr b/games/linux-ut/pkg-descr
new file mode 100644
index 000000000000..4255822ad50e
--- /dev/null
+++ b/games/linux-ut/pkg-descr
@@ -0,0 +1,15 @@
+Unreal Tournament, the ultimate challenge of competitive game-play.
+Unreal Tournament showcases the enhanced, hugely-popular Unreal engine,
+the benchmark of 3-D graphical excellence and immersive gameplay.
+This stand-alone game brings you never before,
+richly-textured and thrilling environments.
+In single player mode with "bots" (virtual customizeable team mates) or
+in multiplayer mode with up to 16 bots and/or humans.
+Step into the Unreal arena and stake your life in the pursuit of victory
+as the Unreal Grand Master. Or suffer the agonizing death of defeat.
+
+For information about the Linux patch/installer
+WWW: http://liflg.org/?catid=6&gameid=51
+
+For more information about UT visit:
+http://www.unrealtournament.com/
diff --git a/games/linux-ut/pkg-plist b/games/linux-ut/pkg-plist
new file mode 100644
index 000000000000..a452f2d51962
--- /dev/null
+++ b/games/linux-ut/pkg-plist
@@ -0,0 +1,574 @@
+bin/ucc
+bin/ut
+%%DATADIR%%/Help/BP4README.txt
+%%DATADIR%%/Help/BonusPackReadme.txt
+%%DATADIR%%/Help/Logo.bmp
+%%DATADIR%%/Help/ReadMe.htm
+%%DATADIR%%/Help/UnrealTournamentLogo.bmp
+%%DATADIR%%/Help/UnrealTournamentSetupLogo.bmp
+%%DATADIR%%/Help/demutators-readme.txt
+%%DATADIR%%/Help/inoxxpack.txt
+%%DATADIR%%/Maps/AS-Frigate.unr
+%%DATADIR%%/Maps/AS-Guardia.unr
+%%DATADIR%%/Maps/AS-HiSpeed.unr
+%%DATADIR%%/Maps/AS-Mazon.unr
+%%DATADIR%%/Maps/AS-OceanFloor.unr
+%%DATADIR%%/Maps/AS-Overlord.unr
+%%DATADIR%%/Maps/AS-Rook.unr
+%%DATADIR%%/Maps/AS-Tutorial.unr
+%%DATADIR%%/Maps/CTF-Beatitude.unr
+%%DATADIR%%/Maps/CTF-Command.unr
+%%DATADIR%%/Maps/CTF-Coret.unr
+%%DATADIR%%/Maps/CTF-Cybrosis][.unr
+%%DATADIR%%/Maps/CTF-Darji16.unr
+%%DATADIR%%/Maps/CTF-Dreary.unr
+%%DATADIR%%/Maps/CTF-EpicBoy.unr
+%%DATADIR%%/Maps/CTF-EternalCave.unr
+%%DATADIR%%/Maps/CTF-Face-SE.unr
+%%DATADIR%%/Maps/CTF-Face.unr
+%%DATADIR%%/Maps/CTF-Face][.unr
+%%DATADIR%%/Maps/CTF-Gauntlet.unr
+%%DATADIR%%/Maps/CTF-HallOfGiants.unr
+%%DATADIR%%/Maps/CTF-High.unr
+%%DATADIR%%/Maps/CTF-Hydro16.unr
+%%DATADIR%%/Maps/CTF-Kosov.unr
+%%DATADIR%%/Maps/CTF-LavaGiant.unr
+%%DATADIR%%/Maps/CTF-Niven.unr
+%%DATADIR%%/Maps/CTF-November.unr
+%%DATADIR%%/Maps/CTF-Noxion16.unr
+%%DATADIR%%/Maps/CTF-Nucleus.unr
+%%DATADIR%%/Maps/CTF-Orbital.unr
+%%DATADIR%%/Maps/CTF-Ratchet.unr
+%%DATADIR%%/Maps/CTF-Tutorial.unr
+%%DATADIR%%/Maps/CityIntro.unr
+%%DATADIR%%/Maps/DM-Agony.unr
+%%DATADIR%%/Maps/DM-ArcaneTemple.unr
+%%DATADIR%%/Maps/DM-Barricade.unr
+%%DATADIR%%/Maps/DM-Bishop.unr
+%%DATADIR%%/Maps/DM-Closer.unr
+%%DATADIR%%/Maps/DM-Codex.unr
+%%DATADIR%%/Maps/DM-Conveyor.unr
+%%DATADIR%%/Maps/DM-Crane.unr
+%%DATADIR%%/Maps/DM-Curse][.unr
+%%DATADIR%%/Maps/DM-Cybrosis][.unr
+%%DATADIR%%/Maps/DM-Deck16][.unr
+%%DATADIR%%/Maps/DM-Fetid.unr
+%%DATADIR%%/Maps/DM-Fractal.unr
+%%DATADIR%%/Maps/DM-Gothic.unr
+%%DATADIR%%/Maps/DM-Grinder.unr
+%%DATADIR%%/Maps/DM-Grit-TOURNEY.unr
+%%DATADIR%%/Maps/DM-HealPod][.unr
+%%DATADIR%%/Maps/DM-HyperBlast.unr
+%%DATADIR%%/Maps/DM-KGalleon.unr
+%%DATADIR%%/Maps/DM-Liandri.unr
+%%DATADIR%%/Maps/DM-Malevolence.unr
+%%DATADIR%%/Maps/DM-Mojo][.unr
+%%DATADIR%%/Maps/DM-Morbias][.unr
+%%DATADIR%%/Maps/DM-Morpheus.unr
+%%DATADIR%%/Maps/DM-Oblivion.unr
+%%DATADIR%%/Maps/DM-Peak.unr
+%%DATADIR%%/Maps/DM-Phobos.unr
+%%DATADIR%%/Maps/DM-Pressure.unr
+%%DATADIR%%/Maps/DM-Pyramid.unr
+%%DATADIR%%/Maps/DM-Shrapnel][.unr
+%%DATADIR%%/Maps/DM-SpaceNoxx.unr
+%%DATADIR%%/Maps/DM-Stalwart.unr
+%%DATADIR%%/Maps/DM-StalwartXL.unr
+%%DATADIR%%/Maps/DM-Tempest.unr
+%%DATADIR%%/Maps/DM-Turbine.unr
+%%DATADIR%%/Maps/DM-Tutorial.unr
+%%DATADIR%%/Maps/DM-Viridian-TOURNEY.unr
+%%DATADIR%%/Maps/DM-Zeto.unr
+%%DATADIR%%/Maps/DOM-Bullet.unr
+%%DATADIR%%/Maps/DOM-Cidom.unr
+%%DATADIR%%/Maps/DOM-Cinder.unr
+%%DATADIR%%/Maps/DOM-Condemned.unr
+%%DATADIR%%/Maps/DOM-Cryptic.unr
+%%DATADIR%%/Maps/DOM-Gearbolt.unr
+%%DATADIR%%/Maps/DOM-Ghardhen.unr
+%%DATADIR%%/Maps/DOM-Lament.unr
+%%DATADIR%%/Maps/DOM-Lament][.unr
+%%DATADIR%%/Maps/DOM-Leadworks.unr
+%%DATADIR%%/Maps/DOM-MetalDream.unr
+%%DATADIR%%/Maps/DOM-Olden.unr
+%%DATADIR%%/Maps/DOM-Sesmar.unr
+%%DATADIR%%/Maps/DOM-Tutorial.unr
+%%DATADIR%%/Maps/DOM-WolfsBay.unr
+%%DATADIR%%/Maps/EOL_Assault.unr
+%%DATADIR%%/Maps/EOL_CTF.unr
+%%DATADIR%%/Maps/EOL_Challenge.unr
+%%DATADIR%%/Maps/EOL_Deathmatch.unr
+%%DATADIR%%/Maps/EOL_Domination.unr
+%%DATADIR%%/Maps/EOL_Statues.unr
+%%DATADIR%%/Maps/Entry.unr
+%%DATADIR%%/Maps/UT-Logo-Map.unr
+%%DATADIR%%/Maps/UTCredits.unr
+%%DATADIR%%/Music/Botmca9.umx
+%%DATADIR%%/Music/Botpck10.umx
+%%DATADIR%%/Music/Cannon.umx
+%%DATADIR%%/Music/Colossus.umx
+%%DATADIR%%/Music/Course.umx
+%%DATADIR%%/Music/Credits.umx
+%%DATADIR%%/Music/Ending.umx
+%%DATADIR%%/Music/Enigma.umx
+%%DATADIR%%/Music/Foregone.umx
+%%DATADIR%%/Music/Godown.umx
+%%DATADIR%%/Music/Lock.umx
+%%DATADIR%%/Music/Mech8.umx
+%%DATADIR%%/Music/Mission.umx
+%%DATADIR%%/Music/Nether.umx
+%%DATADIR%%/Music/Organic.umx
+%%DATADIR%%/Music/Phantom.umx
+%%DATADIR%%/Music/Razor-ub.umx
+%%DATADIR%%/Music/Run.umx
+%%DATADIR%%/Music/SaveMe.umx
+%%DATADIR%%/Music/Savemeg.umx
+%%DATADIR%%/Music/Seeker.umx
+%%DATADIR%%/Music/Seeker2.umx
+%%DATADIR%%/Music/Skyward.umx
+%%DATADIR%%/Music/Strider.umx
+%%DATADIR%%/Music/Suprfist.umx
+%%DATADIR%%/Music/UnWorld2.umx
+%%DATADIR%%/Music/Uttitle.umx
+%%DATADIR%%/Music/Wheels.umx
+%%DATADIR%%/Music/firebr.umx
+%%DATADIR%%/Music/utmenu23.umx
+%%DATADIR%%/NetGamesUSA.com/About_NetGames_USA.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/Backup of default ngStatsUT.cfg
+%%DATADIR%%/NetGamesUSA.com/ngStats/Readme-Help_Using_ngStats.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/data/db.ver
+%%DATADIR%%/NetGamesUSA.com/ngStats/history.txt
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/About_Epic_Games.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/About_NetGames_USA.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/About_ngTCS.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/About_ngWorldStats.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Help_Using_ngStats.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Highest_Score/index.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Last_Game/index.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Recent_Index.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Legal_Terms.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats/All_Totals.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats/Bot_Totals.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats/Human_Totals.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats/Player_Index.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats/Rankings.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats/Total_Index.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/Change_ngWorldStats_Password.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/Confirm_Password.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/UT_Logo_Large_Button.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/UT_Logo_Small_Button.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/View_ngStats.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/View_ngWorldStats.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/blue_white.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/flags_279.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g1.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g10.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g11.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g12.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g13.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g14.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g15.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g16.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g17.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g18.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g19.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g2.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g20.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g21.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g22.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g23.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g24.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g25.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g26.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g27.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g28.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g29.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g3.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g30.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g31.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g32.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g4.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g5.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g6.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g7.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g8.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g9.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g_legend.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/g_no.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/graph_back_ngStats.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/graph_back_ngStats_big.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngStats.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngStats_106_Wide.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngStats_Processing.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngTCS_129x114.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngTCS_Lite_129x114.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngTCS_Pro_129x114.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngUSA_Logo.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngUSA_Logo_106_wide.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngWorldStats.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_500x83.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_ENABLED_240x70.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_ENABLED_88x31.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_Enabled_234x46.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_Password.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/unreallogo.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics/white.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/ngStats_Main.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/processing.html
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/README.txt
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics/background.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics/sidebar_120x90.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics/skin_credit_88x31.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/skin.css
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/custom_graphics/background.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/custom_graphics/sidebar_120x90.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/custom_graphics/skin_credit_88x31.gif
+%%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/skin.css
+%%DATADIR%%/NetGamesUSA.com/ngStats/ngStats End User License Agreement (EULA).txt
+%%DATADIR%%/NetGamesUSA.com/ngStats/ngStatsUT
+%%DATADIR%%/NetGamesUSA.com/ngStats/ngStatsUT.cfg
+%%DATADIR%%/NetGamesUSA.com/ngStats/ngusa.jar
+%%DATADIR%%/NetGamesUSA.com/ngStats/processedLogs/_tmp
+%%DATADIR%%/NetGamesUSA.com/ngWorldStats/bin/Help Using ngWorldStats Readme.txt
+%%DATADIR%%/NetGamesUSA.com/ngWorldStats/bin/ngWS.ver
+%%DATADIR%%/NetGamesUSA.com/ngWorldStats/bin/ngWorldStats
+%%DATADIR%%/NetGamesUSA.com/ngWorldStats/bin/ngWorldStats End User License Agreement (EULA).txt
+%%DATADIR%%/NetGamesUSA.com/ngWorldStats/logs/New_Install.log
+%%DATADIR%%/README
+%%DATADIR%%/README.Loki
+%%DATADIR%%/README.bonus.pack.collection
+%%DATADIR%%/Sounds/Activates.uax
+%%DATADIR%%/Sounds/Addon1.uax
+%%DATADIR%%/Sounds/AmbAncient.uax
+%%DATADIR%%/Sounds/AmbCity.uax
+%%DATADIR%%/Sounds/AmbModern.uax
+%%DATADIR%%/Sounds/AmbOutside.uax
+%%DATADIR%%/Sounds/Announcer.uax
+%%DATADIR%%/Sounds/BossVoice.uax
+%%DATADIR%%/Sounds/DDay.uax
+%%DATADIR%%/Sounds/DMatch.uax
+%%DATADIR%%/Sounds/DoorsAnc.uax
+%%DATADIR%%/Sounds/DoorsMod.uax
+%%DATADIR%%/Sounds/Extro.uax
+%%DATADIR%%/Sounds/Female1Voice.uax
+%%DATADIR%%/Sounds/Female2Voice.uax
+%%DATADIR%%/Sounds/FemaleSounds.uax
+%%DATADIR%%/Sounds/LadderSounds.uax
+%%DATADIR%%/Sounds/Male1Voice.uax
+%%DATADIR%%/Sounds/Male2Voice.uax
+%%DATADIR%%/Sounds/MaleSounds.uax
+%%DATADIR%%/Sounds/Pan1.uax
+%%DATADIR%%/Sounds/TutVoiceAS.uax
+%%DATADIR%%/Sounds/TutVoiceCTF.uax
+%%DATADIR%%/Sounds/TutVoiceDM.uax
+%%DATADIR%%/Sounds/TutVoiceDOM.uax
+%%DATADIR%%/Sounds/VRikers.uax
+%%DATADIR%%/Sounds/noxxsnd.uax
+%%DATADIR%%/Sounds/openingwave.uax
+%%DATADIR%%/Sounds/rain.uax
+%%DATADIR%%/System/ALAudio.so
+%%DATADIR%%/System/Audio.so
+%%DATADIR%%/System/BossSkins.int
+%%DATADIR%%/System/BotPack.u
+%%DATADIR%%/System/Botpack.int
+%%DATADIR%%/System/CommandoSkins.int
+%%DATADIR%%/System/Core.int
+%%DATADIR%%/System/Core.so
+%%DATADIR%%/System/Core.u
+%%DATADIR%%/System/DefUser.ini
+%%DATADIR%%/System/Default.ini
+%%DATADIR%%/System/Editor.int
+%%DATADIR%%/System/Editor.so
+%%DATADIR%%/System/Editor.u
+%%DATADIR%%/System/Engine.int
+%%DATADIR%%/System/Engine.so
+%%DATADIR%%/System/Engine.u
+%%DATADIR%%/System/EpicCustomModels.u
+%%DATADIR%%/System/FCommandoSkins.int
+%%DATADIR%%/System/Female1Skins.int
+%%DATADIR%%/System/Female2Skins.int
+%%DATADIR%%/System/Fire.so
+%%DATADIR%%/System/Fire.u
+%%DATADIR%%/System/Galaxy.int
+%%DATADIR%%/System/GlideDrv.int
+%%DATADIR%%/System/GlideDrv.so
+%%DATADIR%%/System/IpDrv.int
+%%DATADIR%%/System/IpDrv.so
+%%DATADIR%%/System/IpDrv.u
+%%DATADIR%%/System/IpServer.int
+%%DATADIR%%/System/IpServer.u
+%%DATADIR%%/System/License.int
+%%DATADIR%%/System/Male1Skins.int
+%%DATADIR%%/System/Male2Skins.int
+%%DATADIR%%/System/Male3Skins.int
+%%DATADIR%%/System/Manifest.ini
+%%DATADIR%%/System/Manifest.int
+%%DATADIR%%/System/MeTaLDrv.int
+%%DATADIR%%/System/MultiMesh.int
+%%DATADIR%%/System/MultiMesh.u
+%%DATADIR%%/System/NullDrv.so
+%%DATADIR%%/System/NullRender.so
+%%DATADIR%%/System/OpenGLDrv.so
+%%DATADIR%%/System/OpenGlDrv.ini
+%%DATADIR%%/System/OpenGlDrv.int
+%%DATADIR%%/System/Relics.int
+%%DATADIR%%/System/Relics.u
+%%DATADIR%%/System/RelicsBindings.int
+%%DATADIR%%/System/RelicsBindings.u
+%%DATADIR%%/System/Render.so
+%%DATADIR%%/System/SDLDrv.so
+%%DATADIR%%/System/SDLGLDrv.int
+%%DATADIR%%/System/SDLGLDrv.so
+%%DATADIR%%/System/SDLSoftDrv.int
+%%DATADIR%%/System/SDLSoftDrv.so
+%%DATADIR%%/System/SGLDrv.int
+%%DATADIR%%/System/SGirlSkins.int
+%%DATADIR%%/System/Setup.int
+%%DATADIR%%/System/SkTrooperSkins.int
+%%DATADIR%%/System/SkeletalChars.int
+%%DATADIR%%/System/SkeletalChars.u
+%%DATADIR%%/System/SoftDrv.int
+%%DATADIR%%/System/SoldierSkins.int
+%%DATADIR%%/System/Startup.int
+%%DATADIR%%/System/TCowMeshSkins.int
+%%DATADIR%%/System/TNaliMeshSkins.int
+%%DATADIR%%/System/TSkMSkins.int
+%%DATADIR%%/System/UBrowser.int
+%%DATADIR%%/System/UBrowser.u
+%%DATADIR%%/System/UMenu.int
+%%DATADIR%%/System/UMenu.u
+%%DATADIR%%/System/UTBrowser.u
+%%DATADIR%%/System/UTMenu.int
+%%DATADIR%%/System/UTMenu.u
+%%DATADIR%%/System/UTServerAdmin.int
+%%DATADIR%%/System/UTServerAdmin.u
+%%DATADIR%%/System/UWeb.int
+%%DATADIR%%/System/UWeb.so
+%%DATADIR%%/System/UWeb.u
+%%DATADIR%%/System/UWindow.u
+%%DATADIR%%/System/Unreal.int
+%%DATADIR%%/System/UnrealEd.int
+%%DATADIR%%/System/UnrealI.int
+%%DATADIR%%/System/UnrealI.u
+%%DATADIR%%/System/UnrealIOrder.int
+%%DATADIR%%/System/UnrealShare.int
+%%DATADIR%%/System/UnrealShare.u
+%%DATADIR%%/System/UnrealTournament.ini
+%%DATADIR%%/System/UnrealTournament.int
+%%DATADIR%%/System/User.ini
+%%DATADIR%%/System/WinDrv.int
+%%DATADIR%%/System/Window.int
+%%DATADIR%%/System/de-logo.bmp
+%%DATADIR%%/System/de.int
+%%DATADIR%%/System/de.u
+%%DATADIR%%/System/libSDL-1.1.so.0
+%%DATADIR%%/System/libmikmod.so.2
+%%DATADIR%%/System/libopenal-0.0.so
+%%DATADIR%%/System/license.int
+%%DATADIR%%/System/ucc-bin
+%%DATADIR%%/System/ut-bin
+%%DATADIR%%/Textures/AlfaFX.utx
+%%DATADIR%%/Textures/Ancient.utx
+%%DATADIR%%/Textures/ArenaTex.utx
+%%DATADIR%%/Textures/Belt_fx.utx
+%%DATADIR%%/Textures/BluffFX.utx
+%%DATADIR%%/Textures/BossSkins.utx
+%%DATADIR%%/Textures/CTF.utx
+%%DATADIR%%/Textures/ChizraEFX.utx
+%%DATADIR%%/Textures/Coret_FX.utx
+%%DATADIR%%/Textures/Creative.utx
+%%DATADIR%%/Textures/Crypt.utx
+%%DATADIR%%/Textures/Crypt2.utx
+%%DATADIR%%/Textures/Crypt_FX.utx
+%%DATADIR%%/Textures/DDayFX.utx
+%%DATADIR%%/Textures/DMeffects.utx
+%%DATADIR%%/Textures/DacomaFem.utx
+%%DATADIR%%/Textures/DacomaSkins.utx
+%%DATADIR%%/Textures/DecayedS.utx
+%%DATADIR%%/Textures/Detail.utx
+%%DATADIR%%/Textures/Egypt.utx
+%%DATADIR%%/Textures/EgyptPan.utx
+%%DATADIR%%/Textures/FCommandoSkins.utx
+%%DATADIR%%/Textures/Faces.utx
+%%DATADIR%%/Textures/Factory.utx
+%%DATADIR%%/Textures/Female1Skins.utx
+%%DATADIR%%/Textures/Female2Skins.utx
+%%DATADIR%%/Textures/FireEng.utx
+%%DATADIR%%/Textures/FlareFX.utx
+%%DATADIR%%/Textures/FractalFX.utx
+%%DATADIR%%/Textures/GenEarth.utx
+%%DATADIR%%/Textures/GenFX.utx
+%%DATADIR%%/Textures/GenFluid.utx
+%%DATADIR%%/Textures/GenIn.utx
+%%DATADIR%%/Textures/GenTerra.utx
+%%DATADIR%%/Textures/GenWarp.utx
+%%DATADIR%%/Textures/GothFem.utx
+%%DATADIR%%/Textures/GothSkins.utx
+%%DATADIR%%/Textures/GreatFire.utx
+%%DATADIR%%/Textures/GreatFire2.utx
+%%DATADIR%%/Textures/HubEffects.utx
+%%DATADIR%%/Textures/ISVFX.utx
+%%DATADIR%%/Textures/Indus1.utx
+%%DATADIR%%/Textures/Indus2.utx
+%%DATADIR%%/Textures/Indus3.utx
+%%DATADIR%%/Textures/Indus4.utx
+%%DATADIR%%/Textures/Indus5.utx
+%%DATADIR%%/Textures/Indus6.utx
+%%DATADIR%%/Textures/Indus7.utx
+%%DATADIR%%/Textures/JWSky.utx
+%%DATADIR%%/Textures/LadderFonts.utx
+%%DATADIR%%/Textures/LadrArrow.utx
+%%DATADIR%%/Textures/LadrStatic.utx
+%%DATADIR%%/Textures/LavaFX.utx
+%%DATADIR%%/Textures/Lian-X.utx
+%%DATADIR%%/Textures/Liquids.utx
+%%DATADIR%%/Textures/Logo.utx
+%%DATADIR%%/Textures/Male1Skins.utx
+%%DATADIR%%/Textures/Male2Skins.utx
+%%DATADIR%%/Textures/Male3Skins.utx
+%%DATADIR%%/Textures/MenuGr.utx
+%%DATADIR%%/Textures/Metalmys.utx
+%%DATADIR%%/Textures/Mine.utx
+%%DATADIR%%/Textures/NaliCast.utx
+%%DATADIR%%/Textures/NaliFX.utx
+%%DATADIR%%/Textures/NivenFX.utx
+%%DATADIR%%/Textures/Old_FX.utx
+%%DATADIR%%/Textures/Palettes.utx
+%%DATADIR%%/Textures/PhraelFx.utx
+%%DATADIR%%/Textures/PlayrShp.utx
+%%DATADIR%%/Textures/Queen.utx
+%%DATADIR%%/Textures/RainFX.utx
+%%DATADIR%%/Textures/Render.utx
+%%DATADIR%%/Textures/RotatingU.utx
+%%DATADIR%%/Textures/SGTech1.utx
+%%DATADIR%%/Textures/SGirlSkins.utx
+%%DATADIR%%/Textures/Scripted.utx
+%%DATADIR%%/Textures/ShaneChurch.utx
+%%DATADIR%%/Textures/ShaneDay.utx
+%%DATADIR%%/Textures/ShaneSky.utx
+%%DATADIR%%/Textures/SkTrooperSkins.utx
+%%DATADIR%%/Textures/Skaarj.utx
+%%DATADIR%%/Textures/SkyBox.utx
+%%DATADIR%%/Textures/SkyCity.utx
+%%DATADIR%%/Textures/Slums.utx
+%%DATADIR%%/Textures/Soldierskins.utx
+%%DATADIR%%/Textures/SpaceFX.utx
+%%DATADIR%%/Textures/Starship.utx
+%%DATADIR%%/Textures/TCowMeshSkins.utx
+%%DATADIR%%/Textures/TCrystal.utx
+%%DATADIR%%/Textures/TNaliMeshSkins.utx
+%%DATADIR%%/Textures/TSkMSkins.utx
+%%DATADIR%%/Textures/Terranius.utx
+%%DATADIR%%/Textures/TrenchesFX.utx
+%%DATADIR%%/Textures/UT.utx
+%%DATADIR%%/Textures/UT_ArtFX.utx
+%%DATADIR%%/Textures/UTbase1.utx
+%%DATADIR%%/Textures/UTcrypt.utx
+%%DATADIR%%/Textures/UTtech1.utx
+%%DATADIR%%/Textures/UTtech2.utx
+%%DATADIR%%/Textures/UTtech3.utx
+%%DATADIR%%/Textures/UWindowFonts.utx
+%%DATADIR%%/Textures/XFX.utx
+%%DATADIR%%/Textures/XbpFX.utx
+%%DATADIR%%/Textures/Xtortion.utx
+%%DATADIR%%/Textures/castle1.utx
+%%DATADIR%%/Textures/city.utx
+%%DATADIR%%/Textures/commandoskins.utx
+%%DATADIR%%/Textures/credits.utx
+%%DATADIR%%/Textures/eol.utx
+%%DATADIR%%/Textures/noxxpack.utx
+%%DATADIR%%/Textures/of1.utx
+%%DATADIR%%/Textures/xutfx.utx
+%%DATADIR%%/Web/current.uhtm
+%%DATADIR%%/Web/current_console.uhtm
+%%DATADIR%%/Web/current_console_log.uhtm
+%%DATADIR%%/Web/current_console_send.uhtm
+%%DATADIR%%/Web/current_game.uhtm
+%%DATADIR%%/Web/current_menu.uhtm
+%%DATADIR%%/Web/current_mutators.uhtm
+%%DATADIR%%/Web/current_players.uhtm
+%%DATADIR%%/Web/defaults.uhtm
+%%DATADIR%%/Web/defaults_bots.uhtm
+%%DATADIR%%/Web/defaults_ippolicy-d.uhtm
+%%DATADIR%%/Web/defaults_ippolicy-f.uhtm
+%%DATADIR%%/Web/defaults_ippolicy-h.uhtm
+%%DATADIR%%/Web/defaults_maps.uhtm
+%%DATADIR%%/Web/defaults_menu.uhtm
+%%DATADIR%%/Web/defaults_rules.uhtm
+%%DATADIR%%/Web/defaults_server.uhtm
+%%DATADIR%%/Web/defaults_settings.uhtm
+%%DATADIR%%/Web/images/1-1.gif
+%%DATADIR%%/Web/images/1-2.gif
+%%DATADIR%%/Web/images/1.gif
+%%DATADIR%%/Web/images/2-1.gif
+%%DATADIR%%/Web/images/2-2.gif
+%%DATADIR%%/Web/images/3-1.gif
+%%DATADIR%%/Web/images/3-2.gif
+%%DATADIR%%/Web/images/4-1.gif
+%%DATADIR%%/Web/images/4-2.gif
+%%DATADIR%%/Web/images/5-1.gif
+%%DATADIR%%/Web/images/5-2.gif
+%%DATADIR%%/Web/images/6-1.gif
+%%DATADIR%%/Web/images/6-2.gif
+%%DATADIR%%/Web/images/7-1.gif
+%%DATADIR%%/Web/images/7-2.gif
+%%DATADIR%%/Web/images/7-3.gif
+%%DATADIR%%/Web/images/image.gif
+%%DATADIR%%/Web/images/logo.gif
+%%DATADIR%%/Web/images/m1-1.gif
+%%DATADIR%%/Web/images/m1-2.gif
+%%DATADIR%%/Web/images/m3-1.gif
+%%DATADIR%%/Web/images/m3-2.gif
+%%DATADIR%%/Web/images/right.gif
+%%DATADIR%%/Web/menu.uhtm
+%%DATADIR%%/Web/message.uhtm
+%%DATADIR%%/Web/plaintext/current.uhtm
+%%DATADIR%%/Web/plaintext/current_console.uhtm
+%%DATADIR%%/Web/plaintext/current_console_log.uhtm
+%%DATADIR%%/Web/plaintext/current_console_send.uhtm
+%%DATADIR%%/Web/plaintext/current_game.uhtm
+%%DATADIR%%/Web/plaintext/current_menu.uhtm
+%%DATADIR%%/Web/plaintext/current_mutators.uhtm
+%%DATADIR%%/Web/plaintext/current_players.uhtm
+%%DATADIR%%/Web/plaintext/defaults.uhtm
+%%DATADIR%%/Web/plaintext/defaults_bots.uhtm
+%%DATADIR%%/Web/plaintext/defaults_ippolicy-d.uhtm
+%%DATADIR%%/Web/plaintext/defaults_ippolicy-f.uhtm
+%%DATADIR%%/Web/plaintext/defaults_ippolicy-h.uhtm
+%%DATADIR%%/Web/plaintext/defaults_maps.uhtm
+%%DATADIR%%/Web/plaintext/defaults_menu.uhtm
+%%DATADIR%%/Web/plaintext/defaults_rules.uhtm
+%%DATADIR%%/Web/plaintext/defaults_server.uhtm
+%%DATADIR%%/Web/plaintext/defaults_settings.uhtm
+%%DATADIR%%/Web/plaintext/menu.uhtm
+%%DATADIR%%/Web/plaintext/message.uhtm
+%%DATADIR%%/Web/plaintext/root.uhtm
+%%DATADIR%%/Web/root.uhtm
+@dirrm %%DATADIR%%/Help
+@dirrm %%DATADIR%%/Logs
+@dirrm %%DATADIR%%/Maps
+@dirrm %%DATADIR%%/Music
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/data
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/graphics
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Highest_Score
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Last_Game
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/Individual_Game_Stats
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/custom_graphics
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/skins
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html/Total_Game_Stats
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/html
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats/processedLogs
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngStats
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngWorldStats/bin
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngWorldStats/logs
+@dirrm %%DATADIR%%/NetGamesUSA.com/ngWorldStats
+@dirrm %%DATADIR%%/NetGamesUSA.com
+@dirrm %%DATADIR%%/Sounds
+@dirrm %%DATADIR%%/System
+@dirrm %%DATADIR%%/Textures
+@dirrm %%DATADIR%%/Web/images
+@dirrm %%DATADIR%%/Web/plaintext
+@dirrm %%DATADIR%%/Web
+@dirrm %%DATADIR%%