aboutsummaryrefslogtreecommitdiff
path: root/games/luola/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-22 20:04:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-22 20:04:34 +0000
commit5bc2b70b0402f170e149012d03555ad223ae2a50 (patch)
treeb4706b68de32c90bf342dcb8bd11fc45492ff15c /games/luola/Makefile
parent106e69742bab2d8e2e8d79cf73bda94365aa9948 (diff)
Notes
Diffstat (limited to 'games/luola/Makefile')
-rw-r--r--games/luola/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/games/luola/Makefile b/games/luola/Makefile
new file mode 100644
index 000000000000..304702c53003
--- /dev/null
+++ b/games/luola/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: luola
+# Date created: 20 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= luola
+PORTVERSION= 1.3.0
+CATEGORIES= games
+MASTER_SITES= http://www.luolamies.org/software/luola/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ stdlevels-5.2${EXTRACT_SUFX} \
+ nostalgia-1.1${EXTRACT_SUFX}
+DIST_SUBDIR= luola
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Multiplayer Cave-flying game
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl image ttf
+
+CONFIGURE_ARGS= --program-prefix=''
+
+OPTIONS= SDL_GFX "Enable sdl_gfx for nicer graphics" on \
+ SOUND "Enable sound" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SDL_GFX)
+CONFIGURE_ARGS+= --disable-sdl-gfx
+.else
+USE_SDL+= gfx
+.endif
+
+.if !defined(WITHOUT_SOUND)
+CONFIGURE_ARGS+= --enable-sound
+USE_SDL+= mixer
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/audio.c ${WRKSRC}/src/startup.c ${WRKSRC}/tools/lcmaptool.c
+ @${REINPLACE_CMD} -e '/LIBS=.*-lSDL_/ s|\(SDL_[a-z]*\)|\1 `sdl11-config --libs`|' ${WRKSRC}/configure
+
+post-install:
+ @${INSTALL_DATA} ${WRKDIR}/*.lev ${WRKDIR}/*.png ${DATADIR}/levels
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in README FAQ
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>