aboutsummaryrefslogtreecommitdiff
path: root/games/lwjgl
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-11-26 12:12:55 +0000
committerChris Rees <crees@FreeBSD.org>2012-11-26 12:12:55 +0000
commit716b6bc1f99c3f6282be347c15d4a67c227085c9 (patch)
tree47d19d6a8b6389418bf0ee8ad2085dd7360e363a /games/lwjgl
parent465a7968c30d8b07594da593e5e7fac859b50ccc (diff)
downloadports-716b6bc1f99c3f6282be347c15d4a67c227085c9.tar.gz
ports-716b6bc1f99c3f6282be347c15d4a67c227085c9.zip
Notes
Diffstat (limited to 'games/lwjgl')
-rw-r--r--games/lwjgl/Makefile30
-rw-r--r--games/lwjgl/distinfo6
-rw-r--r--games/lwjgl/files/patch-build.xml67
-rw-r--r--games/lwjgl/files/patch-platform_build__build-applet.xml21
-rw-r--r--games/lwjgl/files/patch-platform_build__linux_ant__build.xml39
-rw-r--r--games/lwjgl/files/patch-src__java__org__lwjgl__MacOSXSysImplementation.java23
-rw-r--r--games/lwjgl/files/patch-src__java__org__lwjgl__opengl__MacOSXDisplay.java32
7 files changed, 48 insertions, 170 deletions
diff --git a/games/lwjgl/Makefile b/games/lwjgl/Makefile
index 0e28f51adae8..8f37ba03d3e5 100644
--- a/games/lwjgl/Makefile
+++ b/games/lwjgl/Makefile
@@ -1,19 +1,19 @@
-# New ports collection makefile for: jinput
-# Date created: Mar 25 2012
-# Whom: loader <loader@freebsdmall.com>
-#
+# Created by: loader <loader@freebsdmall.com>
# $FreeBSD$
-#
PORTNAME= lwjgl
-DISTVERSION= 2.7.1
+DISTVERSION= 2.8.5
CATEGORIES= games java
MASTER_SITES= SF/java-game-lib/Official%20Releases/${PORTNAME:U}%20${PORTVERSION}/
-DISTNAME= ${PORTNAME}-source-${DISTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-source-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= loader@freebsdmall.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= The Lightweight Java Game Library
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/${DISTNAME}/doc/LICENSE
+
BUILD_DEPENDS= ${JAVALIBDIR}/jutils/jutils.jar:${PORTSDIR}/games/jutils \
${JAVALIBDIR}/jinput/jinput.jar:${PORTSDIR}/games/jinput \
${LOCALBASE}/include/X11/extensions/xf86vmode.h:${PORTSDIR}/x11/libXxf86vm \
@@ -33,11 +33,12 @@ USE_ZIP= yes
USE_JAVA= yes
USE_LDCONFIG= yes
USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*.[^j][^a][^r]$
JAVA_VERSION= 1.6+
JAVA_OS= native
JAVA_VENDOR= openjdk
USE_ANT= yes
-MAKE_ENV+= CLASSPATH=${JAVALIBDIR}/jutils/jutils.jar:${JAVALIBDIR}/jinput/jinput.jar
+MAKE_ENV+= CLASSPATH=${JAVALIBDIR}/jutils/jutils.jar:${JAVALIBDIR}/jinput/jinput.jar:${WRKSRC}/${DISTNAME}/jar/
ALL_TARGET= jars compile_native
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}/${PORTNAME}.jar \
@@ -49,14 +50,17 @@ PLIST_DIRS= %%JAVAJARDIR%%/${PORTNAME} \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
PLIST_FILES+= lib/${PORTNAME}${PORTVERSION}/lib${PORTNAME}.so
.endif
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
PLIST_FILES+= lib/${PORTNAME}${PORTVERSION}/lib${PORTNAME}64.so
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's,PREFIX,${PREFIX},g' ${WRKSRC}/platform_build/linux_ant/build.xml
+
do-install:
@${ECHO_MSG} -n ">> Install JAR files in ${JAVAJARDIR}/${PORTNAME}/ ..."
@${MKDIR} ${JAVAJARDIR}/${PORTNAME}
@@ -65,10 +69,10 @@ do-install:
.endfor
@${ECHO_MSG} " [ DONE ]"
@${MKDIR} ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
@${INSTALL_DATA} ${WRKSRC}/libs/linux/lib${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
.endif
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
@${INSTALL_DATA} ${WRKSRC}/libs/linux/lib${PORTNAME}64.so ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
.endif
diff --git a/games/lwjgl/distinfo b/games/lwjgl/distinfo
index 2bd509c7f0f9..7870effa48d3 100644
--- a/games/lwjgl/distinfo
+++ b/games/lwjgl/distinfo
@@ -1,2 +1,4 @@
-SHA256 (lwjgl-source-2.7.1.zip) = f6805e7ec4f00198b772063d0df5e2063f44ce839f615677b9bc68ad037644b6
-SIZE (lwjgl-source-2.7.1.zip) = 2149031
+SHA256 (lwjgl-2.8.5.zip) = 680e4c9f84ca89fad844820019a9134c4643a00a44e3d6a02defb3d38700492c
+SIZE (lwjgl-2.8.5.zip) = 5550071
+SHA256 (lwjgl-source-2.8.5.zip) = b52f8885fb5a2cb9cd2528a9492164fccdf63031fbafb2ac96fd0f271fcbb130
+SIZE (lwjgl-source-2.8.5.zip) = 2969449
diff --git a/games/lwjgl/files/patch-build.xml b/games/lwjgl/files/patch-build.xml
index f746b8ded716..2260c3744546 100644
--- a/games/lwjgl/files/patch-build.xml
+++ b/games/lwjgl/files/patch-build.xml
@@ -1,59 +1,14 @@
-Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
-
-
---- ./build.xml.orig 2011-02-06 19:23:40.000000000 +0000
-+++ ./build.xml 2012-03-26 18:14:03.079373854 +0000
-@@ -246,7 +246,7 @@
- <class name="org.lwjgl.opengl.WindowsContextImplementation" />
- </javah>
+--- build.xml.orig
++++ build.xml
+@@ -7,7 +7,6 @@
+ <import file="platform_build/build-applet.xml"/>
+ <import file="platform_build/build-webstart.xml"/>
+ <import file="platform_build/build-maven.xml"/>
+- <import file="eclipse-update/org.lwjgl.build/build-updatesite.xml"/>
-- <javah classpath="${lwjgl.bin}" destdir="${lwjgl.src.native}/macosx" force="yes">
-+ <!-- <javah classpath="${lwjgl.bin}" destdir="${lwjgl.src.native}/macosx" force="yes">
- <class name="org.lwjgl.MacOSXSysImplementation" />
- <class name="org.lwjgl.opengl.MacOSXMouseEventQueue" />
- <class name="org.lwjgl.opengl.MacOSXCanvasPeerInfo" />
-@@ -254,7 +254,7 @@
- <class name="org.lwjgl.opengl.MacOSXPbufferPeerInfo" />
- <class name="org.lwjgl.opengl.MacOSXDisplay" />
- <class name="org.lwjgl.opengl.MacOSXContextImplementation" />
-- </javah>
-+ </javah> -->
-
- <javah classpath="${lwjgl.bin}" destdir="${lwjgl.src.headers}" force="yes">
- <class name="org.lwjgl.opengl.AWTSurfaceLock" />
-@@ -293,13 +293,13 @@
- </tokenfilter>
- </filterchain>
- </loadfile>
-- <loadfile srcfile="${lwjgl.src}/java/org/lwjgl/MacOSXSysImplementation.java" property="lwjgl.java.macosx.version">
-+ <!-- <loadfile srcfile="${lwjgl.src}/java/org/lwjgl/MacOSXSysImplementation.java" property="lwjgl.java.macosx.version">
- <filterchain>
- <tokenfilter>
- <containsstring contains="JNI_VERSION ="/>
- </tokenfilter>
- </filterchain>
-- </loadfile>
-+ </loadfile> -->
- <loadfile srcfile="${lwjgl.src.native}/windows/org_lwjgl_WindowsSysImplementation.h" property="lwjgl.native.windows.version">
- <filterchain>
- <tokenfilter>
-@@ -314,13 +314,13 @@
- </tokenfilter>
- </filterchain>
- </loadfile>
-- <loadfile srcfile="${lwjgl.src.native}/macosx/org_lwjgl_MacOSXSysImplementation.h" property="lwjgl.native.macosx.version">
-+ <!-- <loadfile srcfile="${lwjgl.src.native}/macosx/org_lwjgl_MacOSXSysImplementation.h" property="lwjgl.native.macosx.version">
- <filterchain>
- <tokenfilter>
- <containsstring contains="#define org_lwjgl_MacOSXSysImplementation_JNI_VERSION"/>
- </tokenfilter>
- </filterchain>
-- </loadfile>
-+ </loadfile> -->
- <echo>
- lwjgl.java.windows.version = ${lwjgl.java.windows.version}
- lwjgl.native.windows.version = ${lwjgl.native.windows.version}
-@@ -380,7 +380,10 @@
+ <!-- ================================================================== -->
+ <!-- Everything below this line is targets. -->
+@@ -463,7 +462,10 @@
<antcall target="-compile_native_win32" />
<condition property="lwjgl.platform.linux">
@@ -65,7 +20,7 @@ Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
</condition>
<antcall target="-compile_native_linux" />
-@@ -493,6 +496,7 @@
+@@ -604,6 +606,7 @@
<condition property="native_path" value="libs/linux">
<or>
<os name="Linux" />
diff --git a/games/lwjgl/files/patch-platform_build__build-applet.xml b/games/lwjgl/files/patch-platform_build__build-applet.xml
deleted file mode 100644
index 99b3375318f3..000000000000
--- a/games/lwjgl/files/patch-platform_build__build-applet.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
-
-
---- ./platform_build/build-applet.xml.orig 2011-02-06 19:22:46.000000000 +0000
-+++ ./platform_build/build-applet.xml 2012-03-26 18:14:03.104373501 +0000
-@@ -1,7 +1,7 @@
- <project name="applet">
-
- <!-- Create our packer task -->
-- <taskdef name="pack200" classname="com.sun.tools.apache.ant.pack200.Pack200Task" classpath="platform_build/Pack200Task.jar"/>
-+ <!-- <taskdef name="pack200" classname="com.sun.tools.apache.ant.pack200.Pack200Task" classpath="platform_build/Pack200Task.jar"/> -->
-
- <target name="applet">
- <antcall target="-applet">
-@@ -144,4 +144,4 @@
- <param name="output" value="applet/advance/solaris_natives.jar.lzma"/>
- </antcall>
- </target>
--</project>
-\ No newline at end of file
-+</project>
diff --git a/games/lwjgl/files/patch-platform_build__linux_ant__build.xml b/games/lwjgl/files/patch-platform_build__linux_ant__build.xml
index 5bd2aa378caf..31ae524dd408 100644
--- a/games/lwjgl/files/patch-platform_build__linux_ant__build.xml
+++ b/games/lwjgl/files/patch-platform_build__linux_ant__build.xml
@@ -1,16 +1,13 @@
-Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
-
-
---- ./platform_build/linux_ant/build.xml.orig 2011-02-06 19:22:44.000000000 +0000
-+++ ./platform_build/linux_ant/build.xml 2012-03-26 18:14:03.120371531 +0000
+--- platform_build/linux_ant/build.xml.orig
++++ platform_build/linux_ant/build.xml
@@ -4,8 +4,8 @@
<property name="native" location="../../src/native"/>
<property name="libname32" value="liblwjgl.so"/>
<property name="libname64" value="liblwjgl64.so"/>
- <property name="libs32" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXext -lXcursor -lXrandr -lpthread -L${java.home}/lib/i386 -ljawt" />
- <property name="libs64" value="-L/usr/X11R6/lib64 -L/usr/X11/lib64 -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/amd64 -ljawt" />
-+ <property name="libs32" value="-L/usr/lib -L/usr/local/lib -lm -lX11 -lXext -lXcursor -lXrandr -lpthread -L${java.home}/lib/i386 -ljawt" />
-+ <property name="libs64" value="-L/usr/lib -L/usr/local/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/amd64 -ljawt" />
++ <property name="libs32" value="-LPREFIX/lib -lm -lX11 -lXext -lXcursor -lXrandr -pthread -L${java.home}/lib/i386 -ljawt" />
++ <property name="libs64" value="-LPREFIX/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -pthread -L${java.home}/lib/amd64 -ljawt" />
<property name="cflags32" value="-O2 -Wall -c -fPIC -std=c99 -Wunused"/>
<target name="clean">
@@ -43,33 +40,29 @@ Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
</condition>
<antcall target="compile32"/>
-@@ -69,11 +76,14 @@
- <arg line="${cflags32} ${cflags_pthread}"/>
- <arg value="-I${java.home}/include"/>
- <arg value="-I${java.home}/include/linux"/>
-+ <arg value="-I${java.home}/include/freebsd"/>
+@@ -72,10 +79,12 @@
<arg value="-I${java.home}/../include"/>
<arg value="-I${java.home}/../include/linux"/>
<arg value="-I${java.home}/../include/solaris"/>
+ <arg value="-I${java.home}/../include/freebsd"/>
<arg value="-I${native}/common"/>
+ <arg value="-I${native}/common/opengl"/>
<arg value="-I${native}/linux"/>
-+ <arg value="-I/usr/local/include"/>
+ <arg value="-I${native}/linux/opengl"/>
++ <arg value="-IPREFIX/include"/>
<mapper type="glob" from="*.c" to="*.o"/>
- <fileset dir="${native}/linux" includes="*.c"/>
- <fileset dir="${native}/generated" includes="*.c"/>
-@@ -95,11 +105,14 @@
- <arg line="${cflags64} ${cflags_pthread}"/>
- <arg value="-I${java.home}/include"/>
- <arg value="-I${java.home}/include/linux"/>
-+ <arg value="-I${java.home}/include/freebsd"/>
+ <fileset dir="${native}/common" includes="*.c"/>
+ <fileset dir="${native}/common/opengl" includes="*.c"/>
+@@ -104,10 +113,12 @@
<arg value="-I${java.home}/../include"/>
<arg value="-I${java.home}/../include/linux"/>
<arg value="-I${java.home}/../include/solaris"/>
+ <arg value="-I${java.home}/../include/freebsd"/>
<arg value="-I${native}/common"/>
+ <arg value="-I${native}/common/opengl"/>
<arg value="-I${native}/linux"/>
-+ <arg value="-I/usr/local/include"/>
+ <arg value="-I${native}/linux/opengl"/>
++ <arg value="-IPREFIX/include"/>
<mapper type="glob" from="*.c" to="*.o"/>
- <fileset dir="${native}/linux" includes="*.c"/>
- <fileset dir="${native}/generated" includes="*.c"/>
+ <fileset dir="${native}/common" includes="*.c"/>
+ <fileset dir="${native}/common/opengl" includes="*.c"/>
diff --git a/games/lwjgl/files/patch-src__java__org__lwjgl__MacOSXSysImplementation.java b/games/lwjgl/files/patch-src__java__org__lwjgl__MacOSXSysImplementation.java
deleted file mode 100644
index ada378a46ff4..000000000000
--- a/games/lwjgl/files/patch-src__java__org__lwjgl__MacOSXSysImplementation.java
+++ /dev/null
@@ -1,23 +0,0 @@
-Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
-
-
---- ./src/java/org/lwjgl/MacOSXSysImplementation.java.orig 2011-02-06 19:23:32.000000000 +0000
-+++ ./src/java/org/lwjgl/MacOSXSysImplementation.java 2012-03-26 18:14:03.135376460 +0000
-@@ -33,7 +33,7 @@
-
- import java.awt.Toolkit;
-
--import com.apple.eio.FileManager;
-+// import com.apple.eio.FileManager;
-
- /**
- *
-@@ -55,7 +55,7 @@
-
- public boolean openURL(String url) {
- try {
-- FileManager.openURL(url);
-+ // FileManager.openURL(url);
- return true;
- } catch (Exception e) {
- LWJGLUtil.log("Exception occurred while trying to invoke browser: " + e);
diff --git a/games/lwjgl/files/patch-src__java__org__lwjgl__opengl__MacOSXDisplay.java b/games/lwjgl/files/patch-src__java__org__lwjgl__opengl__MacOSXDisplay.java
deleted file mode 100644
index c757b88e322e..000000000000
--- a/games/lwjgl/files/patch-src__java__org__lwjgl__opengl__MacOSXDisplay.java
+++ /dev/null
@@ -1,32 +0,0 @@
-Obtained from http://foo.poildetroll.net/minecraft/lwjgl-2.7.1-freebsd.diff
-
-
---- ./src/java/org/lwjgl/opengl/MacOSXDisplay.java.orig 2011-02-06 19:23:26.000000000 +0000
-+++ ./src/java/org/lwjgl/opengl/MacOSXDisplay.java 2012-03-26 18:14:03.153375501 +0000
-@@ -54,9 +54,9 @@
- import org.lwjgl.LWJGLException;
- import org.lwjgl.LWJGLUtil;
-
--import com.apple.eawt.Application;
--import com.apple.eawt.ApplicationAdapter;
--import com.apple.eawt.ApplicationEvent;
-+// import com.apple.eawt.Application;
-+// import com.apple.eawt.ApplicationAdapter;
-+// import com.apple.eawt.ApplicationEvent;
-
- import static org.lwjgl.opengl.GL11.*;
-
-@@ -79,11 +79,11 @@
- try {
- AccessController.doPrivileged(new PrivilegedExceptionAction<Object>() {
- public Object run() throws Exception {
-- Application.getApplication().addApplicationListener(new ApplicationAdapter() {
-+/* Application.getApplication().addApplicationListener(new ApplicationAdapter() {
- public void handleQuit(ApplicationEvent event) {
- doHandleQuit();
- }
-- });
-+ }); */
- return null;
- }
- });