aboutsummaryrefslogtreecommitdiff
path: root/games/mari0
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-01-19 15:50:48 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-01-19 15:50:48 +0000
commitafbbcb92c598a9e5e0bcda51e887e2aa8db24df6 (patch)
tree4a561fbddd23c466c6aff078919ae93a5be3ba96 /games/mari0
parentf7b5fefe053adff92463b781f2d4d2a77d0c9b77 (diff)
Notes
Diffstat (limited to 'games/mari0')
-rw-r--r--games/mari0/Makefile41
-rw-r--r--games/mari0/distinfo3
-rw-r--r--games/mari0/files/mari0.in3
-rw-r--r--games/mari0/pkg-descr14
4 files changed, 61 insertions, 0 deletions
diff --git a/games/mari0/Makefile b/games/mari0/Makefile
new file mode 100644
index 000000000000..1135eb1f8140
--- /dev/null
+++ b/games/mari0/Makefile
@@ -0,0 +1,41 @@
+# Created by: Mahdi Mokhtari <mokhi64@gmail.com>
+# $FreeBSD$
+
+PORTNAME= mari0
+PORTVERSION= 1.6
+CATEGORIES= games
+MASTER_SITES= http://stabyourself.net/dl.php?file=${PORTNAME}-${PORTVERSION:C/\./00/}/
+DISTNAME= ${PORTNAME}-source
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mokhi64@gmail.com
+COMMENT= Nintendo\'s Super Mario Bros and Valve\'s Portal at same time
+
+LICENSE= CC-BY-NC-SA-3.0
+
+RUN_DEPENDS= love:devel/love
+
+USES= zip
+NO_BUILD= yes
+NO_ARCH= yes
+
+SUB_FILES= mari0
+SUB_LIST+= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
+
+PLIST_FILES= bin/mari0
+PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${PORTVERSION}.love \
+ ${STAGEDIR}${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/readme.txt ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/mari0/distinfo b/games/mari0/distinfo
new file mode 100644
index 000000000000..887d93018f83
--- /dev/null
+++ b/games/mari0/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484752394
+SHA256 (mari0-1.6/mari0-source.zip) = b217134425527e879d5355eb7f51e29a60ad0e93550e5769b2f56c04a1f69037
+SIZE (mari0-1.6/mari0-source.zip) = 3625226
diff --git a/games/mari0/files/mari0.in b/games/mari0/files/mari0.in
new file mode 100644
index 000000000000..8738a2d94f17
--- /dev/null
+++ b/games/mari0/files/mari0.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec %%LOCALBASE%%/bin/love %%DATADIR%%/%%PORTNAME%%_%%PORTVERSION%%.love "$@"
diff --git a/games/mari0/pkg-descr b/games/mari0/pkg-descr
new file mode 100644
index 000000000000..8ca92f66afe1
--- /dev/null
+++ b/games/mari0/pkg-descr
@@ -0,0 +1,14 @@
+Mari0 is a fan-made video game that combines
+the Super Mario Bros and Portal games.
+
+I introduces itself with these features:
+ Complete recreation of SMB
+ Elements from Portal
+ Portal gun that shoots portals
+ 4-player simultaneous coop
+ Level Editor that was used to create the levels in the game
+ 33 different hats
+ Downloadable Mappacks
+ Game modifiers for extra fun
+
+WWW: http://stabyourself.net/mari0/