aboutsummaryrefslogtreecommitdiff
path: root/games/marsnomercy/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/marsnomercy/Makefile
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
Notes
Diffstat (limited to 'games/marsnomercy/Makefile')
-rw-r--r--games/marsnomercy/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
index ede1a83261ac..845aadcc0d1f 100644
--- a/games/marsnomercy/Makefile
+++ b/games/marsnomercy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Mars Land of No Mercy
-# Date created: 2006-03-21
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
# $FreeBSD$
-#
PORTNAME= marsnomercy
PORTVERSION= 0.2.1
@@ -27,18 +23,17 @@ PLIST_DIRS= %%DATADIR%%
SUB_FILES= mars-nomercy pkg-message
WRKSRC= ${WRKDIR}/mars-${PORTVERSION}
-OPTIONS= DEBUG "With additional debug information" off \
- OPENGL "Install support for opengl" off
+OPTIONS_DEFINE= DEBUG OPENGL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
SCONS_ARGS+= debug=1
.else
SCONS_ARGS+= debug=0
.endif
-.if defined(WITH_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
SCONS_ARGS+= with_opengl=1
.else
SCONS_ARGS+= with_opengl=0
@@ -64,4 +59,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>