aboutsummaryrefslogtreecommitdiff
path: root/games/marsnomercy/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-08 23:51:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-08 23:51:44 +0000
commitd6e283ec7263ea194c2d1e4ed850249732636bf4 (patch)
tree5e1015276ad6e04804c41bce3a415f20d90561fe /games/marsnomercy/Makefile
parent635862307ebd3ab54e606a2d53f8a52cd5d675cb (diff)
downloadports-d6e283ec7263ea194c2d1e4ed850249732636bf4.tar.gz
ports-d6e283ec7263ea194c2d1e4ed850249732636bf4.zip
Notes
Diffstat (limited to 'games/marsnomercy/Makefile')
-rw-r--r--games/marsnomercy/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
new file mode 100644
index 000000000000..39c21b7f8665
--- /dev/null
+++ b/games/marsnomercy/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: Mars Land of No Mercy
+# Date created: 2006-03-21
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= marsnomercy
+PORTVERSION= 0.1.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mars
+DISTNAME= mars-${PORTVERSION}-src
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= A turn-based strategy game setting on Mars
+
+BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
+
+USE_X_PREFIX= yes
+USE_SDL= sdl image ttf
+MAKE_ENV= CC="${CC}" CXX="${CXX}"
+PLIST= ${WRKDIR}/pkg-plist
+PLIST_FILES= bin/mars-nomercy libexec/mars
+PLIST_DIRS= %%DATADIR%%
+WRKSRC= ${WRKDIR}/mars-${PORTVERSION}
+SUB_FILES= mars-nomercy
+
+OPTIONS= DEBUG "With additional debug information" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+SCONS_ARGS= debug=1
+.else
+SCONS_ARGS= debug=0
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} scons ${SCONS_ARGS}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+ @${INSTALL_SCRIPT} ${WRKDIR}/mars-nomercy ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mars ${PREFIX}/libexec
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>