aboutsummaryrefslogtreecommitdiff
path: root/games/maxr/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-26 20:23:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-26 20:23:00 +0000
commit3edc0d729fa08180860503c8c35576c497918dfa (patch)
tree83a0b57cfeeaf04acacee25bee2685c544ba9f8a /games/maxr/Makefile
parent19a573e01a013eb34484f33d95bef0fc363001d9 (diff)
Notes
Diffstat (limited to 'games/maxr/Makefile')
-rw-r--r--games/maxr/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/maxr/Makefile b/games/maxr/Makefile
new file mode 100644
index 000000000000..be5c8ddd3598
--- /dev/null
+++ b/games/maxr/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: maxr
+# Date created: 23 Dec 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= maxr
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= http://www.maxthegame.de/downloads/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Mechanized Assault and Exploration Reloaded
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl mixer net
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS=/ s|-lSDL_|`${SDL_CONFIG} --libs` &|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/SettingsData.*Path =/ s|"\(.*\)"|"${DATADIR}/\1"|' \
+ ${WRKSRC}/src/loaddata.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/maxr ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} "*" ${DATADIR}
+
+.include <bsd.port.mk>