aboutsummaryrefslogtreecommitdiff
path: root/games/meandmyshadow/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-01-15 06:26:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-01-15 06:26:29 +0000
commite360f3613caf9c9178364c161ea40e951e718987 (patch)
tree8a30cee35f55edbc8df46887cdff91b1c9d14e7f /games/meandmyshadow/Makefile
parent4ec8271d3e097a9e7b79c5a0a0d3396fe8a5aa6d (diff)
Notes
Diffstat (limited to 'games/meandmyshadow/Makefile')
-rw-r--r--games/meandmyshadow/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/games/meandmyshadow/Makefile b/games/meandmyshadow/Makefile
new file mode 100644
index 000000000000..6423fb49cec9
--- /dev/null
+++ b/games/meandmyshadow/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: meandmyshadow
+# Date created: 15 Jan 2012
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meandmyshadow
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Me and My Shadow puzzle/platform game
+
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+
+USE_CMAKE= yes
+USE_SDL= sdl ttf image mixer image gfx
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PORTDOCS= *
+
+DESKTOP_ENTRIES="Me and My Shadow" \
+ "Puzzle/platform game" \
+ "${DATADIR}/meandmyshadow.ico" \
+ "meandmyshadow" \
+ "Game;LogicGame;" \
+ false
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/cmake/Modules/FindSDL_gfx.cmake
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/windows-icon/meandmyshadow.ico \
+ ${DATADIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Controls.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>