aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-21 04:17:58 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-07-21 04:17:58 +0000
commit8c12f790cf6b06f3098a6b962ae52143e69e5a25 (patch)
tree2ee39e6bf075d37d209a48eb79e2126640ecf49d /games/megaglest/Makefile
parentee27b6e61d098de11f93aa594ee6d3dd3cad0038 (diff)
Notes
Diffstat (limited to 'games/megaglest/Makefile')
-rw-r--r--games/megaglest/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index eb33945ba7eb..0c93247d35ab 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= megaglest
-PORTVERSION= 3.4.0
+PORTVERSION= 3.5.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/current_release/
-DISTNAME= ${PORTNAME}-source-${PORTVERSION}
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}.3
MAINTAINER= smoeller@nichthelfer.de
COMMENT= Open source 3D real-time strategy game
@@ -21,9 +21,9 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
vorbis.4:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= ${DATADIR}/tutorials/basic_tutorial/basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
-SUB_FILES= glest-wrapper pkg-message
+SUB_FILES= pkg-message
-USE_BZIP2= yes
+USE_XZ= yes
USE_CMAKE= yes
USE_DOS2UNIX= yes
USE_GL= yes
@@ -32,6 +32,8 @@ USE_OPENAL= al alut
USE_SDL= yes
USE_WX= 2.8+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
OPTIONS= EDITOR "Install MegaGlest Editor" off
.include <bsd.port.options.mk>
@@ -43,21 +45,20 @@ PLIST_SUB+= EDITOR="@comment "
.endif
do-install:
- ${STRIP_CMD} ${WRKSRC}/mk/linux/glest.bin
+ ${STRIP_CMD} ${WRKSRC}/mk/linux/megaglest
@${MKDIR} ${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/glest.bin ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/megaglest ${PREFIX}/bin/${PORTNAME}
.for f in glest.ini glestkeys.ini servers.ini
${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/glest-wrapper ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${WRKSRC}/code_license.txt ${DOCSDIR}
-.endif
+.for f in AUTHORS.source_code.txt CHANGELOG.txt README.txt COPYRIGHT.source_code.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.if defined(WITH_EDITOR)
- ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/glest_editor ${PREFIX}/bin/megaglest_editor
+ ${INSTALL_PROGRAM} ${WRKSRC}/mk/linux/megaglest_editor ${PREFIX}/bin/megaglest_editor
.endif
post-install: