aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest/files
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2011-04-07 05:17:21 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2011-04-07 05:17:21 +0000
commite0351a9ef90cc2371b2f83bfaef56c635c462691 (patch)
tree8388f0a31f65bf79b5b920e278e10f6517baa168 /games/megaglest/files
parent6f46e9afc4db030bb80af2c37eb757747e62294f (diff)
Notes
Diffstat (limited to 'games/megaglest/files')
-rw-r--r--games/megaglest/files/glest-wrapper.in27
-rw-r--r--games/megaglest/files/patch-CMakeLists.txt23
-rw-r--r--games/megaglest/files/pkg-message.in16
3 files changed, 66 insertions, 0 deletions
diff --git a/games/megaglest/files/glest-wrapper.in b/games/megaglest/files/glest-wrapper.in
new file mode 100644
index 000000000000..3b589277a91b
--- /dev/null
+++ b/games/megaglest/files/glest-wrapper.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+# The executable needs to be run from its data directory, and needs to store
+# configuration in it. We therefore mirror the data directory hierarchy in
+# ~/.megaglest3.4.0, and create symlinks to the data files.
+
+if [ -d ~/.megaglest3.4.0 ]
+then
+ echo "Using existing ~/.megaglest3.4.0 directory."
+else
+ echo "Creating ~/.megaglest3.4.0 directory."
+ cd %%DATADIR%% || exit 1
+ find * -type d -exec mkdir -p ~/.megaglest3.4.0/{} \;
+ find * -type f -exec ln -s %%DATADIR%%/{} ~/.megaglest3.4.0/{} \; 2>/dev/null
+ mkdir -p ~/.megaglest3.4.0/screens
+ mkdir -p ~/.megaglest3.4.0/shaders/standard
+ touch ~/.megaglest3.4.0/megaglest.log
+ rm ~/.megaglest3.4.0/glest.ini ~/.megaglest3.4.0/megaglest ~/.megaglest3.4.0/servers.ini
+ cp -f %%DATADIR%%/glest.ini ~/.megaglest3.4.0/
+ cp -f %%DATADIR%%/glestkeys.ini ~/.megaglest3.4.0/
+ cp -f %%DATADIR%%/servers.ini ~/.megaglest3.4.0/
+ chmod 640 ~/.megaglest3.4.0/glest.ini ~/.megaglest3.4.0/servers.ini
+fi
+
+cd ~/.megaglest3.4.0 || exit 1
+echo "Please be patient while loading MegaGlest..."
+exec %%DATADIR%%/glest.bin "$@"
diff --git a/games/megaglest/files/patch-CMakeLists.txt b/games/megaglest/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1eff5478cda5
--- /dev/null
+++ b/games/megaglest/files/patch-CMakeLists.txt
@@ -0,0 +1,23 @@
+*** CMakeLists.txt 2011-02-10 17:41:19.000000000 +0100
+--- CMakeLists.txt_FreeBSD 2011-02-10 17:41:56.000000000 +0100
+*************** IF(CMAKE_COMPILER_IS_GNUCXX OR MINGW)
+*** 59,76 ****
+- OPTION(WANT_SVN_STAMP "use svn stamp" ON)
+- IF(WANT_SVN_STAMP)
+- # The stuff below gets SVN Global Revision # but ONLY when calling cmake!
+- # the FindSubversion.cmake module is part of the standard distribution
+- include(FindSubversion)
+- # extract working copy information for SOURCE_DIR into MY_XXX variables
+- Subversion_WC_INFO(${PROJECT_SOURCE_DIR} MG)
+- #add_definitions(-DSVNVERSION="${MG_WC_REVISION}")
+- ENDIF()
+-
+- SET(SVN_VERSION_CMD "-DSVNVERSION='\\\"${MG_WC_REVISION}\\\"'")
+-
+- IF(UNIX AND NOT APPLE)
+- # We do some funky character escaping to get the right stuff written out to
+- # the final Makefile so we get the SVN Global Revsion #
+- SET(SVN_VERSION_CMD "-DSVNVERSION='\\\"`svnversion -n ${PROJECT_SOURCE_DIR}`\\\"'")
+- ENDIF()
+-
+--- 58 ----
diff --git a/games/megaglest/files/pkg-message.in b/games/megaglest/files/pkg-message.in
new file mode 100644
index 000000000000..7593a0bef4b4
--- /dev/null
+++ b/games/megaglest/files/pkg-message.in
@@ -0,0 +1,16 @@
+###############################################################################
+
+The megaglest game has been installed:
+
+1) You will find the megaglest configuration files in ~/.megaglest
+
+2) If you instlled the megaglest map editor you could lounch it like this:
+
+ # glest_editor
+
+3) If you have problems running megaglest, you should remove your ~/.megaglest
+ directory and try again
+
+4) Enjoy it ;)
+
+###############################################################################