aboutsummaryrefslogtreecommitdiff
path: root/games/memonix
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-19 14:06:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-19 14:06:42 +0000
commit11445f5462b7fdcf9c58d00e5089e25897ed50fe (patch)
tree01f3b0c595a914781fe92c4003719470e1e356c3 /games/memonix
parentb7adec8e553747ddbc9c1fde2e994a34db8389be (diff)
downloadports-11445f5462b7fdcf9c58d00e5089e25897ed50fe.tar.gz
ports-11445f5462b7fdcf9c58d00e5089e25897ed50fe.zip
Notes
Diffstat (limited to 'games/memonix')
-rw-r--r--games/memonix/Makefile56
-rw-r--r--games/memonix/distinfo6
-rw-r--r--games/memonix/pkg-descr11
3 files changed, 73 insertions, 0 deletions
diff --git a/games/memonix/Makefile b/games/memonix/Makefile
new file mode 100644
index 000000000000..fd37531374cd
--- /dev/null
+++ b/games/memonix/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: memonix
+# Date created: 12 Jul 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memonix
+PORTVERSION= 1.6.070713
+CATEGORIES= games
+MASTER_SITES= http://www.viewizard.com/download/ \
+ http://www.amdmi3.ru/distfiles/
+DISTNAME= MemonixSourceCode_${PORTVERSION:S/./_/g:S/_/./}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} memx16.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Brain teasers, puzzle and memory games for kids in one pack
+
+BUILD_DEPENDS= ${CMAKE}:${PORTSDIR}/devel/cmake
+
+CMAKE?= ${LOCALBASE}/bin/cmake
+
+USE_ZIP= yes
+USE_SDL= sdl mixer image
+USE_GL= yes
+
+CMAKE_DEFS= -DCMAKE_EXE_LINKER_FLAGS:STRING="${LINKERFLAGS} ${PTHREAD_LIBS}" \
+ -DCMAKE_THREAD_LIBS:STRING="${PTHREAD_LIBS}"\
+ -DCMAKE_USE_PTHREADS:BOOL=ON \
+ -DCMAKE_C_COMPILER:STRING="${CC}" \
+ -DCMAKE_CXX_COMPILER:STRING="${CXX}" \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${PTHREAD_CFLAGS}"
+
+WRKSRC= ${WRKDIR}/MemonixSourceCode
+
+PLIST_FILES= bin/Memonix %%DATADIR%%/gamedata.vfs
+PLIST_DIRS= %%DATADIR%%
+
+post-extract:
+ @${TAR} -C ${WRKDIR} -xzf ${DISTDIR}/memx16.tar.gz
+
+post-patch:
+ @${REINPLACE_CMD} -e '/strcpy(ProgrammDir,/ s|\./|${DATADIR}/|' \
+ ${WRKSRC}/src/Main.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${CMAKE} . ${CMAKE_DEFS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Memonix ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/Memonix/gamedata.vfs ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/memonix/distinfo b/games/memonix/distinfo
new file mode 100644
index 000000000000..9085b5323544
--- /dev/null
+++ b/games/memonix/distinfo
@@ -0,0 +1,6 @@
+MD5 (MemonixSourceCode_1.6_070713.zip) = dc39f1f51c137beef19a33c61db52af5
+SHA256 (MemonixSourceCode_1.6_070713.zip) = 1e9e950c0a0bc78afde6c116fb3867dde6c9ad6d7560f80ab10ae65c18d5ac62
+SIZE (MemonixSourceCode_1.6_070713.zip) = 188826
+MD5 (memx16.tar.gz) = bb94afdc6f6cb7ba8799fcb1429241ee
+SHA256 (memx16.tar.gz) = bc1ce3d17fb129b58bc6357942879697a62cc16db6e65c3d2b08bf64da2f88dd
+SIZE (memx16.tar.gz) = 6858043
diff --git a/games/memonix/pkg-descr b/games/memonix/pkg-descr
new file mode 100644
index 000000000000..aa1d299704bc
--- /dev/null
+++ b/games/memonix/pkg-descr
@@ -0,0 +1,11 @@
+Brain teasers, puzzle and memory games for kid's in one pack!
+
+Memonix is the latest version of a wonderful collection of four
+brain twisters, including Mosaic, Builder, Pair and Jig-Saw. While
+being amazingly addictive and fun to play, these games can be used
+to improve your child's memory, thinking and reaction. Five difficulty
+levels from normal to obscene plus the timer mean that the challenge
+will never run away. Joyful music and brightly-colored visuals
+maximize the excitement from the gameplay.
+
+WWW: http://www.viewizard.com/