aboutsummaryrefslogtreecommitdiff
path: root/games/meqcc/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-16 12:19:15 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-16 12:19:15 +0000
commit458f7331dbf761eb9ff4fe05dc962d89f0b7774d (patch)
tree9a0fc768f9f940a4ef45e7f5b6bd71e1b757217d /games/meqcc/Makefile
parentf7ab4556e7e04b94f9edef2f3a2db65afe1e5410 (diff)
Notes
Diffstat (limited to 'games/meqcc/Makefile')
-rw-r--r--games/meqcc/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/games/meqcc/Makefile b/games/meqcc/Makefile
new file mode 100644
index 000000000000..c0302129a242
--- /dev/null
+++ b/games/meqcc/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: meQCC
+# Date created: 16 Jan 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meqcc
+PORTVERSION= 1.4
+CATEGORIES= games devel
+MASTER_SITES= http://wiki.quakesrc.org/files/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}src
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= MrElusive's QuakeC compiler
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+MAKEFILE= ${WRKSRC}/linux.mak
+
+post-extract:
+ @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h|mak|txt)" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+ @${REINPLACE_CMD} -e 's/<io\.h>/<unistd\.h>/' ${WRKSRC}/cmdlib.c \
+ ${WRKSRC}/qcc.c ${WRKSRC}/l_log.c
+ @${REINPLACE_CMD} -e '/<conio\.h>/d' ${WRKSRC}/l_log.c
+ @${REINPLACE_CMD} -e 's/unsigned long t/time_t t/' ${WRKSRC}/l_precomp.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qcc ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/[^g]*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>