aboutsummaryrefslogtreecommitdiff
path: root/games/miscom
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-28 08:15:10 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-28 08:15:10 +0000
commitf0ba9c83e5a9b2e7b01f24d5aafa5bab0339cef8 (patch)
tree2dc59392085f269abbe80fc99385b588a7ba3b8b /games/miscom
parent616025bd4101e11a081b12bd6f1a0e926e3c1b2a (diff)
downloadports-f0ba9c83e5a9b2e7b01f24d5aafa5bab0339cef8.tar.gz
ports-f0ba9c83e5a9b2e7b01f24d5aafa5bab0339cef8.zip
Notes
Diffstat (limited to 'games/miscom')
-rw-r--r--games/miscom/Makefile11
-rw-r--r--games/miscom/files/patch-aa35
2 files changed, 10 insertions, 36 deletions
diff --git a/games/miscom/Makefile b/games/miscom/Makefile
index 647bbd551aa7..c70cca1eda2f 100644
--- a/games/miscom/Makefile
+++ b/games/miscom/Makefile
@@ -19,6 +19,15 @@ ALL_TARGET=
WRKSRC= ${WRKDIR}/miscom
MAN6= miscom.6
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+CFLAGS+= -DSOUNDSDIR='\"$(DATADIR)\"' -DSOUND_SUPPORT -DMORE_SOUNDBUF
+.endif
+
+MAKE_ARGS= CC="${CC}" DATADIR="${DATADIR}" \
+ CFLAGS="${CFLAGS}"
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/miscom ${PREFIX}/bin
@ ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${PREFIX}/man/man6
@@ -33,4 +42,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/miscom/files/patch-aa b/games/miscom/files/patch-aa
deleted file mode 100644
index da5262094fd0..000000000000
--- a/games/miscom/files/patch-aa
+++ /dev/null
@@ -1,35 +0,0 @@
---- Makefile.orig Sat Mar 15 15:37:42 1997
-+++ Makefile Sat Jun 19 16:10:46 1999
-@@ -1,7 +1,7 @@
- # makefile for miscom
-
- # needs an ANSI C compiler - gcc is fine
--CC=gcc
-+#CC=gcc
-
- # change these if you want anything anywhere else
- #
-@@ -12,7 +12,7 @@
- MANDIR=/usr/man/man6
-
- # sounds/* go here:
--DATADIR=/usr/games/lib/miscom
-+DATADIR=${PREFIX}/share/miscom
-
- # about `-DMORE_SOUNDBUF':
- # With the new version of the sound driver in 1.3.x/2.0.x kernels,
-@@ -24,11 +24,13 @@
- #
- # comment the line out if you don't want sound support, or if
- # you're compiling on a non-Linux box.
-+.if ${MACHINE_ARCH} == "i386"
- SOUNDOPT=-DSOUNDSDIR=\"$(DATADIR)\" -DSOUND_SUPPORT -DMORE_SOUNDBUF
-+.endif
-
- # compiler opts - shouldn't need changing. the `-I' is there just
- # in case you're using an older ncurses.
--CFLAGS=-O -I/usr/include/ncurses $(SOUNDOPT)
-+CFLAGS+= $(SOUNDOPT)
-
- # how to link your curses lib. `-lncurses' on Linux (and newer BSD?),
- # `-lcurses -ltermcap' on trad. BSD, `-lcurses -ltermlib' on SysV,