aboutsummaryrefslogtreecommitdiff
path: root/games/monkeybubble/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 10:00:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 10:00:19 +0000
commit8e1e6289a99fdf551d57e06d69ed3b8b66cd4ef6 (patch)
tree62c305599b4f7739e3a9a8118004020bfd64a41c /games/monkeybubble/Makefile
parentc1fb859194a65460f12893ac9d1d4691ad40a0ca (diff)
downloadports-8e1e6289a99fdf551d57e06d69ed3b8b66cd4ef6.tar.gz
ports-8e1e6289a99fdf551d57e06d69ed3b8b66cd4ef6.zip
Notes
Diffstat (limited to 'games/monkeybubble/Makefile')
-rw-r--r--games/monkeybubble/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index a2a77596e502..429cbafc1cd0 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= monkeybubble
-PORTVERSION= 0.3.2
-PORTREVISION= 6
+PORTVERSION= 0.4.0
CATEGORIES= games gnome
MASTER_SITES= http://home.gna.org/monkeybubble/downloads/
DISTNAME= monkey-bubble-${PORTVERSION}
@@ -15,24 +14,22 @@ DISTNAME= monkey-bubble-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK2 Puzzle Bobble clone with monkeys
-USE_X_PREFIX= yes
-HAS_MONKEYS= yes
-
-GNU_CONFIGURE= yes
+USE_GNOME= gnomedocutils gnomehack gnomeprefix gnometarget intlhack \
+ librsvg2 libgnomeui
+USE_GSTREAMER= yes
USE_GMAKE= yes
-USE_GSTREAMER80= ogg gconf
-USE_GNOME= gnomehack gnomeprefix librsvg2 libgnomeui \
- intlhack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_OMF= yes
GCONF_SCHEMAS= monkey-bubble.schemas
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
.include <bsd.port.pre.mk>
post-patch:
- ${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/src/net/Makefile.in \
- ${WRKSRC}/src/ui/Makefile.in
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-g -O2||g ; \
+ s|-Werror||g'
.include <bsd.port.post.mk>