aboutsummaryrefslogtreecommitdiff
path: root/games/monster-masher
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-18 09:54:29 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-18 09:54:29 +0000
commitc68e45dbd4f381c19a040dce7f0f010900f3e25a (patch)
tree4bec7faddf38d664e3c08905abed590aa701e44d /games/monster-masher
parent961254088ef7b11173c44b2846b799ec3d12ebaf (diff)
downloadports-c68e45dbd4f381c19a040dce7f0f010900f3e25a.tar.gz
ports-c68e45dbd4f381c19a040dce7f0f010900f3e25a.zip
- Update to version 1.5
* Support for fullscreen mode. This means that people with 1024x768 screens get to see large tiles, too. * A few bug fixes PR: 61496 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=98458
Diffstat (limited to 'games/monster-masher')
-rw-r--r--games/monster-masher/Makefile6
-rw-r--r--games/monster-masher/distinfo2
-rw-r--r--games/monster-masher/files/patch-src-Makefile.in23
3 files changed, 17 insertions, 14 deletions
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 70654e8d9e79..89e2c7cb7d3b 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= monster
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= games gnome
MASTER_SITES= http://www.cs.auc.dk/~olau/monster-masher/source/
PKGNAMESUFFIX= -masher
@@ -18,9 +18,11 @@ COMMENT= Gnomemm puzzle game where you have to clean the caves of monsters
LIB_DEPENDS= gnomeuimm-2.0:${PORTSDIR}/x11-toolkits/libgnomeuimm
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnometarget
+USE_GNOME= gnomeprefix gnomehack gnometarget intlhack
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASA}/lib"
.include <bsd.port.pre.mk>
diff --git a/games/monster-masher/distinfo b/games/monster-masher/distinfo
index 7287e6c66246..6b1655a0fc46 100644
--- a/games/monster-masher/distinfo
+++ b/games/monster-masher/distinfo
@@ -1 +1 @@
-MD5 (monster-masher-1.4.tar.gz) = 35b80609608625578a257c0a0457228b
+MD5 (monster-masher-1.5.tar.gz) = 9a5457ae7208c534492c1b30a784f364
diff --git a/games/monster-masher/files/patch-src-Makefile.in b/games/monster-masher/files/patch-src-Makefile.in
index 1ef19e5eee92..88343513b2ff 100644
--- a/games/monster-masher/files/patch-src-Makefile.in
+++ b/games/monster-masher/files/patch-src-Makefile.in
@@ -1,13 +1,14 @@
---- src/Makefile.in.orig Thu Oct 9 21:58:54 2003
-+++ src/Makefile.in Thu Oct 9 22:01:00 2003
-@@ -117,8 +117,8 @@
-
- monster_masher_SOURCES = animation.cpp animation.hpp arena.cpp arena.hpp canvas-message.cpp canvas-message.hpp canvas.cpp canvas.hpp center-menu.cpp center-menu.hpp fading-decoration.cpp fading-decoration.hpp footsteps.cpp footsteps.hpp game.cpp game.hpp graphic.cpp graphic.hpp gui-helpers.hpp helpers.cpp helpers.hpp hero.cpp hero.hpp i18n.hpp image-cache.cpp image-cache.hpp intro.cpp intro.hpp main-window.cpp main-window.hpp main.cpp monsters.cpp monsters.hpp movement.cpp movement.hpp new-game-window.cpp new-game-window.hpp obstacles.cpp obstacles.hpp persistent.cpp persistent.hpp pixbuf-drawing.cpp pixbuf-drawing.hpp player.cpp player.hpp preferences-window.cpp preferences-window.hpp sound.cpp sound.hpp splat-helpers.cpp splat-helpers.hpp thing.cpp thing.hpp ucompose.hpp vector.hpp
-
--@MAINTAINER_MODE_TRUE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -O0 -Wall
+--- src/Makefile.in.orig Sat Jan 17 19:15:03 2004
++++ src/Makefile.in Sat Jan 17 19:16:39 2004
+@@ -53,9 +53,9 @@
+ CXX = @CXX@
+ CXXDEPMODE = @CXXDEPMODE@
+ CXXFLAGS = @CXXFLAGS@
-@MAINTAINER_MODE_FALSE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall -O3
-+@MAINTAINER_MODE_TRUE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall ${CFLAGS}
-+@MAINTAINER_MODE_FALSE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall ${CFLAGS}
-
- LDADD = $(DEPS_LIBS)
++@MAINTAINER_MODE_FALSE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall @CFLAGS@
+-@MAINTAINER_MODE_TRUE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -O0 -Wall
++@MAINTAINER_MODE_TRUE@CXXFLAGS = @CXXFLAGS@ $(DEPS_CFLAGS) -Wall @CFLAGS@
+ CYGPATH_W = @CYGPATH_W@
+ DATADIRNAME = @DATADIRNAME@
+ DEFS = @DEFS@