aboutsummaryrefslogtreecommitdiff
path: root/games/monsterz
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-05-07 12:53:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-05-07 12:53:54 +0000
commit9b4f686b98554179598363f1c05c1ebbc544d18b (patch)
tree4ae020bf2e48daa0b84413f7d8f998cc1cade2d1 /games/monsterz
parent8dd5d8f949e745d7e64cc10a738ac48c1b816844 (diff)
downloadports-9b4f686b98554179598363f1c05c1ebbc544d18b.tar.gz
ports-9b4f686b98554179598363f1c05c1ebbc544d18b.zip
Notes
Diffstat (limited to 'games/monsterz')
-rw-r--r--games/monsterz/Makefile49
-rw-r--r--games/monsterz/distinfo2
-rw-r--r--games/monsterz/files/pkg-message.in5
-rw-r--r--games/monsterz/pkg-descr20
-rw-r--r--games/monsterz/pkg-plist24
5 files changed, 100 insertions, 0 deletions
diff --git a/games/monsterz/Makefile b/games/monsterz/Makefile
new file mode 100644
index 000000000000..980c11b30d10
--- /dev/null
+++ b/games/monsterz/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: monsterz
+# Date created: Fri 29 apr 2005
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= monsterz
+PORTVERSION= 0.6.0
+CATEGORIES= games
+MASTER_SITES= http://sam.zoy.org/monsterz/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Monsterz - arcade puzzle game
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+LINSTDIR?= share/games/${PORTNAME}
+INSTDIR= ${PREFIX}/${LINSTDIR}
+PLIST_SUB= LINSTDIR=${LINSTDIR}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+PORTDOCS= AUTHORS COPYING INSTALL README TODO
+
+do-install:
+ ${MKDIR} ${INSTDIR}/graphics ${INSTDIR}/sound
+ ${INSTALL_SCRIPT} ${WRKSRC}/monsterz.py ${INSTDIR}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${INSTDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${INSTDIR}
+.for sd in graphics sound
+ ${FIND} ${WRKSRC}/${sd} -type f -exec ${INSTALL_DATA} {} ${INSTDIR}/${sd} \;
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/games/monsterz/distinfo b/games/monsterz/distinfo
new file mode 100644
index 000000000000..c4b70d7ddb9a
--- /dev/null
+++ b/games/monsterz/distinfo
@@ -0,0 +1,2 @@
+MD5 (monsterz-0.6.0.tar.gz) = af2ecbd5671b3b57b3c16a0374825ff6
+SIZE (monsterz-0.6.0.tar.gz) = 2490036
diff --git a/games/monsterz/files/pkg-message.in b/games/monsterz/files/pkg-message.in
new file mode 100644
index 000000000000..4318710342ae
--- /dev/null
+++ b/games/monsterz/files/pkg-message.in
@@ -0,0 +1,5 @@
+Monsterz has been installed. To run it, type
+
+%%PREFIX%%/share/games/monsterz/monsterz.py&
+
+or launch it with `python -O' or `python -OO'.
diff --git a/games/monsterz/pkg-descr b/games/monsterz/pkg-descr
new file mode 100644
index 000000000000..e573815c29a7
--- /dev/null
+++ b/games/monsterz/pkg-descr
@@ -0,0 +1,20 @@
+Monsterz is a little arcade puzzle game, similar to the famous Bejeweled or
+Zookeeper.
+
+The goal of the game is to create rows of similar monsters, either
+horizontally or vertically. The only allowed move is the swap of two adjacent
+monsters, on the condition that it creates a row of three or more. When
+alignments are cleared, pieces fall from the top of the screen to fill the
+board again. Chain reactions earn you even more points.
+
+This game is mostly about luck, but it remains highly addictive. You have been
+warned. Currently two modes are available:
+
+ * Classic - play against the clock and clear a given number of each monster
+ type to reach next level.
+ * Puzzle - clear lines of monsters to move pieces around and put together
+ the puzzle.
+ * Training - play against the clock in a neverending level, chose the timer
+ difficulty and number of monsters for infinite fun.
+
+WWW: http://sam.zoy.org/monsterz/
diff --git a/games/monsterz/pkg-plist b/games/monsterz/pkg-plist
new file mode 100644
index 000000000000..67dc98369463
--- /dev/null
+++ b/games/monsterz/pkg-plist
@@ -0,0 +1,24 @@
+%%LINSTDIR%%/graphics/background.png
+%%LINSTDIR%%/graphics/bigtiles.png
+%%LINSTDIR%%/graphics/board.png
+%%LINSTDIR%%/graphics/icon.png
+%%LINSTDIR%%/graphics/logo.png
+%%LINSTDIR%%/graphics/tiles.png
+%%LINSTDIR%%/monsterz.py
+%%LINSTDIR%%/monsterz.pyc
+%%LINSTDIR%%/monsterz.pyo
+%%LINSTDIR%%/sound/applause.wav
+%%LINSTDIR%%/sound/boing.wav
+%%LINSTDIR%%/sound/click.wav
+%%LINSTDIR%%/sound/ding.wav
+%%LINSTDIR%%/sound/duh.wav
+%%LINSTDIR%%/sound/grunt.wav
+%%LINSTDIR%%/sound/laugh.wav
+%%LINSTDIR%%/sound/music.s3m
+%%LINSTDIR%%/sound/pop.wav
+%%LINSTDIR%%/sound/warning.wav
+%%LINSTDIR%%/sound/whip.wav
+@dirrm %%LINSTDIR%%/sound
+@dirrm %%LINSTDIR%%/graphics
+@dirrm %%LINSTDIR%%
+@unexec rmdir %D/share/games 2>/dev/null || true