aboutsummaryrefslogtreecommitdiff
path: root/games/monsterz
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-05-13 22:32:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-05-13 22:32:56 +0000
commit29b5d7222b061e3b7565d95447cd18394f6414c8 (patch)
tree90feb840e89c1d50cbdf458b3a78cf3040743c10 /games/monsterz
parent3b741ef6c993baab181dd2803f5580221bb1dcdc (diff)
downloadports-29b5d7222b061e3b7565d95447cd18394f6414c8.tar.gz
ports-29b5d7222b061e3b7565d95447cd18394f6414c8.zip
Notes
Diffstat (limited to 'games/monsterz')
-rw-r--r--games/monsterz/Makefile28
-rw-r--r--games/monsterz/distinfo6
-rw-r--r--games/monsterz/files/patch-Makefile18
-rw-r--r--games/monsterz/files/pkg-message.in5
-rw-r--r--games/monsterz/pkg-plist52
5 files changed, 58 insertions, 51 deletions
diff --git a/games/monsterz/Makefile b/games/monsterz/Makefile
index 1e083d32bd4b..f22d2d5b5a37 100644
--- a/games/monsterz/Makefile
+++ b/games/monsterz/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= monsterz
-PORTVERSION= 0.6.1
+PORTVERSION= 0.7.0
CATEGORIES= games
MASTER_SITES= http://sam.zoy.org/monsterz/
@@ -17,33 +17,21 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= yes
-NO_BUILD= yes
+MAKE_ENV= prefix=${PREFIX}
-LINSTDIR?= share/games/${PORTNAME}
-INSTDIR= ${PREFIX}/${LINSTDIR}
-PLIST_SUB= LINSTDIR=${LINSTDIR}
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
+SCOREDIR= /var/games
+PLIST_SUB= SCOREDIR=${SCOREDIR}
PORTDOCS= AUTHORS COPYING INSTALL README TODO
-do-install:
- ${MKDIR} ${INSTDIR}/graphics ${INSTDIR}/sound
- ${INSTALL_SCRIPT} ${WRKSRC}/monsterz.py ${INSTDIR}
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${INSTDIR}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${INSTDIR}
-.for sd in graphics sound
- ${FIND} ${WRKSRC}/${sd} -type f -exec ${INSTALL_DATA} {} ${INSTDIR}/${sd} \;
-.endfor
-
post-install:
+ ${STRIP_CMD} ${PREFIX}/games/monsterz
+ ${LN} -sf ${PREFIX}/games/monsterz ${PREFIX}/bin
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/games/monsterz
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/games/monsterz
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/games/monsterz/distinfo b/games/monsterz/distinfo
index 59f87ce26d35..12cfb4e849e1 100644
--- a/games/monsterz/distinfo
+++ b/games/monsterz/distinfo
@@ -1,3 +1,3 @@
-MD5 (monsterz-0.6.1.tar.gz) = f7b6ae95e013482db6cdf9c9b9a8d424
-SHA256 (monsterz-0.6.1.tar.gz) = a2bd5201cbbc495b45d886d58b1050e0b01ed4edbd660d3bd8eb3f2258a7fa99
-SIZE (monsterz-0.6.1.tar.gz) = 2490124
+MD5 (monsterz-0.7.0.tar.gz) = 323d04d4a2a2905df91eab4ff17e537d
+SHA256 (monsterz-0.7.0.tar.gz) = f529af194d1bc522c4fb9959607f668183f7a08b4465fbc167871ec828bc1ee0
+SIZE (monsterz-0.7.0.tar.gz) = 1881420
diff --git a/games/monsterz/files/patch-Makefile b/games/monsterz/files/patch-Makefile
new file mode 100644
index 000000000000..0e04d450f3a9
--- /dev/null
+++ b/games/monsterz/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Fri May 12 18:39:38 2006
++++ Makefile Sat May 13 19:06:56 2006
+@@ -1,5 +1,5 @@
+
+-prefix = /usr/local
++prefix?= /usr/local
+ gamesdir = ${prefix}/games
+ datadir = ${prefix}/share
+ pkgdatadir = $(datadir)/games/monsterz
+@@ -22,7 +22,7 @@
+ all: monsterz
+
+ monsterz: monsterz.c
+- $(CC) -Wall monsterz.c -DDATADIR=\"$(pkgdatadir)\" -DSCOREFILE=\"$(scorefile)\" -o monsterz
++ $(CC) $(CFLAGS) -Wall monsterz.c -DDATADIR=\"$(pkgdatadir)\" -DSCOREFILE=\"$(scorefile)\" -o monsterz
+
+ bitmap: $(BITMAP)
+
diff --git a/games/monsterz/files/pkg-message.in b/games/monsterz/files/pkg-message.in
deleted file mode 100644
index 4318710342ae..000000000000
--- a/games/monsterz/files/pkg-message.in
+++ /dev/null
@@ -1,5 +0,0 @@
-Monsterz has been installed. To run it, type
-
-%%PREFIX%%/share/games/monsterz/monsterz.py&
-
-or launch it with `python -O' or `python -OO'.
diff --git a/games/monsterz/pkg-plist b/games/monsterz/pkg-plist
index b213f61920d3..40b8c1493fed 100644
--- a/games/monsterz/pkg-plist
+++ b/games/monsterz/pkg-plist
@@ -1,24 +1,30 @@
-%%LINSTDIR%%/graphics/background.png
-%%LINSTDIR%%/graphics/bigtiles.png
-%%LINSTDIR%%/graphics/board.png
-%%LINSTDIR%%/graphics/icon.png
-%%LINSTDIR%%/graphics/logo.png
-%%LINSTDIR%%/graphics/tiles.png
-%%LINSTDIR%%/monsterz.py
-%%LINSTDIR%%/monsterz.pyc
-%%LINSTDIR%%/monsterz.pyo
-%%LINSTDIR%%/sound/applause.wav
-%%LINSTDIR%%/sound/boing.wav
-%%LINSTDIR%%/sound/click.wav
-%%LINSTDIR%%/sound/ding.wav
-%%LINSTDIR%%/sound/duh.wav
-%%LINSTDIR%%/sound/grunt.wav
-%%LINSTDIR%%/sound/laugh.wav
-%%LINSTDIR%%/sound/music.s3m
-%%LINSTDIR%%/sound/pop.wav
-%%LINSTDIR%%/sound/warning.wav
-%%LINSTDIR%%/sound/whip.wav
-@dirrm %%LINSTDIR%%/sound
-@dirrm %%LINSTDIR%%/graphics
-@dirrm %%LINSTDIR%%
+bin/monsterz
+games/monsterz
+share/games/monsterz/graphics/background.png
+share/games/monsterz/graphics/bigtiles.png
+share/games/monsterz/graphics/board.png
+share/games/monsterz/graphics/icon.png
+share/games/monsterz/graphics/logo.png
+share/games/monsterz/graphics/tiles.png
+share/games/monsterz/monsterz.py
+share/games/monsterz/monsterz.pyc
+share/games/monsterz/monsterz.pyo
+share/games/monsterz/sound/applause.wav
+share/games/monsterz/sound/boing.wav
+share/games/monsterz/sound/click.wav
+share/games/monsterz/sound/ding.wav
+share/games/monsterz/sound/duh.wav
+share/games/monsterz/sound/grunt.wav
+share/games/monsterz/sound/laugh.wav
+share/games/monsterz/sound/music.s3m
+share/games/monsterz/sound/pop.wav
+share/games/monsterz/sound/warning.wav
+share/games/monsterz/sound/whip.wav
+@dirrm share/games/monsterz/sound
+@dirrm share/games/monsterz/graphics
+@dirrm share/games/monsterz
@dirrmtry share/games
+@dirrmtry games
+@exec if [ ! -e %%SCOREDIR%% ] ; then mkdir -p -m 775 %%SCOREDIR%% ; fi
+@exec [ -e %%SCOREDIR%%/monsterz ] || touch %%SCOREDIR%%/monsterz && chmod g+w %%SCOREDIR%%/monsterz
+@unexec if [ ! -s %%SCOREDIR%%/monsterz ] ; then rm -f %%SCOREDIR%%/monsterz && rm -r %%SCOREDIR%% || true ; fi