aboutsummaryrefslogtreecommitdiff
path: root/games/moria/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-08-07 04:26:34 +0000
committerGreg Lewis <glewis@FreeBSD.org>2003-08-07 04:26:34 +0000
commit3b5afbbdfbc755e6cf5a13531219153e802aac13 (patch)
treec2dfbd7504151b0f1389030e74f1dc71cca5d03a /games/moria/Makefile
parent3024fe12f5297620373e1db4a274414aeec520c1 (diff)
. Add a port of moria. For those too young to have played moria:
The game of moria is a single player dungeon simulation. A player may choose from a number of races and classes when creating a character, and then `run' that character over a period of days, weeks, even months, attempting to win the game by defeating the Balrog which lurks in the deeper levels. The player will begin his adventure on the town level where he may acquire supplies, weapons, armor, and magical devices by bartering with various shop owners. After preparing for his adventure, the player can descend into the dungeons of moria where fantastic adventures await his coming! WWW: http://www-math.bgsu.edu/~grabine/moria.html
Notes
Notes: svn path=/head/; revision=86419
Diffstat (limited to 'games/moria/Makefile')
-rw-r--r--games/moria/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/moria/Makefile b/games/moria/Makefile
new file mode 100644
index 000000000000..d295484d998c
--- /dev/null
+++ b/games/moria/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: moria
+# Date created: 6 August 2003
+# Whom: glewis@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= moria
+PORTVERSION= 5.5.2
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.funet.fi/pub/unix/games/moria/source/ \
+ ftp://ftp.greyhelm.com/pub/Games/Moria/source/
+DISTNAME= um${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= glewis@FreeBSD.org
+COMMENT= A dungeon exploration game
+
+USE_REINPLACE= yes
+
+MAN6= moria.6
+WRKSRC= ${WRKDIR}/umoria
+ALL_TARGET= moria
+
+do-configure:
+ for i in ${WRKSRC}/source/config.h ${WRKSRC}/unix/Makefile; do \
+ ${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" $$i; \
+ done
+ cd ${WRKSRC} && ${LN} -sf source/* unix/* .
+
+post-install:
+ for i in ${MAN6}; do \
+ ${INSTALL_MAN} ${WRKSRC}/doc/$$i ${PREFIX}/man/man6; \
+ done
+
+.include <bsd.port.mk>