aboutsummaryrefslogtreecommitdiff
path: root/games/moria/files/patch-unix::Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-29 17:12:47 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-29 17:12:47 +0000
commit08a006d08a4c35d2c3ecc9a3d10cf7fd14661a84 (patch)
tree0cfc4f0736babb895eb97a65c6defe632a0249c7 /games/moria/files/patch-unix::Makefile
parentf474a16cfbfad1844b9c50e45e36a3a77f0c59b5 (diff)
downloadports-08a006d08a4c35d2c3ecc9a3d10cf7fd14661a84.tar.gz
ports-08a006d08a4c35d2c3ecc9a3d10cf7fd14661a84.zip
Notes
Diffstat (limited to 'games/moria/files/patch-unix::Makefile')
-rw-r--r--games/moria/files/patch-unix::Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/games/moria/files/patch-unix::Makefile b/games/moria/files/patch-unix::Makefile
deleted file mode 100644
index b78b568e23ec..000000000000
--- a/games/moria/files/patch-unix::Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
---- unix/Makefile.orig 1994-07-21 15:37:08.000000000 -0700
-+++ unix/Makefile 2014-06-09 19:44:28.000000000 -0700
-@@ -1,17 +1,13 @@
- # BINDIR is the directory where the moria binary while be put
- # LIBDIR is where the other files (score, news, hours) will be put
- # LIBDIR must be the same directory defined in config.h
--# OWNER is who you want the game to be chown to.
--# GROUP is who you wnat the game to be chgrp to.
--BINDIR = /home/zariski/grabiner/moria
--LIBDIR = /home/zariski/grabiner/moria/files
--OWNER = grabiner
--GROUP = grad
-+BINDIR = ${STAGEDIR}${PREFIX}/bin
-+LIBDIR = ${STAGEDIR}${DATADIR}
-
- # For testing and debugging the program, it is best to use this line.
- # CFLAGS = -g
- # For playing the game, you may want to use this line
--CFLAGS = -O
-+#CFLAGS = -O
-
- # For BSD Systems
- CURSES = -lcurses -ltermcap
-@@ -26,7 +22,7 @@
- # Normal systems don't require anything here.
- LFLAGS =
-
--CC = cc
-+#CC = cc
-
- SRCS = main.c misc1.c misc2.c misc3.c misc4.c store1.c files.c io.c \
- create.c desc.c generate.c sets.c dungeon.c creature.c death.c \
-@@ -60,17 +56,11 @@
- # you must define BINDIR and LIBDIR before installing
- # assumes that BINDIR and LIBDIR exist
- install:
-- chmod 755 $(BINDIR)
-- cp moria $(BINDIR)
-- chmod 4711 $(BINDIR)/moria
-- chmod 711 $(LIBDIR)
-- (cd files; cp $(LIBFILES) $(LIBDIR))
-- (cd $(LIBDIR); chmod 444 $(LIBFILES))
-- (cd $(LIBDIR); touch scores; chmod 644 scores)
-- chown $(OWNER) $(BINDIR)/moria
-- chgrp $(GROUP) $(BINDIR)/moria
-- (cd $(LIBDIR); chown $(OWNER) $(LIBFILES) scores)
-- (cd $(LIBDIR); chgrp $(GROUP) $(LIBFILES) scores)
-+ -${MKDIR} $(BINDIR)
-+ ${BSD_INSTALL_PROGRAM} moria $(BINDIR)
-+ -${MKDIR} $(LIBDIR)
-+ (cd files; ${BSD_INSTALL_DATA} $(LIBFILES) $(LIBDIR))
-+ (cd $(LIBDIR); ${TOUCH} scores)
- # If you are short on disk space, or aren't interested in debugging moria.
- # strip $(BINDIR)/moria
-