aboutsummaryrefslogtreecommitdiff
path: root/games/nehquake
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-15 18:33:49 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-15 18:33:49 +0000
commit44946a69cd6d3ee985cd42e38e9bd12a7dbdb81b (patch)
treeb9fcdf29e084646de692ab64ac036337948ba081 /games/nehquake
parent4ca93c868774dc1c976e4e277ec1065e37d59abf (diff)
Notes
Diffstat (limited to 'games/nehquake')
-rw-r--r--games/nehquake/Makefile28
-rw-r--r--games/nehquake/pkg-plist3
2 files changed, 11 insertions, 20 deletions
diff --git a/games/nehquake/Makefile b/games/nehquake/Makefile
index 0a303f04f6e5..8f1c81b74455 100644
--- a/games/nehquake/Makefile
+++ b/games/nehquake/Makefile
@@ -12,19 +12,22 @@ DISTNAME= NehQuake-bjp-bin-src.linux
MAINTAINER= ports@FreeBSD.org
COMMENT= Quake engine designed for playing Nehahra
-USES= gmake dos2unix
-USE_BZIP2= yes
+USES= gmake dos2unix tar:bzip2
USE_GL= gl
USE_XORG= xxf86dga
OPTIONS_DEFINE= OPTIMIZED_CFLAGS SDL X86_ASM
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS SDL X86_ASM
+OPTIONS_SUB= yes
+
+SDL_USE= SDL=sdl
+SDL_MAKE_ENV= BUILD_SDL=YES
+
X86_ASM_DESC= Enable x86 assembly code
ALL_TARGET= release
SUB_FILES= pkg-message
-NO_STAGE= yes
.include "${.CURDIR}/../quake-data/Makefile.include"
.include <bsd.port.options.mk>
@@ -37,24 +40,11 @@ MAKE_ENV+= USE_${f}=NO
. endif
.endfor
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL= sdl
-MAKE_ENV+= BUILD_SDL=YES
-PLIST_SUB+= SDL=""
-.else
-PLIST_SUB+= SDL="@comment "
-.endif
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/release/nehahra ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/release/nehahra ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MSDL}
- ${INSTALL_PROGRAM} ${WRKSRC}/release/nehahra-sdl ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/release/nehahra-sdl ${STAGEDIR}${PREFIX}/bin
.endif
- ${MKDIR} ${Q1DIR}/nehahra
-
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+ @${MKDIR} ${STAGEDIR}${Q1DIR}/nehahra
.include <bsd.port.mk>
diff --git a/games/nehquake/pkg-plist b/games/nehquake/pkg-plist
index 4a7280e52164..06c93dfd21a1 100644
--- a/games/nehquake/pkg-plist
+++ b/games/nehquake/pkg-plist
@@ -1,3 +1,4 @@
bin/nehahra
%%SDL%%bin/nehahra-sdl
-@unexec rmdir %D/%%Q1DIR%%/nehahra 2>/dev/null || echo "If you are permanently removing this port, you should remove any configuration files and data files left in %D/%%Q1DIR%%/nehahra." | fmt
+@dirrmtry %%Q1DIR%%/nehahra
+@exec mkdir -p %D/%%Q1DIR%%/nehahra