aboutsummaryrefslogtreecommitdiff
path: root/games/nelly/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-10 03:20:10 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-10 03:20:10 +0000
commit6be79b4d463befbb085e105a6004622f0be49597 (patch)
tree110a8edfd60741110d422c12a1a19cb29475d3d6 /games/nelly/Makefile
parentb73b27a91ac6bd58def400185ed51287fb7eab61 (diff)
Notes
Diffstat (limited to 'games/nelly/Makefile')
-rw-r--r--games/nelly/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/games/nelly/Makefile b/games/nelly/Makefile
new file mode 100644
index 000000000000..a7723e899ec5
--- /dev/null
+++ b/games/nelly/Makefile
@@ -0,0 +1,65 @@
+# New Ports collection makefile for: nelly
+# Date created: 16 July 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= nelly
+PORTVERSION= 1.0
+CATEGORIES= games python
+MASTER_SITES= http://www.partiallydisassembled.net/nelly/ \
+ http://media.pyweek.org/dl/2/rushed/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Nelly's Rooftop Garden, physics-based puzzle game
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=0:${PORTSDIR}/devel/py-game \
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl
+
+OPTIONS_DEFINE= DATA
+OPTIONS_DEFAULT= DATA
+
+USE_PYTHON_RUN= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= README
+
+SUB_FILES= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
+ ${WRKSRC}/*.py
+ @(cd ${WRKSRC} && ${RM} *.py.bak)
+
+do-install:
+# Scripts
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+# Executable
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
+
+# Data
+.if ${PORT_OPTIONS:MDATA}
+. for d in fonts levels textures
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+. endfor
+.endif
+
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/textures/menu.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>