aboutsummaryrefslogtreecommitdiff
path: root/games/nethack32
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-31 15:08:01 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-31 15:08:01 +0000
commit2103b2e6878c583487c252ce9198b2760be086f3 (patch)
tree7948aca63033fa688d9c90f32ab7cea364643f0f /games/nethack32
parentc89b1ead0c36a61716d3d1049bf305895e9bc47f (diff)
downloadports-2103b2e6878c583487c252ce9198b2760be086f3.tar.gz
ports-2103b2e6878c583487c252ce9198b2760be086f3.zip
Somehow in r363374 I added USES=gmake, which broke the port. Remove it to
re-fix the build. While here, small tweaks to plist to pass sanity checks, and wrap compound statements in the Makefile.
Notes
Notes: svn path=/head/; revision=366775
Diffstat (limited to 'games/nethack32')
-rw-r--r--games/nethack32/Makefile14
-rw-r--r--games/nethack32/pkg-plist11
2 files changed, 14 insertions, 11 deletions
diff --git a/games/nethack32/Makefile b/games/nethack32/Makefile
index 77c21b45cfff..eb69d33ac504 100644
--- a/games/nethack32/Makefile
+++ b/games/nethack32/Makefile
@@ -16,7 +16,7 @@ COMMENT= Dungeon explorin', slashin', hackin' game
WRKSRC= ${WRKDIR}/${TRUEPORTNAME}-3.2.2
-USES= gmake tar:tgz
+USES= tar:tgz
USE_XORG= xaw xpm
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
@@ -57,20 +57,20 @@ post-patch:
.endfor
do-configure:
- @cd ${WRKSRC}/sys/unix && ${SH} setup.sh
+ @(cd ${WRKSRC}/sys/unix && ${SH} setup.sh)
pre-install:
@${CAT} ${FILESDIR}/pkg-deinstall.in | ${SED} \
-e 's|%%HACKDIR%%|${HACKDIR}|g' > ${PKGDEINSTALL}
post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/save
.if !exists(${PREFIX}/bin/${HACKLINK}) && ${HACKNAME} != ${HACKLINK}
- @${LN} -s -f ${PREFIX}/bin/${HACKNAME} ${STAGEDIR}${PREFIX}/bin/${HACKLINK}
+ @${LN} -s -f ${HACKNAME} ${STAGEDIR}${PREFIX}/bin/${HACKLINK}
.endif
- @cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} manpages
-.if ${PORT_OPTIONS:MDOCS}
+ ${DO_MAKE_BUILD} -C ${WRKSRC}/doc ${MAKE_ARGS} manpages
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${STAGEDIR}${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/games/nethack32/pkg-plist b/games/nethack32/pkg-plist
index 3d95c3ddbd64..b24d3e72dfeb 100644
--- a/games/nethack32/pkg-plist
+++ b/games/nethack32/pkg-plist
@@ -135,9 +135,12 @@ man/man6/lev_comp%%HACKEXT%%.6.gz
man/man6/%%HACKNAME%%.6.gz
man/man6/recover%%HACKEXT%%.6.gz
%%PORTDOCS%%%%DOCSDIR%%/Guidebook.txt
-@exec mkdir %D/%%DATADIR%%/save
-@exec chown games:games %D/%%DATADIR%%/save
-@exec chmod 0775 %D/%%DATADIR%%/save
-@unexec rmdir %D/%%DATADIR%%/save
+@mode 0775
+@owner games
+@group games
+@dirrmtry %%DATADIR%%/save
+@group
+@owner
+@mode
@dirrmtry %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%