aboutsummaryrefslogtreecommitdiff
path: root/games/nethack32
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-04-08 23:23:29 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-04-08 23:23:29 +0000
commit2d43ceb257d07220b5b76c9f2dffa6554ffebf5f (patch)
tree1d03dc6b39c8c5fc5a3d7460a78d7911c593eb36 /games/nethack32
parent4858085ab61791f148fdb02ec6bd7137f7c4219f (diff)
downloadports-2d43ceb257d07220b5b76c9f2dffa6554ffebf5f.tar.gz
ports-2d43ceb257d07220b5b76c9f2dffa6554ffebf5f.zip
Notes
Diffstat (limited to 'games/nethack32')
-rw-r--r--games/nethack32/Makefile7
-rw-r--r--games/nethack32/files/patch-af24
-rw-r--r--games/nethack32/files/patch-ag67
-rw-r--r--games/nethack32/pkg-plist245
4 files changed, 209 insertions, 134 deletions
diff --git a/games/nethack32/Makefile b/games/nethack32/Makefile
index fe662cef640c..a148c2d4f2a5 100644
--- a/games/nethack32/Makefile
+++ b/games/nethack32/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nethack
PORTVERSION= 3.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -30,11 +30,10 @@ USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
pre-configure:
- @cd ${WRKSRC}/sys/unix; ${SH} setup.sh
+ @cd ${WRKSRC}/sys/unix && ${SH} setup.sh
post-install:
- @cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
- @cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
+ @cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE} manpages
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}
diff --git a/games/nethack32/files/patch-af b/games/nethack32/files/patch-af
index 75c84c235c88..f7200e63880e 100644
--- a/games/nethack32/files/patch-af
+++ b/games/nethack32/files/patch-af
@@ -1,12 +1,26 @@
-diff -ruN ./sys/unix/Makefile.doc ../nethack-3.2.2/sys/unix/Makefile.doc
---- ./sys/unix/Makefile.doc Wed Dec 11 05:20:08 1996
-+++ ../nethack-3.2.2/sys/unix/Makefile.doc Sun Mar 21 17:25:02 1999
-@@ -31,7 +31,7 @@
+$FreeBSD$
+
+--- sys/unix/Makefile.doc.orig Tue Dec 10 13:20:08 1996
++++ sys/unix/Makefile.doc Thu Apr 8 16:29:59 2004
+@@ -31,15 +31,15 @@
GAME = nethack
-MANDIR = /usr/man/man6
-+MANDIR = ${PREFIX}/man/man6
++MANDIR = ${MANPREFIX}/man/man6
MANEXT = 6
# manual installation for most BSD-style systems
+-GAMEMANCREATE = cp nethack.6
+-LEVMANCREATE = cp lev_comp.6
+-DGNMANCREATE = cp dgn_comp.6
+-RCVRMANCREATE = cp recover.6
+-DLBMANCREATE = cp dlb.6
++GAMEMANCREATE = ${BSD_INSTALL_MAN} nethack.6
++LEVMANCREATE = ${BSD_INSTALL_MAN} lev_comp.6
++DGNMANCREATE = ${BSD_INSTALL_MAN} dgn_comp.6
++RCVRMANCREATE = ${BSD_INSTALL_MAN} recover.6
++DLBMANCREATE = ${BSD_INSTALL_MAN} dlb.6
+ # manual installation for most SYSV-style systems
+ # GAMEMANCREATE = nroff -man nethack.6 >
+ # LEVMANCREATE = nroff -man lev_comp.6 >
diff --git a/games/nethack32/files/patch-ag b/games/nethack32/files/patch-ag
index 6fbe422824f3..307e8a64e630 100644
--- a/games/nethack32/files/patch-ag
+++ b/games/nethack32/files/patch-ag
@@ -1,6 +1,7 @@
-diff -ruN ./sys/unix/Makefile.top ../nethack-3.2.2/sys/unix/Makefile.top
---- ./sys/unix/Makefile.top Wed Dec 11 05:20:10 1996
-+++ ../nethack-3.2.2/sys/unix/Makefile.top Sun Mar 21 17:29:27 1999
+$FreeBSD$
+
+--- sys/unix/Makefile.top.orig Tue Dec 10 13:20:10 1996
++++ sys/unix/Makefile.top Thu Apr 8 16:57:27 2004
@@ -16,14 +16,14 @@
# make NetHack
GAME = nethack
@@ -38,3 +39,63 @@ diff -ruN ./sys/unix/Makefile.top ../nethack-3.2.2/sys/unix/Makefile.top
VARDATD = data oracles options quest.dat rumors
VARDAT = $(VARDATD) $(VARDATND)
+@@ -74,7 +74,7 @@
+ $(GAME):
+ ( cd src ; $(MAKE) )
+
+-all: $(GAME) Guidebook $(VARDAT) dungeon spec_levs check-dlb
++all: $(GAME) recover Guidebook $(VARDAT) dungeon spec_levs check-dlb
+ @echo "Done."
+
+ Guidebook:
+@@ -126,6 +126,8 @@
+ ( cd util ; $(MAKE) dlb )
+ ( cd dat ; ../util/dlb cf nhdat $(DATDLB) )
+
++recover:
++ ( cd util ; $(MAKE) recover )
+
+ dofiles:
+ target=`sed -n \
+@@ -136,15 +138,17 @@
+ -e '$$s/.*/nodlb/p' < dat/options` ; \
+ $(MAKE) dofiles-$${target-nodlb}
+ cp src/$(GAME) $(GAMEDIR)
++ cp util/recover $(GAMEDIR)
+ -rm -f $(SHELLDIR)/$(GAME)
+ sed -e 's;/usr/games/lib/nethackdir;$(GAMEDIR);' \
+ -e 's;HACKDIR/nethack;HACKDIR/$(GAME);' \
+ < sys/unix/nethack.sh \
+ > $(SHELLDIR)/$(GAME)
+ # set up their permissions
+- -( cd $(GAMEDIR) ; $(CHOWN) $(GAMEUID) $(GAME) ; \
+- $(CHGRP) $(GAMEGRP) $(GAME) )
++ -( cd $(GAMEDIR) ; $(CHOWN) $(GAMEUID) $(GAME) recover ; \
++ $(CHGRP) $(GAMEGRP) $(GAME) recover )
+ chmod $(GAMEPERM) $(GAMEDIR)/$(GAME)
++ chmod $(GAMEPERM) $(GAMEDIR)/recover
+ -$(CHOWN) $(GAMEUID) $(SHELLDIR)/$(GAME)
+ $(CHGRP) $(GAMEGRP) $(SHELLDIR)/$(GAME)
+ chmod $(EXEPERM) $(SHELLDIR)/$(GAME)
+@@ -164,7 +168,7 @@
+ $(CHGRP) $(GAMEGRP) $(DAT) ; \
+ chmod $(FILEPERM) $(DAT) )
+
+-update: $(GAME) $(VARDAT) dungeon spec_levs
++update: $(GAME) recover $(VARDAT) dungeon spec_levs
+ # (don't yank the old version out from under people who're playing it)
+ -mv $(GAMEDIR)/$(GAME) $(GAMEDIR)/$(GAME).old
+ # quest.dat is also kept open and has the same problems over NFS
+@@ -180,10 +184,10 @@
+ # and a reminder
+ @echo You may also want to install the man pages via the doc Makefile.
+
+-install: $(GAME) $(VARDAT) dungeon spec_levs
++install: $(GAME) recover $(VARDAT) dungeon spec_levs
+ # set up the directories
+ -mkdir $(SHELLDIR)
+- -rm -rf $(GAMEDIR)
++ -rmdir $(GAMEDIR)
+ -mkdir $(GAMEDIR) $(GAMEDIR)/save
+ -$(CHOWN) $(GAMEUID) $(GAMEDIR) $(GAMEDIR)/save
+ $(CHGRP) $(GAMEGRP) $(GAMEDIR) $(GAMEDIR)/save
diff --git a/games/nethack32/pkg-plist b/games/nethack32/pkg-plist
index 7dfddb3cb28d..049ab6dde527 100644
--- a/games/nethack32/pkg-plist
+++ b/games/nethack32/pkg-plist
@@ -1,124 +1,125 @@
bin/nethack
-share/nethack/nethack
-@exec mkdir %D/share/nethack/save
-@exec chmod -R 775 %D/share/nethack
-@exec chmod 2755 %D/share/nethack/nethack
-@exec chown games:games %D/share/nethack/save
-@unexec rm -rf %D/share/nethack/save
-%%PORTDOCS%%share/doc/nethack/Guidebook.txt
-share/nethack/pet_mark.xbm
-share/nethack/rip.xpm
-share/nethack/x11tiles
-share/nethack/A-filla.lev
-share/nethack/A-fillb.lev
-share/nethack/A-goal.lev
-share/nethack/A-locate.lev
-share/nethack/A-start.lev
-share/nethack/B-filla.lev
-share/nethack/B-fillb.lev
-share/nethack/B-goal.lev
-share/nethack/B-locate.lev
-share/nethack/B-start.lev
-share/nethack/C-filla.lev
-share/nethack/C-fillb.lev
-share/nethack/C-goal.lev
-share/nethack/C-locate.lev
-share/nethack/C-start.lev
-share/nethack/E-filla.lev
-share/nethack/E-fillb.lev
-share/nethack/E-goal.lev
-share/nethack/E-locate.lev
-share/nethack/E-start.lev
-share/nethack/H-filla.lev
-share/nethack/H-fillb.lev
-share/nethack/H-goal.lev
-share/nethack/H-locate.lev
-share/nethack/H-start.lev
-share/nethack/K-filla.lev
-share/nethack/K-fillb.lev
-share/nethack/K-goal.lev
-share/nethack/K-locate.lev
-share/nethack/K-start.lev
-share/nethack/P-filla.lev
-share/nethack/P-fillb.lev
-share/nethack/P-goal.lev
-share/nethack/P-locate.lev
-share/nethack/P-start.lev
-share/nethack/R-filla.lev
-share/nethack/R-fillb.lev
-share/nethack/R-goal.lev
-share/nethack/R-locate.lev
-share/nethack/R-start.lev
-share/nethack/S-filla.lev
-share/nethack/S-fillb.lev
-share/nethack/S-goal.lev
-share/nethack/S-locate.lev
-share/nethack/S-start.lev
-share/nethack/T-filla.lev
-share/nethack/T-fillb.lev
-share/nethack/T-goal.lev
-share/nethack/T-locate.lev
-share/nethack/T-start.lev
-share/nethack/V-filla.lev
-share/nethack/V-fillb.lev
-share/nethack/V-goal.lev
-share/nethack/V-locate.lev
-share/nethack/V-start.lev
-share/nethack/W-filla.lev
-share/nethack/W-fillb.lev
-share/nethack/W-goal.lev
-share/nethack/W-locate.lev
-share/nethack/W-start.lev
-share/nethack/air.lev
-share/nethack/asmodeus.lev
-share/nethack/astral.lev
-share/nethack/baalz.lev
-share/nethack/bigrm-1.lev
-share/nethack/bigrm-2.lev
-share/nethack/bigrm-3.lev
-share/nethack/bigrm-4.lev
-share/nethack/bigrm-5.lev
-share/nethack/castle.lev
-share/nethack/cmdhelp
-share/nethack/data
-share/nethack/dungeon
-share/nethack/earth.lev
-share/nethack/fakewiz1.lev
-share/nethack/fakewiz2.lev
-share/nethack/fire.lev
-share/nethack/help
-share/nethack/hh
-share/nethack/history
-share/nethack/juiblex.lev
-share/nethack/knox.lev
-share/nethack/license
-share/nethack/medusa-1.lev
-share/nethack/medusa-2.lev
-share/nethack/minefill.lev
-share/nethack/minend-1.lev
-share/nethack/minend-2.lev
-share/nethack/minetn-1.lev
-share/nethack/minetn-2.lev
-share/nethack/opthelp
-share/nethack/options
-share/nethack/oracle.lev
-share/nethack/oracles
-share/nethack/orcus.lev
-share/nethack/quest.dat
-share/nethack/rumors
-share/nethack/sanctum.lev
-share/nethack/tower1.lev
-share/nethack/tower2.lev
-share/nethack/tower3.lev
-share/nethack/valley.lev
-share/nethack/water.lev
-share/nethack/wizard1.lev
-share/nethack/wizard2.lev
-share/nethack/wizard3.lev
-share/nethack/wizhelp
+%%DATADIR%%/nethack
+@exec mkdir %D/%%DATADIR%%/save
+@exec chmod -R 775 %D/%%DATADIR%%
+@exec chmod 2755 %D/%%DATADIR%%/nethack
+@exec chown games:games %D/%%DATADIR%%/save
+@unexec rmdir %D/%%DATADIR%%/save 2>/dev/null || true
+%%PORTDOCS%%%%DOCSDIR%%/Guidebook.txt
+%%DATADIR%%/pet_mark.xbm
+%%DATADIR%%/rip.xpm
+%%DATADIR%%/x11tiles
+%%DATADIR%%/A-filla.lev
+%%DATADIR%%/A-fillb.lev
+%%DATADIR%%/A-goal.lev
+%%DATADIR%%/A-locate.lev
+%%DATADIR%%/A-start.lev
+%%DATADIR%%/B-filla.lev
+%%DATADIR%%/B-fillb.lev
+%%DATADIR%%/B-goal.lev
+%%DATADIR%%/B-locate.lev
+%%DATADIR%%/B-start.lev
+%%DATADIR%%/C-filla.lev
+%%DATADIR%%/C-fillb.lev
+%%DATADIR%%/C-goal.lev
+%%DATADIR%%/C-locate.lev
+%%DATADIR%%/C-start.lev
+%%DATADIR%%/E-filla.lev
+%%DATADIR%%/E-fillb.lev
+%%DATADIR%%/E-goal.lev
+%%DATADIR%%/E-locate.lev
+%%DATADIR%%/E-start.lev
+%%DATADIR%%/H-filla.lev
+%%DATADIR%%/H-fillb.lev
+%%DATADIR%%/H-goal.lev
+%%DATADIR%%/H-locate.lev
+%%DATADIR%%/H-start.lev
+%%DATADIR%%/K-filla.lev
+%%DATADIR%%/K-fillb.lev
+%%DATADIR%%/K-goal.lev
+%%DATADIR%%/K-locate.lev
+%%DATADIR%%/K-start.lev
+%%DATADIR%%/P-filla.lev
+%%DATADIR%%/P-fillb.lev
+%%DATADIR%%/P-goal.lev
+%%DATADIR%%/P-locate.lev
+%%DATADIR%%/P-start.lev
+%%DATADIR%%/R-filla.lev
+%%DATADIR%%/R-fillb.lev
+%%DATADIR%%/R-goal.lev
+%%DATADIR%%/R-locate.lev
+%%DATADIR%%/R-start.lev
+%%DATADIR%%/S-filla.lev
+%%DATADIR%%/S-fillb.lev
+%%DATADIR%%/S-goal.lev
+%%DATADIR%%/S-locate.lev
+%%DATADIR%%/S-start.lev
+%%DATADIR%%/T-filla.lev
+%%DATADIR%%/T-fillb.lev
+%%DATADIR%%/T-goal.lev
+%%DATADIR%%/T-locate.lev
+%%DATADIR%%/T-start.lev
+%%DATADIR%%/V-filla.lev
+%%DATADIR%%/V-fillb.lev
+%%DATADIR%%/V-goal.lev
+%%DATADIR%%/V-locate.lev
+%%DATADIR%%/V-start.lev
+%%DATADIR%%/W-filla.lev
+%%DATADIR%%/W-fillb.lev
+%%DATADIR%%/W-goal.lev
+%%DATADIR%%/W-locate.lev
+%%DATADIR%%/W-start.lev
+%%DATADIR%%/air.lev
+%%DATADIR%%/asmodeus.lev
+%%DATADIR%%/astral.lev
+%%DATADIR%%/baalz.lev
+%%DATADIR%%/bigrm-1.lev
+%%DATADIR%%/bigrm-2.lev
+%%DATADIR%%/bigrm-3.lev
+%%DATADIR%%/bigrm-4.lev
+%%DATADIR%%/bigrm-5.lev
+%%DATADIR%%/castle.lev
+%%DATADIR%%/cmdhelp
+%%DATADIR%%/data
+%%DATADIR%%/dungeon
+%%DATADIR%%/earth.lev
+%%DATADIR%%/fakewiz1.lev
+%%DATADIR%%/fakewiz2.lev
+%%DATADIR%%/fire.lev
+%%DATADIR%%/help
+%%DATADIR%%/hh
+%%DATADIR%%/history
+%%DATADIR%%/juiblex.lev
+%%DATADIR%%/knox.lev
+%%DATADIR%%/license
+%%DATADIR%%/medusa-1.lev
+%%DATADIR%%/medusa-2.lev
+%%DATADIR%%/minefill.lev
+%%DATADIR%%/minend-1.lev
+%%DATADIR%%/minend-2.lev
+%%DATADIR%%/minetn-1.lev
+%%DATADIR%%/minetn-2.lev
+%%DATADIR%%/opthelp
+%%DATADIR%%/options
+%%DATADIR%%/oracle.lev
+%%DATADIR%%/oracles
+%%DATADIR%%/orcus.lev
+%%DATADIR%%/quest.dat
+%%DATADIR%%/recover
+%%DATADIR%%/rumors
+%%DATADIR%%/sanctum.lev
+%%DATADIR%%/tower1.lev
+%%DATADIR%%/tower2.lev
+%%DATADIR%%/tower3.lev
+%%DATADIR%%/valley.lev
+%%DATADIR%%/water.lev
+%%DATADIR%%/wizard1.lev
+%%DATADIR%%/wizard2.lev
+%%DATADIR%%/wizard3.lev
+%%DATADIR%%/wizhelp
@mode 664
-share/nethack/logfile
-share/nethack/record
-share/nethack/perm
-@dirrm share/nethack
-%%PORTDOCS%%@dirrm share/doc/nethack
+%%DATADIR%%/logfile
+%%DATADIR%%/record
+%%DATADIR%%/perm
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%