aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-26 14:56:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-26 14:56:09 +0000
commitdc8eed9a2ee617db9d8d4a81f0de17039021b58f (patch)
treea1e787a84da170eeb69a111fb4c93351137e605f /games/nethack34/Makefile
parentb5bd0897dd9063faeb34d5231c813a704d8c818b (diff)
Notes
Diffstat (limited to 'games/nethack34/Makefile')
-rw-r--r--games/nethack34/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 804eb7d53021..74ace8a5488f 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -45,10 +45,11 @@ GRAPHICS= GNOME_GRAPHICS
.elif ${PKGNAMESUFFIX} == "-nox11"
GRAPHICS= # none
.if defined(WITH_MENUCOLORS)
-PATCHFILES+= nh343-menucolor.diff
-PATCH_SITES+= ${MASTER_SITE_LOCAL:S|%SUBDIR%|glewis|}
+PATCHFILES+= nh343-menucolor_jilles.diff
+PATCH_SITES+= http://www.stack.nl/~jilles/games/ \
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|glewis|}
PATCH_DIST_STRIP= -p1
-MAKE_ENV+= LIBTTY="-lgnuregex"
+CFLAGS+= -DMENU_COLOR_REGEX_POSIX
.endif
.elif ${PKGNAMESUFFIX} == "-qt"
USE_QT_VER= 3
@@ -61,15 +62,6 @@ GRAPHICS= QT_GRAPHICS
.include <bsd.port.pre.mk>
-# FreeBSD 5.2.1-RELEASE (or, well, almost) and above use include/gnu/regex.h
-# while prior releases use include/gnuregex.h. This simply gets rid of the
-# repetitive warning during the build process on 5.x.
-.if ${OSVERSION} >= 502010
-GNU_REGEX_H= <gnu/regex.h>
-.else
-GNU_REGEX_H= <gnuregex.h>
-.endif
-
pre-everything::
@if [ "${PKGBASE}" != "nethack" ]; then \
${ECHO_MSG} "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" ; \
@@ -82,18 +74,14 @@ pre-everything::
post-patch:
.for f in include/config.h sys/unix/Makefile.src sys/unix/Makefile.top
- ${REINPLACE_CMD} -e 's|%%HACKNAME%%|${HACKNAME}|g;s|%%HACKDIR%%|${PREFIX}/${HACKDIR}|g' ${WRKSRC}/${f}
+ @${REINPLACE_CMD} -e 's|%%HACKNAME%%|${HACKNAME}|g;s|%%HACKDIR%%|${PREFIX}/${HACKDIR}|g' ${WRKSRC}/${f}
.endfor
- ${REINPLACE_CMD} -e 's|<regex.h>|${GNU_REGEX_H}|g' ${WRKSRC}/src/sounds.c
- ${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/win/Qt/qt_win.cpp
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' ${WRKSRC}/win/Qt/qt_win.cpp
.if defined(WITHOUT_SHELL)
- ${REINPLACE_CMD} -e 's|#define SHELL|/* #define SHELL|' ${WRKSRC}/include/unixconf.h
-.endif
-.if defined(WITH_MENUCOLORS)
- ${REINPLACE_CMD} -e 's|<regex.h>|${GNU_REGEX_H}|g' ${WRKSRC}/include/color.h
+ @${REINPLACE_CMD} -e 's|#define SHELL|/* #define SHELL|' ${WRKSRC}/include/unixconf.h
.endif
.if defined(WITH_MAIL)
- ${REINPLACE_CMD} -e 's|/\* #define MAIL \*/|#define MAIL|' ${WRKSRC}/include/unixconf.h
+ @${REINPLACE_CMD} -e 's|/\* #define MAIL \*/|#define MAIL|' ${WRKSRC}/include/unixconf.h
.endif
pre-configure: