aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-07-25 00:25:21 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-07-25 00:25:21 +0000
commit1cc68d4767b344835fed68826ecfb7a61000d9de (patch)
treee8e4e89aa686151fa884725bf1957a724573613b /games/nethack34/Makefile
parent5ec4d82dc1e5c5a026a8b88f82db760d9c8268bc (diff)
downloadports-1cc68d4767b344835fed68826ecfb7a61000d9de.tar.gz
ports-1cc68d4767b344835fed68826ecfb7a61000d9de.zip
Notes
Diffstat (limited to 'games/nethack34/Makefile')
-rw-r--r--games/nethack34/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 338f696345e9..468d6111997a 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -45,16 +45,30 @@ MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GRAPHICS= GNOME_GRAPHICS
.elif ${PKGNAMESUFFIX} == "-nox11"
GRAPHICS= # none
+#
+# Patch notes:
+# 1) hpmon and statuscolors conflict with one another
+# 2) menucolors patch must be applied before statuscolors
+#
+.if defined(WITH_HPMON) && defined(WITH_STATUSCOLORS)
+IGNORE= you cannot enable both HPMON and STATUSCOLORS
+.endif
.if defined(WITH_MENUCOLORS)
PATCHFILES+= nh343-menucolor.diff
PATCH_SITES+= http://bilious.homelinux.org/~paxed/nethack/
PATCH_DIST_STRIP= -p1
CFLAGS+= -DMENU_COLOR_REGEX_POSIX
.endif
+.if defined(WITH_STATUSCOLORS)
+PATCHFILES+= nh343-statuscolors.fixed.patch
+PATCH_SITES+= http://jdc.parodius.com/nethack/ \
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|wxs|}
+PATCH_DIST_STRIP= -p1
+.endif
.if defined(WITH_HPMON)
PATCHFILES+= hpmon.diff
PATCH_SITES+= http://www.netsonic.fi/~walker/nh/ \
- ${MASTER_SITE_LOCAL:S|%SUBDIR%|koitsu|}
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|wxs|}
PATCH_DIST_STRIP= -p1
CFLAGS+= -DHPMON
.endif