aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
commit93872f18cc0a948ab9c010bbe5694579bd59f8c4 (patch)
tree918c0e1660ed837a4087b57670a1b1c181c285e0 /games/nethack34/Makefile
parentd7568468f977aa272698f2ab9e7164f2a52b0ad5 (diff)
downloadports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.tar.gz
ports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.zip
Notes
Diffstat (limited to 'games/nethack34/Makefile')
-rw-r--r--games/nethack34/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index b1e4bc6f70bb..8d19ede9e6ca 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -33,8 +33,6 @@ HACKNAME?= nethack
HACKDIR?= lib/${HACKNAME}
HACKDOCSDIR?= share/doc/${HACKNAME}
-.include <bsd.port.pre.mk>
-
.if defined(WITH_GNOME_GRAPHICS)
CATEGORIES= games gnome
PKGNAMESUFFIX= -gnome
@@ -43,9 +41,6 @@ USE_GNOME= gnomelibs
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GRAPHICS= GNOME_GRAPHICS
.elif defined(WITH_QT_GRAPHICS)
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
PKGNAMESUFFIX= -qt
USE_QT_VER= 3
MAKE_ENV+= QTCPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
@@ -59,6 +54,12 @@ USE_XPM= yes
GRAPHICS= X11_GRAPHICS
.endif
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QT_GRAPHICS) && ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-everything::
.if defined(WITH_GNOME_GRAPHICS) || defined(WITH_QT_GRAPHICS) \
|| defined(WITH_TTY_GRAPHICS) || defined(WITHOUT_X11)