aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 09:25:33 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 09:25:33 +0000
commit10161fd7fbebb49987f2ee9b47fb2a8cf0ac5b1c (patch)
treec787d49c70ce54c0db09143c1e3e622d6e9d18ed /games/nethack34
parent1a9f6ed88d8b90b4c47df629449e32064cc9260b (diff)
x11/xterm: document ncurses requirement (USES+=ncurses), plus ...
In addition to adding USES+= ncurses: * specify libncurses instead of ancient libtermcap (which is symlinked to libncurses anyway on FreeBSD base) * Bring in USES+= alias from dports while here approved by: infrastructure blanket
Notes
Notes: svn path=/head/; revision=407597
Diffstat (limited to 'games/nethack34')
-rw-r--r--games/nethack34/Makefile2
-rw-r--r--games/nethack34/files/patch-sys-unix-Makefile.src21
2 files changed, 14 insertions, 9 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 0f24745daa7a..1dabeb3d2537 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -18,7 +18,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${TRUEPORTNAME}-${PORTVERSION}
-USES= gmake tar:tgz
+USES= alias gmake ncurses tar:tgz
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
diff --git a/games/nethack34/files/patch-sys-unix-Makefile.src b/games/nethack34/files/patch-sys-unix-Makefile.src
index e6298b7408c8..e92c1cb62531 100644
--- a/games/nethack34/files/patch-sys-unix-Makefile.src
+++ b/games/nethack34/files/patch-sys-unix-Makefile.src
@@ -1,6 +1,6 @@
---- sys/unix/Makefile.src.orig 2003-12-07 15:39:13.000000000 -0800
-+++ sys/unix/Makefile.src 2015-12-27 14:18:55.720804000 -0800
-@@ -146,19 +146,29 @@
+--- sys/unix/Makefile.src.orig 2003-12-07 23:39:13 UTC
++++ sys/unix/Makefile.src
+@@ -146,19 +146,29 @@ SYSOBJ = ioctl.o unixmain.o unixtty.o un
# directories. The ones given below is the usual spot for linux systems.
# The paths are for glibconfig.h and gnomesupport.h respectively.
#
@@ -34,7 +34,7 @@
#LINK=g++
# For cross-compiling, eg. with gcc on Linux (see also CC further up):
#CXX=arm-linux-g++
-@@ -215,7 +225,26 @@
+@@ -215,7 +225,26 @@ WINBEOBJ =
#
#
WINSRC = $(WINTTYSRC)
@@ -61,7 +61,12 @@
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -235,19 +264,19 @@
+@@ -231,23 +260,23 @@ WINOBJ = $(WINTTYOBJ)
+ # WINTTYLIB = -lcurses
+ # WINTTYLIB = -lcurses16
+ # WINTTYLIB = -lncurses
+-WINTTYLIB = -ltermlib
++WINTTYLIB = -lncurses
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
@@ -84,7 +89,7 @@
#
# libraries for Gem port
WINGEMLIB = -le_gem -lgem
-@@ -256,6 +285,15 @@
+@@ -256,6 +285,15 @@ WINGEMLIB = -le_gem -lgem
WINBELIB = -lbe
WINLIB = $(WINTTYLIB)
@@ -100,7 +105,7 @@
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
-@@ -285,7 +323,7 @@
+@@ -285,7 +323,7 @@ WINLIB = $(WINTTYLIB)
LIBS =
# make NetHack
@@ -109,7 +114,7 @@
# GAME = nethack.prg
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
-@@ -461,13 +499,13 @@
+@@ -461,13 +499,13 @@ objects.o:
# Qt windowport meta-object-compiler output
qt_kde0.moc: ../include/qt_kde0.h