aboutsummaryrefslogtreecommitdiff
path: root/games/netpanzer
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-12 14:11:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-12 14:11:49 +0000
commitca856aea5f32e483db28f9ebcfa4a836443b69a2 (patch)
treeddb5ecf525ea7076bd3dce3693c4457ca13150d8 /games/netpanzer
parenta78f3d10e8b2d8bf349b7d87b50e2b5e0d3cf989 (diff)
downloadports-ca856aea5f32e483db28f9ebcfa4a836443b69a2.tar.gz
ports-ca856aea5f32e483db28f9ebcfa4a836443b69a2.zip
Add netpanzer, multiplayer, fast paced, tactical, isometric tank warfare game.
PR: ports/67791 Submitted by: Guido Falsi <mad@madpilot.net>
Notes
Notes: svn path=/head/; revision=111338
Diffstat (limited to 'games/netpanzer')
-rw-r--r--games/netpanzer/Makefile43
-rw-r--r--games/netpanzer/distinfo2
-rw-r--r--games/netpanzer/files/patch-src-ServerBrowser-Main.cpp11
-rw-r--r--games/netpanzer/pkg-descr8
-rw-r--r--games/netpanzer/pkg-plist6
5 files changed, 70 insertions, 0 deletions
diff --git a/games/netpanzer/Makefile b/games/netpanzer/Makefile
new file mode 100644
index 000000000000..b187ef566d91
--- /dev/null
+++ b/games/netpanzer/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: netpanzer
+# Date created: 29 May 2004
+# Whom: Guido Falsi <mad@madpilot.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netpanzer
+PORTVERSION= 0.1.5
+CATEGORIES= games
+MASTER_SITES= http://download.berlios.de/netpanzer/
+
+MAINTAINER= mad@madpilot.net
+COMMENT= Real time, isometric view, tank strategy game(multiplayer)
+
+LIB_DEPENDS= physfs-1.0.0:${PORTSDIR}/devel/physfs
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+RUN_DEPENDS= ${X11BASE}/share/netpanzer/wads/netp.act:${PORTSDIR}/games/netpanzerdata
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-libphysfs=${LOCALBASE} --without-wx-config
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_SDL= sdl net mixer image ttf
+USE_GNOME= libxml2
+USE_REINPLACE= yes
+USE_GCC= 3.3
+
+post-patch:
+ @for ff in `${FIND} ${WRKDIR} -type f -name '*.[ch]pp' -exec ${GREP} -q stdint.h {} \; -print`; do \
+ ${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' $${ff}; \
+ done
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} jam)
+
+do-install:
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} jam ${INSTALL_TARGET})
+
+.include <bsd.port.mk>
diff --git a/games/netpanzer/distinfo b/games/netpanzer/distinfo
new file mode 100644
index 000000000000..5439e506b9fe
--- /dev/null
+++ b/games/netpanzer/distinfo
@@ -0,0 +1,2 @@
+MD5 (netpanzer-0.1.5.tar.bz2) = 6ffd1d301362d9a2bd9b1f77fa09ed67
+SIZE (netpanzer-0.1.5.tar.bz2) = 396395
diff --git a/games/netpanzer/files/patch-src-ServerBrowser-Main.cpp b/games/netpanzer/files/patch-src-ServerBrowser-Main.cpp
new file mode 100644
index 000000000000..39cd93827a54
--- /dev/null
+++ b/games/netpanzer/files/patch-src-ServerBrowser-Main.cpp
@@ -0,0 +1,11 @@
+--- src/ServerBrowser/Main.cpp.orig Mon May 31 21:24:01 2004
++++ src/ServerBrowser/Main.cpp Mon May 31 21:24:44 2004
+@@ -16,7 +16,7 @@
+ srand(time(0));
+
+ BrowserConfig* config = new BrowserConfig;
+- config->ircserver = "irc.freenode.net";
++ config->ircserver = "irc.quakenet.org";
+ config->connect_timeout = 20;
+ config->query_timeout = 20;
+
diff --git a/games/netpanzer/pkg-descr b/games/netpanzer/pkg-descr
new file mode 100644
index 000000000000..fe0c70f696ba
--- /dev/null
+++ b/games/netpanzer/pkg-descr
@@ -0,0 +1,8 @@
+netPanzer is an online multiplayer tactical warfare game designed
+for FAST ACTION combat. Gameplay concentrates on the core -- no
+resource management is needed. The game is based on quick tactical
+action and unit management in real-time. Battles progress quickly
+and constantly as destroyed players respawn with a set of new units.
+Players can join or leave multiplayer games at any time.
+
+WWW: http://netpanzer.berlios.de/
diff --git a/games/netpanzer/pkg-plist b/games/netpanzer/pkg-plist
new file mode 100644
index 000000000000..6f4c5aaf88fc
--- /dev/null
+++ b/games/netpanzer/pkg-plist
@@ -0,0 +1,6 @@
+bin/netpanzer
+bin/netpanzerbrowser
+share/pixmaps/netpanzer/netpanzer.png
+share/pixmaps/netpanzer/netpanzer.xpm
+@dirrm share/pixmaps/netpanzer
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true