aboutsummaryrefslogtreecommitdiff
path: root/games/nil
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:37:58 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-01 13:37:58 +0000
commit89b8699dbeacd40e5a746500e2907adaccc65de6 (patch)
tree54d34c9267a27e7b96bbe1bffc5f44023d056b2b /games/nil
parent35516e70f75e62be6f3dfa3a4a6a3c40cd6e420e (diff)
Notes
Diffstat (limited to 'games/nil')
-rw-r--r--games/nil/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 3f79792f03f0..813c2c7ef452 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -22,9 +22,10 @@ USE_GMAKE= yes
USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
-OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT=OPTIMIZED_CFLAGS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "ia64"
BROKEN= does not link on ${ARCH}
@@ -37,7 +38,7 @@ post-patch:
s|sdl-config|${SDL_CONFIG}|'
@${REINPLACE_CMD} -e 's|\.\./data|${DATADIR}|' \
${WRKSRC}/src/common/configuration/configuration.cpp
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
@${REINPLACE_CMD} -e 's|\(--subcall\)|\1 --enable-optimize|' \
${WRKSRC}/configure
.endif
@@ -51,4 +52,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/docs/HOWTO ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>