aboutsummaryrefslogtreecommitdiff
path: root/games/nlarn
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-03-28 15:40:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-03-28 15:40:51 +0000
commit6c6cdf95b4984c625eb219505592bb7690d3bb20 (patch)
treea2d33e3985d88aefb26eb66ea9c5b37a49c78ca6 /games/nlarn
parentf1a8d5595e7b2e56979eb8719b6313bb258e85fd (diff)
downloadports-6c6cdf95b4984c625eb219505592bb7690d3bb20.tar.gz
ports-6c6cdf95b4984c625eb219505592bb7690d3bb20.zip
Notes
Diffstat (limited to 'games/nlarn')
-rw-r--r--games/nlarn/Makefile21
-rw-r--r--games/nlarn/distinfo4
-rw-r--r--games/nlarn/files/patch-Makefile27
-rw-r--r--games/nlarn/files/patch-premake4.lua19
-rw-r--r--games/nlarn/files/patch-src-game.c11
-rw-r--r--games/nlarn/pkg-plist1
6 files changed, 44 insertions, 39 deletions
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
index a9c4616023a3..cf258e5d112f 100644
--- a/games/nlarn/Makefile
+++ b/games/nlarn/Makefile
@@ -1,12 +1,8 @@
-# Ports collection makefile for: games/nlarn
-# Date created: 2011-11-08
-# Whom: Martin Tournoij <martin@arp242.net>
-#
+# Created by: Martin Tournoij <martin@arp242.net>
# $FreeBSD$
-#
PORTNAME= nlarn
-PORTVERSION= 0.7
+PORTVERSION= 0.7.2
CATEGORIES= games
MASTER_SITES= SF
@@ -15,24 +11,13 @@ COMMENT= Roguelike game and as such a remake of the classic game Larn
LICENSE= GPLv3
-BUILD_DEPENDS= premake4:${PORTSDIR}/devel/premake4
-
-WRKSRC= ${WRKDIR}/jaydg-nlarn-NLarn-${PORTVERSION}.0
USE_LUA= 5.1
USE_GNOME= glib20
USE_PKGCONFIG= build
USE_GMAKE= yes
-do-configure:
- cd ${WRKSRC} && ${LOCALBASE}/bin/premake4 --os=bsd gmake
-
post-configure:
- @${REINPLACE_CMD} 's|$$(ARCH)||g; \
- s|-I${LOCALBASE}|-I${LUA_INCDIR} -I${LOCALBASE}|g; \
- s|-lz|-lz -llua-5.1 -lncurses -lpanel|g;' \
- ${WRKSRC}/nlarn.make
-
- @${REINPLACE_CMD} 's|/usr/share/games/nlarn|${DATADIR}|' \
+ @${REINPLACE_CMD} 's|/usr/share/nlarn|${DATADIR}|' \
${WRKSRC}/src/game.c
do-install:
diff --git a/games/nlarn/distinfo b/games/nlarn/distinfo
index 9baacf8b19ce..f9e7a5946ef4 100644
--- a/games/nlarn/distinfo
+++ b/games/nlarn/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nlarn-0.7.tar.gz) = 21818bbc1691a8a79d3d6ce71934076895c2708725e5a0b431d46dba39e2795a
-SIZE (nlarn-0.7.tar.gz) = 244698
+SHA256 (nlarn-0.7.2.tar.gz) = 291fed77cb80261c5dfd375c702482f4d38415e3ce769b237ac22957d42dfbc8
+SIZE (nlarn-0.7.2.tar.gz) = 813829
diff --git a/games/nlarn/files/patch-Makefile b/games/nlarn/files/patch-Makefile
new file mode 100644
index 000000000000..46ae0a44fe9e
--- /dev/null
+++ b/games/nlarn/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2012-07-06 20:29:35.000000000 +0300
++++ Makefile 2013-03-09 11:15:05.000000000 +0200
+@@ -102,13 +102,13 @@
+ LDFLAGS += $(shell pkg-config --libs glib-2.0)
+
+ # Configuration for ncurses
+- ifeq ($(filter Darwin DragonFly OpenBSD,$(OS)),)
++ ifeq ($(filter Darwin DragonFly FreeBSD OpenBSD,$(OS)),)
+ CFLAGS += $(shell ncurses5-config --cflags)
+ LDFLAGS += $(shell ncurses5-config --libs) -lpanel
+ else
+ # OS X is handled separately
+ ifneq ($(OS), Darwin)
+- # DragonFly and OpenBSD have ncurses in base (and no config tool)
++ # DragonFly, FreeBSD and OpenBSD have ncurses in base (and no config tool)
+ LDFLAGS += -lncurses -lpanel
+ endif
+ endif
+@@ -117,6 +117,8 @@
+ # Debian and derivates use lua5.1, the rest of the world lua
+ ifneq ($(wildcard /etc/debian_version),)
+ lua = lua5.1
++ else ifeq ($(OS), FreeBSD)
++ lua = lua-5.1
+ else
+ lua = lua
+ endif
diff --git a/games/nlarn/files/patch-premake4.lua b/games/nlarn/files/patch-premake4.lua
deleted file mode 100644
index 2aedbfff24ba..000000000000
--- a/games/nlarn/files/patch-premake4.lua
+++ /dev/null
@@ -1,19 +0,0 @@
---- premake4.lua.orig 2011-11-08 23:01:23.000000000 +0100
-+++ premake4.lua 2011-11-08 23:01:44.000000000 +0100
-@@ -75,12 +75,11 @@
- -- Add configuration for Lua
- -- Debian and Ubuntu have a specific naming convention for the lua
- -- package; fortunately it can be configured with pkg-config
-- if os.is("linux") and (get_linux_distribution() == "Debian"
-- or get_linux_distribution() == "Ubuntu")
-+ if os.is("bsd")
- then
-- includedirs { get_dirs("include", "lua5.1") }
-- links { "lua5.1" }
-- libdirs { get_dirs("lib", "lua5.1") }
-+ includedirs { get_dirs("include", "lua-5.1") }
-+ links { "lua-5.1" }
-+ libdirs { get_dirs("lib", "lua-5.1") }
- else
- includedirs { get_dirs("include", "lua") }
- links { "lua" }
diff --git a/games/nlarn/files/patch-src-game.c b/games/nlarn/files/patch-src-game.c
new file mode 100644
index 000000000000..c52667d57f1b
--- /dev/null
+++ b/games/nlarn/files/patch-src-game.c
@@ -0,0 +1,11 @@
+--- src/game.c.orig 2012-07-06 20:29:35.000000000 +0300
++++ src/game.c 2013-03-09 12:23:13.000000000 +0200
+@@ -1353,7 +1354,7 @@
+ if (sb == NULL)
+ {
+ /* opening the file failed */
+- log_add_entry(g->log, "Error opening scoreboard file \"%s\".");
++ log_add_entry(g->log, "Error opening scoreboard file.");
+ free(uscores);
+ return;
+ }
diff --git a/games/nlarn/pkg-plist b/games/nlarn/pkg-plist
index 4b86b8e67624..0963d45faa1f 100644
--- a/games/nlarn/pkg-plist
+++ b/games/nlarn/pkg-plist
@@ -4,6 +4,7 @@ bin/nlarn
%%DATADIR%%/maze
%%DATADIR%%/maze_doc.txt
%%DATADIR%%/monsters.lua
+%%DATADIR%%/nlarn-128.bmp
%%DATADIR%%/nlarn.hlp
%%DATADIR%%/nlarn.ini-sample
%%DATADIR%%/nlarn.msg