aboutsummaryrefslogtreecommitdiff
path: root/games/nlarn
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-28 10:29:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-28 10:29:36 +0000
commitd4825fa7da631d54d1f67ffbd89dad45ea4724e7 (patch)
treeeca36de03101797d15c6adc0f89f8e15bb263f6e /games/nlarn
parent10dc9e478522e81c02cfbe1a7a07aa8f0a66a0fe (diff)
NLarn is a roguelike game and as such a remake of the classic game Larn.
Very noticeable differences to the original so far include: - advanced user interface - extremely different item handling - extended monster AI - a real town - colour WWW: http://nlarn.sourceforge.net/ PR: ports/162393 Submitted by: Martin Tournoij <martin@arp242.net>
Notes
Notes: svn path=/head/; revision=289927
Diffstat (limited to 'games/nlarn')
-rw-r--r--games/nlarn/Makefile42
-rw-r--r--games/nlarn/distinfo2
-rw-r--r--games/nlarn/files/patch-premake4.lua19
-rw-r--r--games/nlarn/pkg-descr11
-rw-r--r--games/nlarn/pkg-plist10
5 files changed, 84 insertions, 0 deletions
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
new file mode 100644
index 000000000000..d5f0c7bd9c0a
--- /dev/null
+++ b/games/nlarn/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: games/nlarn
+# Date created: 2011-11-08
+# Whom: Martin Tournoij <martin@arp242.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nlarn
+PORTVERSION= 0.7
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= martin@arp242.net
+COMMENT= Roguelike game and as such a remake of the classic game Larn
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= premake4:${PORTSDIR}/devel/premake4
+
+WRKSRC= ${WRKDIR}/jaydg-nlarn-NLarn-${PORTVERSION}.0
+USE_LUA= 5.1
+USE_GNOME= glib20
+USE_GMAKE= yes
+
+do-configure:
+ cd ${WRKSRC} && ${LOCALBASE}/bin/premake4 --os=bsd gmake
+
+post-configure:
+ @${REINPLACE_CMD} 's|$$(ARCH)||g; \
+ s|-I${LOCALBASE}|-I${LUA_INCDIR} -I${LOCALBASE}|g; \
+ s|-lz|-lz -llua-5.1 -lncurses -lpanel|g;' \
+ ${WRKSRC}/nlarn.make
+
+ @${REINPLACE_CMD} 's|/usr/share/games/nlarn|${DATADIR}|' \
+ ${WRKSRC}/src/game.c
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/games/nlarn/distinfo b/games/nlarn/distinfo
new file mode 100644
index 000000000000..9baacf8b19ce
--- /dev/null
+++ b/games/nlarn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nlarn-0.7.tar.gz) = 21818bbc1691a8a79d3d6ce71934076895c2708725e5a0b431d46dba39e2795a
+SIZE (nlarn-0.7.tar.gz) = 244698
diff --git a/games/nlarn/files/patch-premake4.lua b/games/nlarn/files/patch-premake4.lua
new file mode 100644
index 000000000000..2aedbfff24ba
--- /dev/null
+++ b/games/nlarn/files/patch-premake4.lua
@@ -0,0 +1,19 @@
+--- premake4.lua.orig 2011-11-08 23:01:23.000000000 +0100
++++ premake4.lua 2011-11-08 23:01:44.000000000 +0100
+@@ -75,12 +75,11 @@
+ -- Add configuration for Lua
+ -- Debian and Ubuntu have a specific naming convention for the lua
+ -- package; fortunately it can be configured with pkg-config
+- if os.is("linux") and (get_linux_distribution() == "Debian"
+- or get_linux_distribution() == "Ubuntu")
++ if os.is("bsd")
+ then
+- includedirs { get_dirs("include", "lua5.1") }
+- links { "lua5.1" }
+- libdirs { get_dirs("lib", "lua5.1") }
++ includedirs { get_dirs("include", "lua-5.1") }
++ links { "lua-5.1" }
++ libdirs { get_dirs("lib", "lua-5.1") }
+ else
+ includedirs { get_dirs("include", "lua") }
+ links { "lua" }
diff --git a/games/nlarn/pkg-descr b/games/nlarn/pkg-descr
new file mode 100644
index 000000000000..445bc64646b1
--- /dev/null
+++ b/games/nlarn/pkg-descr
@@ -0,0 +1,11 @@
+NLarn is a roguelike game and as such a remake of the classic game Larn.
+
+Very noticeable differences to the original so far include:
+
+ - advanced user interface
+ - extremely different item handling
+ - extended monster AI
+ - a real town
+ - colour
+
+WWW: http://nlarn.sourceforge.net/
diff --git a/games/nlarn/pkg-plist b/games/nlarn/pkg-plist
new file mode 100644
index 000000000000..4b86b8e67624
--- /dev/null
+++ b/games/nlarn/pkg-plist
@@ -0,0 +1,10 @@
+bin/nlarn
+%%DATADIR%%/README.txt
+%%DATADIR%%/fortune
+%%DATADIR%%/maze
+%%DATADIR%%/maze_doc.txt
+%%DATADIR%%/monsters.lua
+%%DATADIR%%/nlarn.hlp
+%%DATADIR%%/nlarn.ini-sample
+%%DATADIR%%/nlarn.msg
+@dirrm %%DATADIR%%