aboutsummaryrefslogtreecommitdiff
path: root/games/nlarn
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:28:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 15:28:28 +0000
commite836ab008ac38916a93472f2840e03e2e8470ef5 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /games/nlarn
parent35d8b48dff5490ff5d7232109c287da637b58811 (diff)
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=355360
Diffstat (limited to 'games/nlarn')
-rw-r--r--games/nlarn/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/games/nlarn/Makefile b/games/nlarn/Makefile
index 3a06201d695c..2e7d1be18233 100644
--- a/games/nlarn/Makefile
+++ b/games/nlarn/Makefile
@@ -11,19 +11,16 @@ COMMENT= Roguelike game and as such a remake of the classic game Larn
LICENSE= GPLv3
-USES= pkgconfig
-USE_LUA= 5.1
+USES= gmake lua pkgconfig
USE_GNOME= glib20
-USE_GMAKE= yes
-NO_STAGE= yes
post-configure:
@${REINPLACE_CMD} 's|/usr/share/nlarn|${DATADIR}|' \
${WRKSRC}/src/game.c
do-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${DATADIR}/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/nlarn ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${WRKSRC}/nlarn.ini-sample ${WRKSRC}/lib/* ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>